Furnace bug

Post Reply
User avatar
czahrte
Member
Posts: 10
Joined: Sat Jun 23, 2012 05:00
Location: Kentucky, USA

Furnace bug

by czahrte » Post

Bug: I filled up my furnace output area with finished products (99 items in each) and suddenly the game started crashing it directed me to /minetestgame/mods/default/init.lua line: 1411 unable to concatenate string "item" (this may not be the exact message but it has all the pertinent info i believe) i commented out that section and was able to get back into the game to remove the items from the furnace then uncommented the code and continued playing.

Glitch: i have a stack of dirt on one of my maps t hat i had discarded at one time now it wont go away and each time i try to pick it up it gives me 41 dirt and gave a warning about a "static object" now each time i click on it it says:
singleplayer punched object 1 at [location],
singleplayer punched object 2 at [location],
singleplayer punched object 3 at [location]
Etc. etc.

Great game btw hope i can help out some more ^^
(sorry about not getting the verbatim warning messages i didn't think about it when the happened)
Benson... Dear Benson... you are so mercifully free of the ravages of intelligence. - Evil
Do or Do not, there is no 'try' - Yoda
if it's broke, hit it with a hammer. if that don't fix it, get a bigger hammer. - Me

User avatar
LolManKuba
Member
Posts: 939
Joined: Fri Feb 10, 2012 22:36
Location: Ontario, Canada
Contact:

by LolManKuba » Post

Debug.txt?

User avatar
czahrte
Member
Posts: 10
Joined: Sat Jun 23, 2012 05:00
Location: Kentucky, USA

by czahrte » Post

Oops.... didnt think of that

Furnace bug:
02:13:01: ERROR[main]: ServerError: LuaError: error: ...est\bin\..\games\minetest_game\mods\default\init.lua:1411: attempt to concatenate field 'item' (a userdata value)
02:13:01: ERROR[main]: stack traceback:

Glitch:
02:51:42: ERROR[main]: ServerEnvironment::deactivateFarObjects(): id=53 m_static_exists=true but static data doesn't actually exist in (0,-7,0)
WARNING: StaticObjectList::remove(): id=53 not found
02:51:42: VERBOSE[main]: ServerEnvironment::deactivateFarObjects(): object id=53 is not known by clients; deleting
02:51:42: VERBOSE[main]: scriptapi_luaentity_rm: id=53
02:51:42: VERBOSE[main]: ServerEnvironment::deactivateFarObjects(): deactivating object id=55 on inactive block (0,-5,0)
02:51:42: VERBOSE[main]: getStaticData
02:51:42: ERROR[main]: ServerEnvironment::deactivateFarObjects(): id=55 m_static_exists=true but static data doesn't actually exist in (0,-5,0)
WARNING: StaticObjectList::remove(): id=55 not found
02:51:42: VERBOSE[main]: ServerEnvironment::deactivateFarObjects(): object id=55 is not known by clients; deleting
02:51:42: VERBOSE[main]: scriptapi_luaentity_rm: id=55
Benson... Dear Benson... you are so mercifully free of the ravages of intelligence. - Evil
Do or Do not, there is no 'try' - Yoda
if it's broke, hit it with a hammer. if that don't fix it, get a bigger hammer. - Me

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests