[Solved]mod.conf file seems broken [Windows-DEV Build]

User avatar
Napiophelios
Member
 
Posts: 972
Joined: Mon Jul 07, 2014 01:14
GitHub: Napiophelios
IRC: Nappi
In-game: Nappi

[Solved]mod.conf file seems broken [Windows-DEV Build]

by Napiophelios » Wed Jan 02, 2019 17:40

Problem:
Mods with dependancies aren't loading when placed in the mods folder.
But when placed in the game's mods folder they work fine, no issues.


I am using Sfan5's latest dev build: minetest-5.0.0-a7025c7-win64.
I am testing with the latest dev Minetest game release from Github.

I would say this is probably an issue with the windows (dev) builds,
stable release works as expected.

Debug.txt (mods in the game's mods folder / new world created = no problems)
Code: Select all
-------------
  Separator
-------------

2019-01-02 12:25:50: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:25:50: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:25:50: ACTION[Main]: World at [C:\Users\Napiophelios\Games\Minetest_dev\bin\..\worlds\CCMobs2_test_001]
2019-01-02 12:25:50: ACTION[Main]: Server for gameid="minetest" listening on 0.0.0.0:60494.
2019-01-02 12:25:50: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:25:50: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:25:50: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:25:51: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:25:51: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:25:51: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:25:51: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:25:51: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:25:51: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:25:51: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:25:52: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:25:52: WARNING[Main]: Client side mods are disabled by configuration.
2019-01-02 12:25:54: ACTION[Server]: singleplayer [127.0.0.1] joins game.
2019-01-02 12:25:54: ACTION[Server]: singleplayer joins game. List of players: singleplayer
2019-01-02 12:26:07: ACTION[Main]: Server: Shutting down


Debug.txt (mods in mods folder / new world created = won't load the mods)
Code: Select all
-------------
  Separator
-------------

2019-01-02 12:26:50: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:26:50: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:26:50: ERROR[Main]: The following mods could not be found: "mobs_redo"
2019-01-02 12:26:50: ERROR[Main]: mod "ccmobs2" has unsatisfied dependencies:  "mobs"
2019-01-02 12:26:50: ACTION[Main]: World at [C:\Users\Napiophelios\Games\Minetest_dev\bin\..\worlds\CCMobs2_test_002]
2019-01-02 12:26:50: ACTION[Main]: Server for gameid="minetest" listening on 0.0.0.0:54110.
2019-01-02 12:26:50: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:26:50: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:26:51: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:26:51: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:26:51: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:26:51: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:26:52: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:26:52: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:26:52: WARNING[Main]: Irrlicht: PNG warning: Interlace handling should be turned on when using png_read_image
2019-01-02 12:26:53: WARNING[Main]: Client side mods are disabled by configuration.
2019-01-02 12:26:53: ACTION[Server]: singleplayer [127.0.0.1] joins game.
2019-01-02 12:26:53: ACTION[Server]: singleplayer joins game. List of players: singleplayer
2019-01-02 12:26:59: ACTION[Main]: Server: Shutting down
Last edited by Napiophelios on Wed Jan 02, 2019 21:23, edited 3 times in total.
 

User avatar
Napiophelios
Member
 
Posts: 972
Joined: Mon Jul 07, 2014 01:14
GitHub: Napiophelios
IRC: Nappi
In-game: Nappi
 

User avatar
rubenwardy
Moderator
 
Posts: 5681
Joined: Tue Jun 12, 2012 18:11
Location: United Kingdom
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy
 

User avatar
Napiophelios
Member
 
Posts: 972
Joined: Mon Jul 07, 2014 01:14
GitHub: Napiophelios
IRC: Nappi
In-game: Nappi

Re: Issue loading mods [Windows-DEV Build]

by Napiophelios » Wed Jan 02, 2019 20:16

Mobs_Redo folder has a mod.conf file with:
name = mobs

the depends text for my mod also doesn't work
with either mobs or mobs_redo listed.

I will rename any way and see what happens :)

EDIT:
Thanks Ruben that fixed it.
I thought it didn't matter what the folder was named
as long as it had the mod.conf file with the proper name in it.

EDIT2:
mod.conf file seems to no longer function as intended

EDIT3:
Okay apparently the build I am using doesn't have a certain commit that fixes this issue
https://github.com/minetest/minetest/issues/7980
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 3 guests