Graphic performance

bonne
New member
 
Posts: 5
Joined: Sat Jan 26, 2019 12:43

Graphic performance

by bonne » Sun Jan 27, 2019 08:59

Somewhere I read Minetest requirements to indicate "runs on almost any computer".

Well, I have a really old laptop 10 years, and Minetest lags a lot on screen update on this. How to optimize minetest.conf to run smoothly on old laptops with slow, integrated graphic card?

OS is debian 9, graphic card is radeon something oldish

Regards, Lars.
 

User avatar
Festus1965
Member
 
Posts: 931
Joined: Sun Jan 03, 2016 11:58
Location: Thailand - Chiang Mai (+5-6h to MEZ)
In-game: Thomas Explorer

Re: Graphic performance

by Festus1965 » Sun Jan 27, 2019 10:02

I just installed Lubuntu 18.04 on my old asus AIO 2 Core 1.4 GHz 4 GB Ram with integrated CPU GPU.
No special driver found.

Minetest 0.4.16 getting there (with ppa 5.0.0. and cant login other servers) I have
* with shaders on
* view 100 (to reduce that help a lot - just use + or -)
* smooth lightning off
* particles off
* 3d clouds off
* simple leaves
11-15 fps

with
* shaders off
about 16-25 fps, depends on the area view
Last edited by Festus1965 on Sun Jan 27, 2019 10:49, edited 1 time in total.
Server: still up, see some gamer - but there is a new 1st important thread "climate change" for me. Something I know since 1992 - had seen the melting glacier in Switzerland.
 

bonne
New member
 
Posts: 5
Joined: Sat Jan 26, 2019 12:43

Re: Graphic performance

by bonne » Sun Jan 27, 2019 10:21

Seems shaders off helps a lot. What is the syntax for this? Can't find that setting here: https://wiki.minetest.net/Minetest.conf

Regards, Lars.
 

User avatar
Festus1965
Member
 
Posts: 931
Joined: Sun Jan 03, 2016 11:58
Location: Thailand - Chiang Mai (+5-6h to MEZ)
In-game: Thomas Explorer

Re: Graphic performance

by Festus1965 » Sun Jan 27, 2019 10:45

Open Minetest Game
go Settings
Advanced Settings
Open + Client, Grafics, In-Game, Shaders
check if enabled then disable it,
and try again
Server: still up, see some gamer - but there is a new 1st important thread "climate change" for me. Something I know since 1992 - had seen the melting glacier in Switzerland.
 

bonne
New member
 
Posts: 5
Joined: Sat Jan 26, 2019 12:43

Re: Graphic performance

by bonne » Sun Jan 27, 2019 12:11

Ah, found it...:

enable_shaders = 0

Helped a lot, thanks.

How is Chang Mai?

Regards, Lars.
 

User avatar
paramat
Developer
 
Posts: 3448
Joined: Sun Oct 28, 2012 00:05
Location: UK
GitHub: paramat
IRC: paramat

Re: Graphic performance

by paramat » Wed Jan 30, 2019 00:36

Leaves should be 'opaque' not 'simple', makes a big difference.
 


Return to Problems



Who is online

Users browsing this forum: Majestic-12 [Bot] and 1 guest