World Crash When Update to 5.0.0?

User avatar
Arinor_78
New member
 
Posts: 4
Joined: Thu Jan 03, 2019 01:29
Location: North America
IRC: Arinor_78
In-game: Any username with Arinor_ on it

World Crash When Update to 5.0.0?

by Arinor_78 » Mon Mar 11, 2019 22:40

I recently started building a large city in Minetest, and when I updated to 5.0.0, after moving all of my mods and worlds, I tried to open my city, but when I'm "Creating Server," the game exits to my desktop. I tried opening the world in 0.4.17.1, but I get this error message, "A serialization error occurred: ServerEnvironment::loadMeta(): EnvArgsEnd not found! The server is probably running a different version of Minetest." I'm not sure what the problem is, and I'm not a great coder or anything. The world was created in 0.4.17.1, and I don't know why it won't work. Any help would be appreciated, as I don't really want to lose the builds that I spent a month building. Thanks, Arinor_78 :)

UPDATE: This forum is now closed since my world is fixed, Thanks rubenwardy! :)
Last edited by Arinor_78 on Tue Mar 12, 2019 20:07, edited 1 time in total.
My username is just a made-up word with a _ and a number on the end :P
 

User avatar
rubenwardy
Moderator
 
Posts: 5795
Joined: Tue Jun 12, 2012 18:11
Location: United Kingdom
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy

Re: World Crash When Update to 5.0.0?

by rubenwardy » Mon Mar 11, 2019 23:29

Hi, try deleting env_meta.txt in your world folder

If that doesn't work, then it's a bug which has already been fixed and will be fixed in 5.0.1
 

User avatar
Arinor_78
New member
 
Posts: 4
Joined: Thu Jan 03, 2019 01:29
Location: North America
IRC: Arinor_78
In-game: Any username with Arinor_ on it

Re: World Crash When Update to 5.0.0?

by Arinor_78 » Tue Mar 12, 2019 19:51

rubenwardy wrote:Hi, try deleting env_meta.txt in your world folder

If that doesn't work, then it's a bug which has already been fixed and will be fixed in 5.0.1

Ok, Thanks! :)

EDIT: It Worked! Thank you! :D
My username is just a made-up word with a _ and a number on the end :P
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 3 guests