[SOLVED] Minetest 5.0.1 does not start in Lubuntu 19.04

aga_peter
New member
 
Posts: 6
Joined: Fri Aug 30, 2019 17:37
Location: Switzerland

[SOLVED] Minetest 5.0.1 does not start in Lubuntu 19.04

by aga_peter » Fri Aug 30, 2019 17:56

Dear all,

my kids love to play minetest. We never had any problems at home. Now we are running version 5.
We prepared a used notebook ProBook 6540b with Lubuntu 19 and installed 0.4.17 which run great.
Then My kids updated their minetest to 5.01, created a local server and wanted their friends to connect. Unfortunately they were not able to connect because their game is not compatible with the new server. So i installed on the friends computer minetest 5 and when i start it i can see the game window frame which disappears after 1 sec and the game closes (with slow motion video i can see that the window flashes twice and the window title is "unnamed window"). I updated Lubuntu but nothing helped. The notebook has integrated intel graphics.

Any idea?

By the way, my kids have Ubuntu, not Lubuntu and a dedicated graphic card.

thanks
Peter

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 12)


sudo lshw -C video
*-display
description: VGA compatible controller
product: Core Processor Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 12
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:29 memory:d0000000-d03fffff memory:c0000000-cfffffff ioport:3030(size=8) memory:c0000-dffff
Last edited by aga_peter on Sat Aug 31, 2019 19:04, edited 2 times in total.
 

User avatar
Krock
Developer
 
Posts: 4346
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: Minetest 5 does not start / graphics issue

by Krock » Fri Aug 30, 2019 19:12

Please post the results of doing this step: viewtopic.php?p=355723#p355723

Also check whether there are (proprietary) drivers available for this iGPU.
>> Mod Search Engine << - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>
 

aga_peter
New member
 
Posts: 6
Joined: Fri Aug 30, 2019 17:37
Location: Switzerland

Re: Minetest 5 does not start / graphics issue

by aga_peter » Fri Aug 30, 2019 19:52

@Krock

thanks a lot.

Here the results:

Code: Select all
minetest --version
Minetest 5.0.1 (Linux)
Using Irrlicht 1.8.3
BUILD_TYPE=Release
RUN_IN_PLACE=0
USE_GETTEXT=1
USE_SOUND=1
USE_CURL=1
USE_FREETYPE=1
USE_LUAJIT=1
STATIC_SHAREDIR="/share/minetest"


Code: Select all
gdb minetest
(gdb) r
Starting program: /snap/bin/minetest
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7ffff7d54700 (LWP 2218)]
[New Thread 0x7ffff7553700 (LWP 2219)]
[New Thread 0x7ffff6d52700 (LWP 2220)]
[New Thread 0x7ffff6551700 (LWP 2221)]
[New Thread 0x7ffff5d50700 (LWP 2222)]
[New Thread 0x7ffff554f700 (LWP 2223)]
[Detaching after vfork from child process 2224]
[Thread 0x7ffff554f700 (LWP 2223) exited]
[Thread 0x7ffff5d50700 (LWP 2222) exited]
[Thread 0x7ffff6551700 (LWP 2221) exited]
[Thread 0x7ffff6d52700 (LWP 2220) exited]
[Thread 0x7ffff7553700 (LWP 2219) exited]
[Thread 0x7ffff7d54700 (LWP 2218) exited]
process 2214 is executing new program: /snap/core/7396/usr/bin/snap
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7ffff7d54700 (LWP 2226)]
[New Thread 0x7ffff7553700 (LWP 2227)]
[New Thread 0x7ffff6d52700 (LWP 2228)]
[New Thread 0x7ffff6551700 (LWP 2229)]
[New Thread 0x7ffff5d50700 (LWP 2230)]
[New Thread 0x7ffff554f700 (LWP 2231)]
[Detaching after vfork from child process 2232]
[Detaching after vfork from child process 2234]
[Thread 0x7ffff554f700 (LWP 2231) exited]
[Thread 0x7ffff5d50700 (LWP 2230) exited]
[Thread 0x7ffff6551700 (LWP 2229) exited]
[Thread 0x7ffff6d52700 (LWP 2228) exited]
[Thread 0x7ffff7553700 (LWP 2227) exited]
[Thread 0x7ffff7d54700 (LWP 2226) exited]
process 2214 is executing new program: /snap/core/7396/usr/lib/snapd/snap-confine
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
need to run as root or suid
[Inferior 1 (process 2214) exited with code 01]
 

aga_peter
New member
 
Posts: 6
Joined: Fri Aug 30, 2019 17:37
Location: Switzerland
 

User avatar
Krock
Developer
 
Posts: 4346
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: Minetest 5 does not start / graphics issue

by Krock » Sat Aug 31, 2019 08:18

A problem with snap/Ubuntu ("need to run as root or suid"). Uninstall the snap Minetest version, install using apt and retry.
>> Mod Search Engine << - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>
 

aga_peter
New member
 
Posts: 6
Joined: Fri Aug 30, 2019 17:37
Location: Switzerland

Re: Minetest 5 does not start / graphics issue

by aga_peter » Sat Aug 31, 2019 14:38

@Krock

Today I tried other Linux distribution than Lubuntu: Mint and Manjaro, and on both Minetest 5 run successfully without doing anything. And it also works with latest version of Ubuntu. So the problem seems to be Lubuntu specific? But yes, I will try the solution you posted, did not know that there are different ways to install software on linux...

thanks!!!
 

User avatar
Krock
Developer
 
Posts: 4346
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: Minetest 5 does not start / graphics issue

by Krock » Sat Aug 31, 2019 15:05

That just reminded me that the repositories are likely outdated. Here's the PPA link (includes instructions on page): viewtopic.php?p=355768#p355768
>> Mod Search Engine << - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>
 

aga_peter
New member
 
Posts: 6
Joined: Fri Aug 30, 2019 17:37
Location: Switzerland

Re: Minetest 5 does not start / graphics issue

by aga_peter » Sat Aug 31, 2019 19:00

@Krock

you made my day. It works now. I uninstalled minetest within Discover and did following in the terminal:

Code: Select all
sudo add-apt-repository ppa:minetestdevs/stable
sudo apt-get update
sudo apt-get install minetest
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 3 guests