Server crashes

paulvdv
Member
 
Posts: 20
Joined: Sat Sep 22, 2018 11:01

Server crashes

by paulvdv » Sat Aug 31, 2019 18:31

Hello,

I have a public Minetest server and it crashes too often the last time. I guess there is a mod responseable for it, but I don't know which mod. When I look into the logs, it does not become clear to me (and I am an experienced Linux sysadmin). Till now I don't use the debug mode for logging.

How do you advice to look what will be wrong?

I am using Minetest 4.17 from Debian 10: https://packages.debian.org/buster/minetest

It is also possible that somebody does not like the server and does some kind of attack, hmm. Difficult to know what's wrong. No reproduceable problem.

With regards,
Paul
 

paulvdv
Member
 
Posts: 20
Joined: Sat Sep 22, 2018 11:01

Re: Server crashes

by paulvdv » Sat Aug 31, 2019 19:42

I've looked better, and I think I have to find "Runtime errors". I see runtime errors from the mods pyramids, ghost, and zombie. I have disabled pyramids and zombie, and I will disable ghost too when the server does crashes again.
 

User avatar
Krock
Developer
 
Posts: 4346
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: Server crashes

by Krock » Sat Aug 31, 2019 21:08

What kind of runtime errors are those? Please provide the last few relevant lines from your debug.txt file.
>> Mod Search Engine << - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>
 

paulvdv
Member
 
Posts: 20
Joined: Sat Sep 22, 2018 11:01

Re: Server crashes

by paulvdv » Sun Sep 01, 2019 10:13

Krock wrote:What kind of runtime errors are those? Please provide the last few relevant lines from your debug.txt file.


I don't have a debug.txt, but I have a logfile /var/log/minetest/mintest.log. I guess this is the same.

For example this one this morning:

2019-09-01 10:28:06: ERROR[Main]: ServerError: AsyncErr: ServerThread::run Lua: Runtime error from mod 'ghost' in callback LuaABM::trigger(): ...re/games/minetest/mods/mob-engine/creatures/register.lua:498: attempt to index a nil value
2019-09-01 10:28:06: ERROR[Main]: stack traceback:
2019-09-01 10:28:06: ERROR[Main]: ...re/games/minetest/mods/mob-engine/creatures/register.lua:498: in function 'spawnerSpawn'
2019-09-01 10:28:06: ERROR[Main]: ...re/games/minetest/mods/mob-engine/creatures/register.lua:574: in function <...re/games/minetest/mods/mob-engine/creatures/register.lua:572>


-------------
Separator
-------------

Most of the time it has to do with creatures and spawning.
But sometimes there is nothing, like here:

(...)
2019-09-01 11:42:05: ACTION[Server]: Letang139 takes animal_wolf:wolf from creative inventory
2019-09-01 11:42:11: ACTION[Server]: Letang139 punches object 3725: LuaEntitySAO at (49,4,19)
2019-09-01 11:42:11: ACTION[Server]: LuaEntitySAO at (49,4,19) punched by player Letang139, damage 9 hp, health now 1 hp
2019-09-01 11:42:11: ACTION[Server]: Letang139 punches object 3725: LuaEntitySAO at (48.9953,4,18.9973)
2019-09-01 11:42:11: ACTION[Server]: LuaEntitySAO at (48.9953,4,18.9973) punched by player Letang139, damage 1 hp, health now 0 hp


-------------
Separator
-------------


With regrads,
Paul
 

User avatar
Walker
Member
 
Posts: 350
Joined: Tue Oct 03, 2017 09:22
In-game: Walker

Re: Server crashes

by Walker » Sun Sep 01, 2019 12:16

i dont now, but was i see first, is that mob-engine ( doo you using this > https://github.com/minetest-mods/mob-engine ? ) is very old

secound: by the last error you posted, do you became a message in the terminal like "segmentation fault" ?
 

paulvdv
Member
 
Posts: 20
Joined: Sat Sep 22, 2018 11:01

Re: Server crashes

by paulvdv » Sun Sep 01, 2019 13:12

Walker wrote:i dont now, but was i see first, is that mob-engine ( doo you using this > https://github.com/minetest-mods/mob-engine ? ) is very old

secound: by the last error you posted, do you became a message in the terminal like "segmentation fault" ?


No segmentation fault. I use mob-engine because of these problems, before I've used "creatures" and had also problems. mob-engine is newer. What do you use? creatures or the alternative mob-engine is important...

I also don't like I had to turn of those mods what work OK before.

With regards,
Paul
 

User avatar
Walker
Member
 
Posts: 350
Joined: Tue Oct 03, 2017 09:22
In-game: Walker
 

paulvdv
Member
 
Posts: 20
Joined: Sat Sep 22, 2018 11:01

Re: Server crashes

by paulvdv » Sun Sep 01, 2019 13:39

Walker wrote:i use mobs_redo on my servers


Thanks for your help. I have mobs_redo too. What I did now is remove mob-engine and all dependencies like sheep and so on. I am interested if that helps! I will have to clean-up a lot...

WIth regards,
Paul
 

User avatar
Walker
Member
 
Posts: 350
Joined: Tue Oct 03, 2017 09:22
In-game: Walker

Re: Server crashes

by Walker » Sun Sep 01, 2019 15:00

clean up is easy

you only need to enter "/clearobjects quick" inside the game
 

paulvdv
Member
 
Posts: 20
Joined: Sat Sep 22, 2018 11:01

Re: Server crashes

by paulvdv » Mon Sep 02, 2019 12:32

Walker wrote:clean up is easy

you only need to enter "/clearobjects quick" inside the game


What does this? Realize that people did build houses and so on, and I do not want all animals removed. I use at the moment the "cleaner" mod, but you have to learn it which objects has to be cleared.

I would like to tell that I have not seen any crash anymore ;-) Thanks a lot.

With regards,
Paul
 

paulvdv
Member
 
Posts: 20
Joined: Sat Sep 22, 2018 11:01

Re: Server crashes

by paulvdv » Mon Sep 02, 2019 12:37

Now I don't have "creatures" anymore, I miss the ghosts and zombies. And also the sheep and chicken, and maybe more. Is there another mod what works correct, and will add those?
 

User avatar
Walker
Member
 
Posts: 350
Joined: Tue Oct 03, 2017 09:22
In-game: Walker

Re: Server crashes

by Walker » Mon Sep 02, 2019 15:36

have you the other mods from mobs_redo installed ?

by name:
https://notabug.org/TenPlus1/mobs_animal <-- Farm Animals
https://notabug.org/TenPlus1/mobs_monster <-- Monsters
https://notabug.org/TenPlus1/mobs_npc <-- Simple NPC and Trader
https://notabug.org/TenPlus1/mob_horse <-- Ridable Horses with horseshoe upgrades

because mobs_redo is only the engine, you need the others for content
 

paulvdv
Member
 
Posts: 20
Joined: Sat Sep 22, 2018 11:01

Re: Server crashes

by paulvdv » Tue Sep 03, 2019 09:00

Walker wrote:have you the other mods from mobs_redo installed ?

by name:
https://notabug.org/TenPlus1/mobs_animal <-- Farm Animals
https://notabug.org/TenPlus1/mobs_monster <-- Monsters
https://notabug.org/TenPlus1/mobs_npc <-- Simple NPC and Trader
https://notabug.org/TenPlus1/mob_horse <-- Ridable Horses with horseshoe upgrades

because mobs_redo is only the engine, you need the others for content


Thanks! But I still not found zombies and ghosts like I know them from "creatures". With "ghost" I mean the one with green eyes on this picture: viewtopic.php?f=11&t=9917
With creatures I always found them under the ground, or in the evening, but not anymore.

And I see only sheep and chicken when I put them.

Still no crashes! ;-)

With regards,
Paul
 

User avatar
Walker
Member
 
Posts: 350
Joined: Tue Oct 03, 2017 09:22
In-game: Walker

Re: Server crashes

by Walker » Wed Sep 04, 2019 01:20

zombie and ghost are in mobs_monster, and can be found in dark areas and caves

only sheep and chicken ? have you activated all mods ?
it is also possible that not all animals spawn from the beginning, just wait;)
 

paulvdv
Member
 
Posts: 20
Joined: Sat Sep 22, 2018 11:01

Re: Server crashes

by paulvdv » Wed Sep 04, 2019 10:04

Walker wrote:zombie and ghost are in mobs_monster, and can be found in dark areas and caves

only sheep and chicken ? have you activated all mods ?
it is also possible that not all animals spawn from the beginning, just wait;)


Thanks for your help!
I don't see zombie and ghost in mobs_monster
But I see mob_ghost loading:
-----
2019-09-04 11:21:57: ACTION[Main]: MOD: mob_ghost loading ...
2019-09-04 11:21:57: ACTION[Main]: registering pattern flight_pattern_ghost
2019-09-04 11:21:57: ACTION[Main]: ADV_SPAWNING: registering spawner "ghost_spawner_1"
2019-09-04 11:21:57: ACTION[Main]: ADV_SPAWNING: now handling: 2 spawner definitions
2019-09-04 11:21:57: WARNING[Main]: Undeclared global variable "factions" accessed at /usr/share/games/minetest/mods/animals/mob_ghost/init.lua:215
2019-09-04 11:21:57: ACTION[Main]: adding mob ghost
2019-09-04 11:21:57: ACTION[Main]: MOD: mob_ghost mod version 0.0.1 loaded
-----

But I don't see ghosts or zombies in dark places.

And about the sheep and chicken: I can put them somewhere, but they don't come from themselves. Maybe I miss some spawner?

With regards,
Paul
 

User avatar
Walker
Member
 
Posts: 350
Joined: Tue Oct 03, 2017 09:22
In-game: Walker

Re: Server crashes

by Walker » Wed Sep 04, 2019 14:25

Unfortunately, I can´t help you there, preferably you ask in mobs_redo thread ^^
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 2 guests