Strange rendering artifacts in-game [SOLVED]

xpenguin84x
New member
 
Posts: 2
Joined: Thu Sep 26, 2019 03:09

Strange rendering artifacts in-game [SOLVED]

by xpenguin84x » Thu Sep 26, 2019 03:21

I fired up MineTest for the first time in a while and am getting some strange rendering glitches. I've tried messing with the graphics settings, but nothing seems to help. I have an Intel i7 processor and an Nvidia 1070 graphics card so I don't see why my computer would struggle with the game, even with the graphics settings cranked all the way up. Any ideas?

*Edit* The glitches I'm experiencing aren't showing in the screenshots I took. What is happening is, when I look at the ground then up to the sky, the ground textures to be pulled up and flicker behind the clouds. In the menu, the clouds that float around in the background, seem to draw and extend incrementally causing thin, blue lines to form. I hope this makes sense, as I'm clueless as to why this is happening. It worked perfectly before. I uninstalled then re-installed the game, with the same results.
Last edited by xpenguin84x on Mon Sep 30, 2019 15:14, edited 1 time in total.
 

User avatar
Krock
Developer
 
Posts: 4391
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: Strange rendering artifacts in-game

by Krock » Thu Sep 26, 2019 17:33

Welcome to the forums. Here's a few of the usual questions and steps:

1) Disable the shaders and restart Minetest (just to be really sure). Does it change anything?
2) Do other OpenGL games run well with this setup?
3) If you're on Windows, does a new setting line `video_driver = direct3d9` in your minetest.conf change anything? Edit before starting Minetest. Remove the line again after closing Minetest if it didn't help. You could also do that using the "All Settings" (or "Advanced Settings") dialogue, but this way is safer.
4) Change or add the setting `mouse_sensitivity = 0.002` to your minetest.conf (same procedure as above)
Look, I programmed a bug for you. >> Mod Search Engine << - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>
 

micheal65536
Member
 
Posts: 130
Joined: Mon May 22, 2017 20:27

Re: Strange rendering artifacts in-game

by micheal65536 » Thu Sep 26, 2019 20:37

Are you using Linux or Windows? Linux support for nVidia graphics cards has always been somewhat unreliable.
 

xpenguin84x
New member
 
Posts: 2
Joined: Thu Sep 26, 2019 03:09

Re: Strange rendering artifacts in-game

by xpenguin84x » Fri Sep 27, 2019 17:04

Thank you everyone for responding. @Krock You're advice to change to Direct3D worked. I'm a bit confused by that as every other game that uses OpenGL runs just fine. Oh well. Again, thank you everyone for helping me out.

P.S. Sorry about the delay in responding. As a husband and father, my time is at a bit of a premium.
 

User avatar
Krock
Developer
 
Posts: 4391
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: Strange rendering artifacts in-game

by Krock » Fri Sep 27, 2019 17:25

That Direct3D worked for you means that you should definitely fix the video drivers. Go to the manufacturer's website (https://www.geforce.com/drivers) and download the appropriate driver to get Minetest (and other games) running well.

Please add the prefix [Solved] to your main post's title if this helped.
Look, I programmed a bug for you. >> Mod Search Engine << - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 6 guests