Disable damage but in sigleplayer dead

salvamea
New member
 
Posts: 7
Joined: Wed Sep 25, 2019 06:03
In-game: Salvamea

Disable damage but in sigleplayer dead

by salvamea » Mon Oct 21, 2019 14:47

Sorry after the last update in kubuntu, When disabled the damage suffers the same, i have add the ppa
 

User avatar
Krock
Developer
 
Posts: 4391
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: Disable damage but in sigleplayer dead

by Krock » Mon Oct 21, 2019 19:09

Please open your terminal and post the output of `minetest --version`.
Assuming 5.1.0 for now.

What happens if you re-enable damage, die, and disable damage again? Is the player still dead?
Look, I programmed a bug for you. >> Mod Search Engine << - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>
 

salvamea
New member
 
Posts: 7
Joined: Wed Sep 25, 2019 06:03
In-game: Salvamea

Re: Disable damage but in sigleplayer dead

by salvamea » Tue Oct 22, 2019 05:23

Hi Thanks for answering, then the command output is here:
Minetest 5.1.0 (Linux)
Using Irrlicht 1.8.4
BUILD_TYPE=None
RUN_IN_PLACE=0
USE_GETTEXT=1
USE_SOUND=1
USE_CURL=1
USE_FREETYPE=1
USE_LUAJIT=1
STATIC_SHAREDIR="/usr/share/minetest"
have already tried to enable the damage and then to disable but the result is always the same, however the update is there because now the game is entirely in Italian, even if from the version it seems the same.
 

redblade7
Member
 
Posts: 280
Joined: Sun Feb 15, 2015 07:14
IRC: redneonglow redblade7
In-game: redblade7 redblade7_owner

Re: Disable damage but in sigleplayer dead

by redblade7 » Mon Oct 28, 2019 13:56

I'm having the same problem on Creative Gardens since the v5.1.0 upgrade. Despite enable_damage = false, enable_pvp = false, people are dying if they fall off cliffs or stay in water too long. There are no heart or bubble indicators for the death, and all items are retained with no dropped bones.

For a drowning death, the log shows:

2019-10-28 09:50:43: ACTION[Server]: redblade7_owner dies at (219,78,606). No bones placed
2019-10-28 09:50:44: ACTION[Server]: Moving redblade7_owner to static spawnpoint at (2591,24,-1373)
2019-10-28 09:50:44: ACTION[Server]: redblade7_owner respawns at (2591,24,-1373)
-redblade7, admin of: THE CREATIVE GARDENS (creative), THE VALLEYS (sandbox), and THE DIGITAL FARMS (farming/hunger/shops)
 

User avatar
Krock
Developer
 
Posts: 4391
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: Disable damage but in sigleplayer dead

by Krock » Mon Oct 28, 2019 19:13

redblade7 wrote:I'm having the same problem on Creative Gardens since the v5.1.0 upgrade. Despite enable_damage = false, enable_pvp = false, people are dying if they fall off cliffs or stay in water too long.


Cannot reproduce.

The server does neither handle client-sent damage packets (https://github.com/minetest/minetest/bl ... r.cpp#L810) nor does it send death or HP update packets (https://github.com/minetest/minetest/bl ... .cpp#L1341).

Ensure that no mod resets the armor groups by accident (like 3d_armor), because the "immortal" group specifies whether a player can die.
Look, I programmed a bug for you. >> Mod Search Engine << - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>
 

redblade7
Member
 
Posts: 280
Joined: Sun Feb 15, 2015 07:14
IRC: redneonglow redblade7
In-game: redblade7 redblade7_owner

Re: Disable damage but in sigleplayer dead

by redblade7 » Mon Oct 28, 2019 19:19

Krock wrote:
redblade7 wrote:I'm having the same problem on Creative Gardens since the v5.1.0 upgrade. Despite enable_damage = false, enable_pvp = false, people are dying if they fall off cliffs or stay in water too long.


Cannot reproduce.

The server does neither handle client-sent damage packets (https://github.com/minetest/minetest/bl ... r.cpp#L810) nor does it send death or HP update packets (https://github.com/minetest/minetest/bl ... .cpp#L1341).

Ensure that no mod resets the armor groups by accident (like 3d_armor), because the "immortal" group specifies whether a player can die.


I have 3d_armor and xtraarmor installed on that server. Can you please explain what you mean by "resetting the armor group"?
-redblade7, admin of: THE CREATIVE GARDENS (creative), THE VALLEYS (sandbox), and THE DIGITAL FARMS (farming/hunger/shops)
 

User avatar
Linuxdirk
Member
 
Posts: 2197
Joined: Wed Sep 17, 2014 11:21
Location: Germany
In-game: Linuxdirk

Re: Disable damage but in sigleplayer dead

by Linuxdirk » Tue Oct 29, 2019 12:21

Disable those mods and test it. If it properly works re-enable the mods one-by-one until it does not work properly, then report a bug on that mod's issue tracker.
 

User avatar
sfan5
Moderator
 
Posts: 3816
Joined: Wed Aug 24, 2011 09:44
Location: Germany
GitHub: sfan5
IRC: sfan5

Re: Disable damage but in sigleplayer dead

by sfan5 » Tue Oct 29, 2019 15:34

redblade7 wrote:I have 3d_armor and xtraarmor installed on that server. Can you please explain what you mean by "resetting the armor group"?

See: https://github.com/stujones11/minetest- ... r/pull/170
When 3d_armor calls set_armor_groups, it needs to keep "immortal" set as armor group. But it doesn't do that, this signals to the engine that damage should be enabled for the player, most likely causing the symptoms you described.
Mods: Mesecons | WorldEdit | Nuke & Minetest builds for Windows (32-bit & 64-bit)
 

redblade7
Member
 
Posts: 280
Joined: Sun Feb 15, 2015 07:14
IRC: redneonglow redblade7
In-game: redblade7 redblade7_owner

Re: Disable damage but in sigleplayer dead

by redblade7 » Wed Oct 30, 2019 17:17

sfan5 wrote:
redblade7 wrote:I have 3d_armor and xtraarmor installed on that server. Can you please explain what you mean by "resetting the armor group"?

See: https://github.com/stujones11/minetest- ... r/pull/170
When 3d_armor calls set_armor_groups, it needs to keep "immortal" set as armor group. But it doesn't do that, this signals to the engine that damage should be enabled for the player, most likely causing the symptoms you described.


I added the lines from that pull request to the minetest-3d_armor folder on Creative Gardens and it solved the problem, thanks sfan5!

But is this the same issue that the OP was having?
-redblade7, admin of: THE CREATIVE GARDENS (creative), THE VALLEYS (sandbox), and THE DIGITAL FARMS (farming/hunger/shops)
 


Return to Problems



Who is online

Users browsing this forum: Google [Bot] and 2 guests