Sliding around.

jeremyericson
Member
 
Posts: 15
Joined: Mon May 20, 2019 22:51
Location: On my chair
GitHub: CodingPsych
IRC: alepfwxz
In-game: 6789alepfwxz

Sliding around.

by jeremyericson » Mon Nov 04, 2019 19:22

Hey, um so with minetest version 5.1.0 when I walk or fly it makes me slide as if I'm on ice, how do i turn that off? like so i dont slide around?
 

User avatar
Krock
Developer
 
Posts: 4391
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: Sliding around.

by Krock » Tue Nov 05, 2019 18:18

Rename your minetest.conf file, and check whether it still happens when starting Minetest using the default settings.
Look, I programmed a bug for you. >> Mod Search Engine << - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>
 

micheal65536
Member
 
Posts: 130
Joined: Mon May 22, 2017 20:27

Re: Sliding around.

by micheal65536 » Tue Nov 05, 2019 20:03

You always have a bit of momentum in fly mode, you don't stop moving instantly when you let go of the movement keys. However I'm not aware that this has changed in Minetest 5.x.

Try pressing "J" to turn fast mode on/off. It's possible that you had it on by accident. Also try "P" to toggle pitch movement mode - this is new in Minetest 5.x and might create a similar feeling to sliding if you aren't expecting it/used to it.

Otherwise my guess would be that a mod is setting a physics override (possibly incorrectly). Does this happen with Minetest Game without any other mods or are you using a different subgame and/or have you installed extra mods?
 

jeremyericson
Member
 
Posts: 15
Joined: Mon May 20, 2019 22:51
Location: On my chair
GitHub: CodingPsych
IRC: alepfwxz
In-game: 6789alepfwxz

Re: Sliding around.

by jeremyericson » Wed Nov 06, 2019 02:32

Yeah i could'ent figure it out but i used a different account on my computer and it works
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 6 guests