Clients Version not supported (0.4.1)

neomoe
Member
 
Posts: 12
Joined: Wed Jun 06, 2012 15:55

Clients Version not supported (0.4.1)

by neomoe » Wed Jul 25, 2012 23:07

Protocol-Version:
Clients Version is 12.
Server-Version is 11.

With the new update - i can not connect to any(!) Server.
is a downgrade the only possible way ... ?
Last edited by neomoe on Wed Jul 25, 2012 23:07, edited 1 time in total.
 

User avatar
dannydark
Member
 
Posts: 428
Joined: Fri Aug 12, 2011 21:28
Location: Manchester, UK

by dannydark » Wed Jul 25, 2012 23:59

Unfortunately yes, until the server owners update there servers to the newest version or turn off strict protocol checking.

So unless the server owners don't mind setting strict_protocol_version_checking to false in there config then you will have to use an older client version to connect to them servers.
 

User avatar
VanessaE
Moderator
 
Posts: 4473
Joined: Sun Apr 01, 2012 12:38
Location: Waynesville, NC
GitHub: VanessaE
IRC: VanessaE
In-game: VanessaE

by VanessaE » Thu Jul 26, 2012 01:46

With the very latest git, even strict protocol checking being disabled isn't sufficient, due to a fundamental change in the data being sent - between the new 16-bit node IDs (=lots more mods can be installed) and other stuff, current git just isn't compatible with 0.4.1 and older servers.
You might like some of my stuff: Plantlife ~ More Trees ~ Home Decor ~ Pipeworks ~ HDX Textures (64-512px)
 

neomoe
Member
 
Posts: 12
Joined: Wed Jun 06, 2012 15:55

by neomoe » Thu Jul 26, 2012 03:41

Thanks for answers :)
 

User avatar
RealBadAngel
Member
 
Posts: 557
Joined: Wed Jul 18, 2012 16:30

by RealBadAngel » Fri Jul 27, 2012 17:42

which build exactly comes with protocol version 12?
i do have 0.4.1 and it says when tryin to connect to server that i do have 11.
checked another builds but still got same error.

Server is 0.4.1, i do have 0.4.1. And i got this:
Image
Last edited by RealBadAngel on Fri Jul 27, 2012 18:11, edited 1 time in total.
 

User avatar
sfan5
Moderator
 
Posts: 3828
Joined: Wed Aug 24, 2011 09:44
Location: Germany
GitHub: sfan5
IRC: sfan5

by sfan5 » Fri Jul 27, 2012 18:16

There is no official Build with PROTOCOL_VERSION 12

You get my unofficial Build at http://sfan.sf.funpic.de/minetest-builds/.
Just download minetest-0.4.1-7ef0a13-win32.7z
Mods: Mesecons | WorldEdit | Nuke & Minetest builds for Windows (32-bit & 64-bit)
 

neomoe
Member
 
Posts: 12
Joined: Wed Jun 06, 2012 15:55

by neomoe » Sat Jul 28, 2012 08:50

sfan5 wrote:There is no official Build with PROTOCOL_VERSION 12


uhm - sry
but there must be something wrong ...
i have ubuntu 12.04 - and the actual version, which is loaded/installed
_is_ with protocol version 12
it is the same error message RealBadAngel mentioned
i cant connect to any server, which is announced as "0.4.1"
in the server-thread
Last edited by neomoe on Sat Jul 28, 2012 08:53, edited 1 time in total.
 

User avatar
sfan5
Moderator
 
Posts: 3828
Joined: Wed Aug 24, 2011 09:44
Location: Germany
GitHub: sfan5
IRC: sfan5

by sfan5 » Sat Jul 28, 2012 08:57

neomoe wrote:
sfan5 wrote:There is no official Build with PROTOCOL_VERSION 12


uhm - sry
but there must be something wrong ...
i have ubuntu 12.04 - and the actual version, which is loaded/installed
_is_ with protocol version 12
it is the same error message RealBadAngel mentioned
i cant connect to any server, which is announced as "0.4.1"
in the server-thread

You compiled the latest git from Source, because there are no official Builds for Ubuntu.

RealBadAngel has PROTOCOL_VERSION 11 and needs 12
You have PROTOCOL_VERSION 12 and need 11
Thats the difference
Mods: Mesecons | WorldEdit | Nuke & Minetest builds for Windows (32-bit & 64-bit)
 

User avatar
Calinou
Moderator
 
Posts: 3159
Joined: Mon Aug 01, 2011 14:26
Location: Troyes, France
GitHub: Calinou
IRC: Calinou
In-game: Calinou

by Calinou » Sat Jul 28, 2012 09:05

Latest Git protocol is 12.
0.4.0/0.4.1 protocol is 11.

If you want to download the 0.4.1 source, it's here: https://github.com/celeron55/minetest/tarball/stable-0.4
 

neomoe
Member
 
Posts: 12
Joined: Wed Jun 06, 2012 15:55

by neomoe » Sat Jul 28, 2012 09:08

sfan5 wrote:RealBadAngel has PROTOCOL_VERSION 11 and needs 12
You have PROTOCOL_VERSION 12 and need 11
Thats the difference


Thanks for answer.
Its really irritating, for a normal User like me,
to get an overview with this client-version-number "0.4.1",
because most of the servers, which are listed in the server-thread
are named as "0.4.1" but they seem to work with protocol_version 11 ...


Well - it is, as it is :/
Last edited by neomoe on Sat Jul 28, 2012 09:31, edited 1 time in total.
 

User avatar
Menche
Member
 
Posts: 997
Joined: Sat Jul 02, 2011 00:43
Location: An island in a lava lake.
IRC: Menche
In-game: Menche

by Menche » Sat Jul 28, 2012 18:56

sfan5 wrote:You compiled the latest git from Source, because there are no official Builds for Ubuntu.

https://code.launchpad.net/~minetestdevs/+archive/stable/+packages
An innocent kitten dies every time you top-post.
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 2 guests