FPS problem and program freezes on close

Post Reply
User avatar
wacossusca34
New member
Posts: 3
Joined: Fri Sep 23, 2011 17:19

FPS problem and program freezes on close

by wacossusca34 » Post

Specs -

OS - Puppy Linux 5.2.8 - Full hard drive install
2 GB RAM
Some super fking awesome graphics card that runs crysis at very high graphics. Nvidia
2.2 Ghz single core processor

FPS issue: The application is not processing textures fast enough. I can run minecraft much faster. I get 70 - 90 FPS when looking at the sky, but 15 - 25 FPS with some major lag spikes when looking at multiple textures.

Freezes on close: When application is supposed to return to menu, or close, it freezes. It does not show up in my system process viewer, and in order to get rid of the hung window, I have to exit my GUI interface / X (Ctl + Alt + Backspace)

Are these well known issues? Are there fixes for these? I'm planning on running a server for this, so I want the game running nicely for me.

User avatar
wacossusca34
New member
Posts: 3
Joined: Fri Sep 23, 2011 17:19

by wacossusca34 » Post

FPS solved itself. After a reboot...

Lol...

User avatar
celeron55
Administrator
Posts: 476
Joined: Tue Apr 19, 2011 10:10
GitHub: celeron55
IRC: celeron55

by celeron55 » Post

A hundred lines from the end of the debug log after killing it would be useful. (~/.minetest/debug.txt or something)

User avatar
Fallen_Phillip
Member
Posts: 41
Joined: Mon Sep 19, 2011 22:31
Location: Georgia, USA

by Fallen_Phillip » Post

I just rebooted my computer twice to no avail. I have a decent graphics card and 2 GB of RAM. When I first start minetest, I'm at about 30 FPS, but in about 15 to 20 seconds, its down to 10 or less.I was just at 3. Then I disconnect and start again and the process repeats. So I rebooted thinking it would help, and it's the same. :/

EDIT: My minetest DOESN'T freeze when closing though. Its closing just fine.
Last edited by Fallen_Phillip on Sun Sep 25, 2011 21:13, edited 1 time in total.

kahrl
Member
Posts: 236
Joined: Fri Sep 02, 2011 07:51
Location: Rös̓̇chenhof

by kahrl » Post

Fallen_Phillip wrote:I just rebooted my computer twice to no avail. I have a decent graphics card and 2 GB of RAM. When I first start minetest, I'm at about 30 FPS, but in about 15 to 20 seconds, its down to 10 or less.I was just at 3. Then I disconnect and start again and the process repeats. So I rebooted thinking it would help, and it's the same. :/

EDIT: My minetest DOESN'T freeze when closing though. Its closing just fine.
Try pressing "R" once when the FPS drop to unbearable levels, does that make the game playable again?

User avatar
Fallen_Phillip
Member
Posts: 41
Joined: Mon Sep 19, 2011 22:31
Location: Georgia, USA

by Fallen_Phillip » Post

I've tried several times. Nothing changes, really. :/

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest