Black screen (buried) on Linux

cosarara97
Member
 
Posts: 180
Joined: Tue Nov 01, 2011 18:53

Black screen (buried) on Linux

by cosarara97 » Tue Nov 01, 2011 19:17

Hello, I'm using minetest under Linux Mint 11 amd64. The controller of my graphics card (or what lspci says):
VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)

Well, the problem is that minetest's screen randomly (mostly at night or in dark places) turns black like this (without the mouse):
Image

I can still open the menu and disconnect or close it, but that user can never play again.


I have tested it with minetest-c55 (development and stable, compiled form source and form ppa), and minetest delta, it happens with all of them. I don't think it's minetest's fault, but it is the only program which I have this problem with, so it has to be related with it.

Am I the only one with this problem?


EDIT: Sometimes it happens at midday, so it is not related with "light"

EDIT: I get buried
Last edited by cosarara97 on Tue Nov 01, 2011 21:15, edited 1 time in total.
:D
 

User avatar
saschakb
Member
 
Posts: 93
Joined: Sat Sep 24, 2011 19:25
Location: Cyberspace

by saschakb » Tue Nov 01, 2011 19:22

https://bbs.archlinux.org/viewtopic.php?id=116471
That's a common problem with the Intel drivers for Linux. a quick search via duckduckgo/google "intel linux to dark" shows solutions.
Have a look on my minetest screenshots on http://saschakb.tumblr.com
If you would play in my world, fork the datas from https://github.com/saschakb/minetest-world
 

User avatar
Staffs
Member
 
Posts: 329
Joined: Thu Aug 04, 2011 13:16

by Staffs » Tue Nov 01, 2011 19:26

Nonononono You are just spawned in a underground block and you have to enable free move to fly out of it.. Well at least that was the problem in my case
I love mods :D
 

cosarara97
Member
 
Posts: 180
Joined: Tue Nov 01, 2011 18:53

by cosarara97 » Tue Nov 01, 2011 19:33

How do I enable free move?
:D
 

User avatar
cisoun
Member
 
Posts: 232
Joined: Tue Apr 19, 2011 18:56
Location: Switzerland
GitHub: cisoun
IRC: cisoun
In-game: cisoun

by cisoun » Tue Nov 01, 2011 19:39

Press 'K' then 'Space' to come back at the surface.
Also, you can change these keys in the main menu.
Not here for a while due to some troubles between my graphic card and Minetest.
Cisoun's Texture Pack | The Conifers Mod (deprecated) | Faenza icons for Minetest |
Website
 

cosarara97
Member
 
Posts: 180
Joined: Tue Nov 01, 2011 18:53

by cosarara97 » Tue Nov 01, 2011 19:42

Thanks!!!
That was my problem =D. I don't know why, but I was like 20 metres underground O.o
:D
 

User avatar
cisoun
Member
 
Posts: 232
Joined: Tue Apr 19, 2011 18:56
Location: Switzerland
GitHub: cisoun
IRC: cisoun
In-game: cisoun

by cisoun » Tue Nov 01, 2011 19:59

Yeah it happens sometimes. Weird and old bug...
Not here for a while due to some troubles between my graphic card and Minetest.
Cisoun's Texture Pack | The Conifers Mod (deprecated) | Faenza icons for Minetest |
Website
 

cosarara97
Member
 
Posts: 180
Joined: Tue Nov 01, 2011 18:53

by cosarara97 » Tue Nov 01, 2011 21:01

Well, I can play now, but it's still annoying having to be coming back to the surface every 3 minutes. If If it is an old bug, and I have it updated with the ppa, why does it happen? Or it has never been fixed?


EDIT: With the last stable it happens less :D
Last edited by cosarara97 on Wed Nov 02, 2011 13:06, edited 1 time in total.
:D
 

randomproof
Member
 
Posts: 214
Joined: Thu Nov 17, 2011 06:31
Location: California, USA

by randomproof » Thu Nov 17, 2011 06:44

This happens with me too. I am usually 3 blocks under where I saved. Very annoying. I've looked at the log and it says that the correct location is sent and received, but the Y position is usually 5.0 below what it should be. The only thing I think i could be is difference with OpenGL on Linux and Directx on Windows.
 

bookwar
Member
 
Posts: 29
Joined: Sat Oct 08, 2011 20:37

by bookwar » Thu Nov 17, 2011 10:52

Later commits in git have something to do with this bug. So you may try to build the latest source and test if the bug is fixed.

The fix is server-side, so if you play on the public server new client version won't help.
Fedora rpm-package for Minetest
 

User avatar
xyz
Member
 
Posts: 450
Joined: Thu Nov 10, 2011 14:25

by xyz » Thu Nov 17, 2011 11:28

bookwar wrote:Later commits in git have something to do with this bug. So you may try to build the latest source and test if the bug is fixed.

The fix is server-side, so if you play on the public server new client version won't help.

Anyway, it sometimes happen
 

randomproof
Member
 
Posts: 214
Joined: Thu Nov 17, 2011 06:31
Location: California, USA

by randomproof » Thu Nov 17, 2011 20:06

bookwar wrote:Later commits in git have something to do with this bug. So you may try to build the latest source and test if the bug is fixed.

The fix is server-side, so if you play on the public server new client version won't help.


I've tested this in latest source pulled from git and it still happens.
I've made a small change to server.cpp at line 2035 to offset the problem:
player->setPosition(player->getPosition()+v3f(0,5,0));

I wonder if the saved location is from where the feet are and when it is loaded it is set to where the "camera" set.
 

kahrl
Member
 
Posts: 236
Joined: Fri Sep 02, 2011 07:51
Location: Rös̓̇chenhof

by kahrl » Fri Nov 18, 2011 07:04

FYI, if the problem primarily happens when you login to a server (or to a local game), it seems to be a bug with the way gravity and collision detection works. When the client environment doesn't update for about half a second (that's often the case when you login), depending on the floating point implementation of your compiler you might glitch through the ground. There is some intermediate NaN result that breaks the physics formulas.

We discussed this bug in the IRC channel not long ago. See this log starting at around 14:00. Here's my patch: yay
 

User avatar
xyz
Member
 
Posts: 450
Joined: Thu Nov 10, 2011 14:25

by xyz » Fri Nov 18, 2011 07:31

kahrl wrote:FYI, if the problem primarily happens when you login to a server (or to a local game), it seems to be a bug with the way gravity and collision detection works. When the client environment doesn't update for about half a second (that's often the case when you login), depending on the floating point implementation of your compiler you might glitch through the ground. There is some intermediate NaN result that breaks the physics formulas.

We discussed this bug in the IRC channel not long ago. See this log starting at around 14:00. Here's my patch: yay

It also often happens just in random moments of time.
 

User avatar
Menche
Member
 
Posts: 997
Joined: Sat Jul 02, 2011 00:43
Location: An island in a lava lake.
IRC: Menche
In-game: Menche

by Menche » Fri Nov 18, 2011 15:02

Occasionally taking a screenshot caused this to happen to me.
An innocent kitten dies every time you top-post.
 

randomproof
Member
 
Posts: 214
Joined: Thu Nov 17, 2011 06:31
Location: California, USA

by randomproof » Fri Nov 18, 2011 15:15

kahrl wrote:FYI, if the problem primarily happens when you login to a server (or to a local game), it seems to be a bug with the way gravity and collision detection works. When the client environment doesn't update for about half a second (that's often the case when you login), depending on the floating point implementation of your compiler you might glitch through the ground. There is some intermediate NaN result that breaks the physics formulas.

We discussed this bug in the IRC channel not long ago. See this log starting at around 14:00. Here's my patch: yay


This was my thinking too, but I had no idea how to test or debug that this happening. Thank you.
 

CalumMc
Member
 
Posts: 58
Joined: Mon Dec 12, 2011 16:50
Location: England

by CalumMc » Tue Jan 03, 2012 11:56

That happens with me too, fedora with AMD Radeon graphics.
 

cosarara97
Member
 
Posts: 180
Joined: Tue Nov 01, 2011 18:53

by cosarara97 » Tue Jan 03, 2012 20:41

It doesn't happen to me now (Mint 12 amd64). I thought it was fixed : /
:D
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 12 guests