Page 1 of 1

Some number keys not working

PostPosted: Sat Nov 17, 2012 11:28
by Zeg9
Hello, I have a problem since I switched to arch linux (I had other problems before, too, but they are fixed now):
Some number keys are not working, including half of the keypad, and the 7 key (numpad AND the other one).
It seems they are detected as other keys, then ignored.
If I set the keymap to qwerty, the 7 key works (I have an azerty keyboard), the numpad still doesn't work though.
If I add qwerty in the keymap list (but I keep azerty on first pos), it seems to work, but some software become in qwerty...
Anyone has an explanation or, even better, a fix to that ? :s
Oh, and I am on a 64 bit architecture, and I use xfce (the issue happens on other DEs too)
Thanks for reading.

PostPosted: Sat Nov 17, 2012 12:06
by PilzAdam
Some keys on the numpad dont work for me either.

PostPosted: Sat Nov 17, 2012 12:25
by Zeg9
Numpad isn't really a problem, actually, the real problem is that I can't type 7 in any box, including server ip...
I actually modify /etc/hosts to get on servers with 7 in their ip, but I shouldn't have to do this I think :p

PostPosted: Wed Dec 05, 2012 17:15
by dannydark
I've heard of some other people having problems with the 7 key on azerty keyboard layout, this (I think) is a irrlicht issue and currently the only way around it is either to switch to qwerty layout temporarily or to copy-paste the number 7.

Also numpad seems to work fine for me on my windows system, I will check my linux and mac systems later after work to see if I have any keyboard issues on them although I use a qwerty keyboard.

could you give us some more information like OS, Keyboard layout and which keys don't work on your numpad at least then we will know what needs fixing, unless it is a irrlicht bug in which case we can give them a detailed report of the issue.

Hybrid Dog wrote:Numpad is useful to edit long text on signs or sth.
7 → move to first letter
1 → move to last letter


We can do this anyway by turning numlock off to use the keys other functions and on to use the numbers ^_^

PostPosted: Sun Dec 09, 2012 15:42
by Zeg9
I am using arch linux, an azerty keyboard, and only 9 and 3 are working on numpad.
Also, all other keys work, except the 7. and copy-pasting in minetest just crashes the source application (the one I copy from)...
EDIT: It seems I haven't got this problem in debian, too.

PostPosted: Sun Dec 09, 2012 20:23
by Calinou
Happens to me too, this seems to happen when using an AZERTY keyboard layout with Minetest (I can guess it since you're from France :P).

Workaround: switch to QWERTY (= "american"), then press "è"... which is a 7 in QWERTY.

I use Xfce too. Haven't tried with other DEs.

PostPosted: Sun Dec 09, 2012 20:47
by sfan5
I can confirm this!
Really annoying.

PostPosted: Mon Dec 10, 2012 06:32
by Zeg9
I found a way to fix that, but it's "cheaty":
chroot to my existing debian squeeze... and run minetest inside that chroot.
I think debian has an old version of something, that worked better before.

EDIT: btw, the forum asked me 3 questions before it lets me post that -_-
EDIT2: I haven't got this bug in supertuxkart, that game also using irrlicht
EDIT3: it seems our 7 key is ignored because it is considered as "shift" (go in change keys and press it, you'll see)

PostPosted: Mon May 13, 2013 19:57
by glomie
with kde and debian
i start the game with qwerty keyboard then i change to azerty.

Edit:
That don't work anymore, its a big problem, what can i do ?

PostPosted: Wed May 15, 2013 14:16
by glomie
Finaly found a way, US keyboard first in list of keyboard.

PostPosted: Fri Jan 17, 2014 05:13
by khonkhortisan
The numpad is fixed on linux as of irrlicht r4669. You can download the latest stable irrlicht release 1.8.1, manually make that change, recompile irrlicht, and compile minetest linked to it.
Index: source/Irrlicht/CIrrDeviceLinux.cpp
===================================================================
--- source/Irrlicht/CIrrDeviceLinux.cpp (revision 4668)
+++ source/Irrlicht/CIrrDeviceLinux.cpp (revision 4669)
@@ -1061,7 +1061,7 @@
irrevent.KeyInput.Control = (event.xkey.state & ControlMask) != 0;
irrevent.KeyInput.Shift = (event.xkey.state & ShiftMask) != 0;

- event.xkey.state = 0; // ignore shift-ctrl states for figuring out the key
+ event.xkey.state &= ~(ControlMask|ShiftMask); // ignore shift-ctrl states for figuring out the key
XLookupString(&event.xkey, buf, sizeof(buf), &mp.X11Key, NULL);
const s32 idx = KeyMap.binary_search(mp);
if (idx != -1)

Re: Some number keys not working

PostPosted: Thu Jun 19, 2014 13:08
by JPRuehmann
Hello
I still got this Problem with LibIrrlicht 1.9
Thanks,
JPR

Re: Some number keys not working

PostPosted: Sat Jun 28, 2014 14:07
by jp
My "7" has never work for me (AZERTY keyboard). Thank you to fix that please...

Re: Some number keys not working

PostPosted: Thu Aug 07, 2014 10:57
by Gael de Sailly
I have this problem too. The numpad don't work except 0 ; 3 ; 9. I have a Franch keyboard, and the 7 / è / ` key don't works at all.

It's very troublesome when an ip adress contains a seven. I haven't this problem before. At the beginning of the July month, I've updated Minetest from 0.4.9 to 0.4.10 and, some days after, updated my computer from Ubuntu 12.04 to 14.04, and re-installed Minetest 0.4.10. I don't know from which of these updates comes this seven key bug.

But now, copying-pasting on Minetest GUIs works, which wasn't the case before.

Re: Some number keys not working

PostPosted: Wed Aug 13, 2014 00:41
by Minetestforfun
Gael de Sailly wrote:I have this problem too. The numpad don't work except 0 ; 3 ; 9. I have a Franch keyboard, and the 7 / è / ` key don't works at all.

We are now 10 on the "Seven Petition". I am not criticizing the developers, they do what they can. Maybe they do not know more than me where is the origin of this bug.

It's very troublesome when an ip adress contains a seven. I haven't this problem before. At the beginning of the July month, I've updated Minetest from 0.4.9 to 0.4.10 and, some days after, updated my computer from Ubuntu 12.04 to 14.04, and re-installed Minetest 0.4.10. I don't know from which of these updates comes this seven key bug.

But now, copying-pasting on Minetest GUIs works, which wasn't the case before.


Same problem, french keyboard

Re: Some number keys not working

PostPosted: Wed Aug 13, 2014 09:48
by cheapie
I'm using the US-International keyboard layout, and the only number pad keys that work for me are 0, 3, and 9.

Re: Some number keys not working

PostPosted: Mon Oct 06, 2014 13:38
by Gael de Sailly
Gael de Sailly wrote:But now, copying-pasting on Minetest GUIs works, which wasn't the case before.

In fact, it depends on the GUI : in the new version of VanessaE's Signs Library, it doesn't work. For example i play in the VanessaE's Vanilla Server. I've made a long tunnel and I wanted to put a sign which shows the name and the length of the tunnel (as we can see on the French highways). 177 nodes : I had to round it to 180.

Re: Some number keys not working

PostPosted: Thu Oct 16, 2014 22:33
by TammaraBc3
Zeg9 wrote:Hello, I have a problem since I switched to arch linux (I had other problems before, too, but they are fixed now):
Some number keys are not working, including half of the keypad, and the 7 key (numpad AND the other one).
It seems they are detected as other keys, then ignored.
If I set the keymap to qwerty, the 7 key works (I have an azerty keyboard), the numpad still doesn't work though.
If I add qwerty in the keymap list (but I keep azerty on first pos), it seems to work, but some software become in qwerty...
Anyone has an explanation or, even better, a fix to that ? :s
Oh, and I am on a 64 bit architecture, and I use xfce (the issue happens on other DEs too)
Thanks for reading.


Were you able to solve the problem? I'm using AZERTY keyboard as well and numpad don't work for me either.