Library problem with Debian

benni
New member
 
Posts: 6
Joined: Fri Nov 11, 2011 14:52

Library problem with Debian

by benni » Sat Nov 12, 2011 16:18

Hi!

I tryed to install the Ubuntu-deb-Package on a Debian-Box to run a server from there. That is what i got:

benni@nightingale:~$ minetestserver
minetestserver: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by minetestserver)
minetestserver: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by minetestserver)
benni@nightingale:~$ uname -a
Linux nightingale 2.6.18-6-xen-vserver-amd64 #1 SMP Sun Feb 21 01:19:17 UTC 2010 x86_64 GNU/Linux
benni@nightingale:~$ cat /etc/debian_version
5.0.9

Is there a package for Debian anywhere? Or have i to install from source? Is there a way to install the needed library?

Thanks for any help.
 

Dunatotatos
New member
 
Posts: 6
Joined: Fri Nov 11, 2011 22:43

by Dunatotatos » Sat Nov 12, 2011 17:27

Hello,

Package for ubuntu works for Debian (Both operating systems use aptitude/apt-get/dpkg). Your problem came from non satisfied depends. Is libstdc++6 installed on your computer ?
 

benni
New member
 
Posts: 6
Joined: Fri Nov 11, 2011 14:52

by benni » Sat Nov 12, 2011 17:50

Looks so:

benni@nightingale:~$ ls /usr/lib/libstdc++.so.*
/usr/lib/libstdc++.so.5 /usr/lib/libstdc++.so.6
/usr/lib/libstdc++.so.5.0.7 /usr/lib/libstdc++.so.6.0.10
benni@nightingale:~$ ls /usr/lib64/libstdc++.so.*
/usr/lib64/libstdc++.so.5 /usr/lib64/libstdc++.so.6
/usr/lib64/libstdc++.so.5.0.7 /usr/lib64/libstdc++.so.6.0.10

maybe i need a newer version? But where to get one and how to install without messing the whole system up?

Thanks for any help again.
 

benni
New member
 
Posts: 6
Joined: Fri Nov 11, 2011 14:52

by benni » Sat Nov 12, 2011 22:01

Ok, looks like i need a dist-upgrade. I have still an very old Debian lenny :-(
 

Dunatotatos
New member
 
Posts: 6
Joined: Fri Nov 11, 2011 22:43

by Dunatotatos » Sun Nov 13, 2011 01:19

Indeed, you might have problems if you use an old version of Debian.
I tested minetest on Debian squeeze, it works well.
 

pabs
New member
 
Posts: 4
Joined: Tue Nov 15, 2011 04:17

by pabs » Tue Nov 15, 2011 04:31

Debian lenny security support stops in February so it is a really good idea to upgrade to Debian squeeze ASAP.
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 8 guests