“<invalid multibyte string>” on most signs on the Minemacro server

User avatar
Wuzzy
Member
 
Posts: 3427
Joined: Mon Sep 24, 2012 15:01
GitHub: Wuzzy2
IRC: Wuzzy
In-game: Wuzzy

“<invalid multibyte string>” on most signs on the Minemacro server

by Wuzzy » Mon Sep 16, 2013 20:51

Hi, if I join the server Minemacro 1.0 Brasil and look on a sign, most likely I see the text “<invalid multibyte string>”.

What went wrong here? Do other players experience this problem, too?

I use GNU/Linux; Linux 3.9.4 and Minetest 0.4.8.
My creations. I gladly accept bitcoins: 17fsUywHxeMHKG41UFfu34F1rAxZcrVoqH
 

User avatar
BrunoMine
Member
 
Posts: 1046
Joined: Thu Apr 25, 2013 17:29
Location: SP-Brasil
GitHub: BrunoMine

by BrunoMine » Mon Sep 16, 2013 21:07

I saw you on the server.
The other players were able to see the signs normally.
Perhaps this is because of different coding.
Use windows 7.
My small square universe under construction ... Minemacro
Comunidade Minetest Brasil
www.minetestbrasil.com
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

by PilzAdam » Tue Sep 17, 2013 01:28

brunob.santos wrote:Use windows 7.

NO!

Wuzzy wrote:Hi, if I join the server Minemacro 1.0 Brasil and look on a sign, most likely I see the text “<invalid multibyte string>”.

What went wrong here? Do other players experience this problem, too?

I use GNU/Linux; Linux 3.9.4 and Minetest 0.4.8.

There is no Minetest 0.4.8....
Anyway, does your Minetest build have freetype support compiled in?
 

User avatar
BrunoMine
Member
 
Posts: 1046
Joined: Thu Apr 25, 2013 17:29
Location: SP-Brasil
GitHub: BrunoMine

by BrunoMine » Tue Sep 17, 2013 14:30

PilzAdam wrote:NO!


I use windowns 7. only warning.
My small square universe under construction ... Minemacro
Comunidade Minetest Brasil
www.minetestbrasil.com
 

User avatar
Wuzzy
Member
 
Posts: 3427
Joined: Mon Sep 24, 2012 15:01
GitHub: Wuzzy2
IRC: Wuzzy
In-game: Wuzzy

by Wuzzy » Tue Sep 17, 2013 21:43

Whoops, I meant of couse version 0.4.7.

PilzAdam wrote:
brunob.santos wrote:Use windows 7.

NO!


lol

I don’t know wheather I had FreeType support. I was using the Arch Linux build.

Anyways, I just built version 0.4.7 from source with the FREETYPE flag set. Then I joined the server again but there were still the invalid multibyte strings. :-(

On this new build I also made a new test. I started a new minetest_game world and placed a sign and used a text with the character “ü” in it. This character wasn’t printed, instead there was a long space instead of the “ü” which was about double as long as the character would have been. After I saved the sign text and reopened the dialog, the text looked the same as before; no “<invalid multibyte-string>”
Last edited by Wuzzy on Tue Sep 17, 2013 21:47, edited 1 time in total.
My creations. I gladly accept bitcoins: 17fsUywHxeMHKG41UFfu34F1rAxZcrVoqH
 

User avatar
orwell
Member
 
Posts: 778
Joined: Wed Jun 24, 2015 18:45
Location: Raxacoricofallapatorius
GitHub: orwell96
IRC: orwell96_mt
In-game: orwell

Re: “<invalid multibyte string>” on most signs on the Minema

by orwell » Sun Jul 05, 2015 16:48

I had that invalid multibyte string problem too: server hosted on a windows machine, any linux clients got only invalid multibyte strings.
found out that this is about umlauts like ä, ö, ü, ß. windows saved these in an encoding differing from utf8. of course, other windows clients could read them, but linux had problems there.
solution: convert these umlauts to utf8 encoding.
maybe this is the problem of the minemacro server too. don't know this server, but if they use non-ascii chars, they should ensure using utf8 for them.

EDIT: My problem was regarding umlauts hardcoded into lua code which was saved by windows in another text encoding. Possibly, the minetest windows build sends text in this strange windows-specific encoding, and the server-side lua has to do an encoding conversion before saving the sign text.
Lua is great!
List of my mods
I like singing. I like dancing. I like ... niyummm...
 

User avatar
jogag
Member
 
Posts: 106
Joined: Wed Aug 12, 2015 18:32
Location: Online
GitHub: jogag
IRC: jogag
In-game: jogag

Re: “<invalid multibyte string>” on most signs on the Minema

by jogag » Sun Aug 16, 2015 10:31

orwell wrote:server hosted on a windows machine, any linux clients got only invalid multibyte strings.


Windows server?????
I think changing the server OS would be a GOOD idea.

This happens because the minetest_game saves the sign text in the map file, which is saved by the Windows kernel in a proprietary format, not in UTF-8. The map saves correctly because it does not contain non-ascii characters, but the sign text will be encoded because it contains those characters.
When the game reads that file, it reads the windows encoding, and sends the text encoded in the microsoft format.
Windows clients can properly show the string, while Linux clients fail and show the "<invalid multibyte string>" warning on the signs.

So the best solution is changing the OS of the server, from windows to linux.
This is because the 99% of the world servers use Linux. :D
 

User avatar
addi
Member
 
Posts: 658
Joined: Thu Sep 20, 2012 03:16
Location: Black-Forest, Germany
GitHub: adrido

Re: “<invalid multibyte string>” on most signs on the Minema

by addi » Sun Aug 16, 2015 11:53

jogag wrote:...
This happens because the minetest_game saves the sign text in the map file, which is saved by the Windows kernel in a proprietary format, not in UTF-8. The map saves correctly because it does not contain non-ascii characters, but the sign text will be encoded because it contains those characters.
When the game reads that file, it reads the windows encoding, and sends the text encoded in the microsoft format.
Windows clients can properly show the string, while Linux clients fail and show the "<invalid multibyte string>" warning on the signs.
...

rofl. You are completely wrong. 1. minetest_game saves nothing. The minetest engine saves the map. 2. The map is not saved by Windows kernel, its saved by minetest engine. 3. its not a proprietary format, its saved as blob value in a sqlite database. (or any other database that minetest supports).
All in all it does not care witch OS server or clients are using. The bug only happens, because minetest has a terrible support for Umlauts (äöü) or other special chars and is different from version to version.

BTW: This thread is relay old and the problem is maybe already solved.
 

Dragonop
Member
 
Posts: 1178
Joined: Tue Oct 23, 2012 12:59
Location: Argentina
GitHub: Dragonop
IRC: Dragonop
In-game: Dragonop

Re: “<invalid multibyte string>” on most signs on the Minema

by Dragonop » Sun Aug 16, 2015 22:02

jogag wrote:Windows server?????
I think changing the server OS would be a GOOD idea.

I think you have a serious fanatisism problem.
Sorry about this offtopic post.
 

User avatar
jogag
Member
 
Posts: 106
Joined: Wed Aug 12, 2015 18:32
Location: Online
GitHub: jogag
IRC: jogag
In-game: jogag

Re: “<invalid multibyte string>” on most signs on the Minema

by jogag » Thu Aug 20, 2015 17:01

Dragonop wrote:
jogag wrote:Windows server?????
I think changing the server OS would be a GOOD idea.

I think you have a serious fanatisism problem.
Sorry about this offtopic post.

I started hating windows when I detected a trojan in my laptop for the first time. Then I switched to linux, which is better for me. :)
 

User avatar
jogag
Member
 
Posts: 106
Joined: Wed Aug 12, 2015 18:32
Location: Online
GitHub: jogag
IRC: jogag
In-game: jogag

Re: “<invalid multibyte string>” on most signs on the Minema

by jogag » Thu Aug 20, 2015 17:07

addi wrote:
jogag wrote:...
This happens because the minetest_game saves the sign text in the map file, which is saved by the Windows kernel in a proprietary format, not in UTF-8. The map saves correctly because it does not contain non-ascii characters, but the sign text will be encoded because it contains those characters.
When the game reads that file, it reads the windows encoding, and sends the text encoded in the microsoft format.
Windows clients can properly show the string, while Linux clients fail and show the "<invalid multibyte string>" warning on the signs.
...

rofl. You are completely wrong. 1. minetest_game saves nothing. The minetest engine saves the map. 2. The map is not saved by Windows kernel, its saved by minetest engine. 3. its not a proprietary format, its saved as blob value in a sqlite database. (or any other database that minetest supports).
All in all it does not care witch OS server or clients are using. The bug only happens, because minetest has a terrible support for Umlauts (äöü) or other special chars and is different from version to version.

BTW: This thread is relay old and the problem is maybe already solved.

Oh, this is because I don't know much of windows, and minetest is made without thinking about issues with these characters... and Minetest is made and tested mostly on linux, so it's not often tested on windows. (thanks to people which test MT on windows!!!)
 

Dragonop
Member
 
Posts: 1178
Joined: Tue Oct 23, 2012 12:59
Location: Argentina
GitHub: Dragonop
IRC: Dragonop
In-game: Dragonop

Re: “<invalid multibyte string>” on most signs on the Minema

by Dragonop » Thu Aug 20, 2015 22:12

jogag, Minetest is usually tested on Windows and a bunch of distros. (some devs use Windows as main)
You got the trojan because you didn't use the software that you need to avoid that stuff, or you downloaded illegal stuff (not actually a risk if you know how).
Also, Linux also has viruses, thinking that it doesn't or saying that you have less riks is just dumb. (almost all the stuff is community created....)
You actually wont ever get any virus if you don't download a lot of stuff (witch I actually do, and I never get any viruses btw )

EDIT: what does this has to do with server hosting (I mean, you getting a trojan is not a valid option)
 

User avatar
jogag
Member
 
Posts: 106
Joined: Wed Aug 12, 2015 18:32
Location: Online
GitHub: jogag
IRC: jogag
In-game: jogag

Re: “<invalid multibyte string>” on most signs on the Minema

by jogag » Sat Aug 22, 2015 11:26

Dragonop wrote:jogag, Minetest is usually tested on Windows and a bunch of distros. (some devs use Windows as main)
You got the trojan because you didn't use the software that you need to avoid that stuff, or you downloaded illegal stuff (not actually a risk if you know how).
Also, Linux also has viruses, thinking that it doesn't or saying that you have less riks is just dumb. (almost all the stuff is community created....)
You actually wont ever get any virus if you don't download a lot of stuff (witch I actually do, and I never get any viruses btw )

EDIT: what does this has to do with server hosting (I mean, you getting a trojan is not a valid option)

I simply tried linux and I started using it because I wanted to switch OS.
And yes, there are windows developers, but I think most developers are on linux.
(There are viruses for linux, but they don't explode your pc while coding, and they want root password I don't give).
 

User avatar
BrunoMine
Member
 
Posts: 1046
Joined: Thu Apr 25, 2013 17:29
Location: SP-Brasil
GitHub: BrunoMine

Re: “<invalid multibyte string>” on most signs on the Minema

by BrunoMine » Thu Jul 21, 2016 18:37

I changed my operating system but the problem still occurs. I'm using ubuntu server.
Image
 

User avatar
BrunoMine
Member
 
Posts: 1046
Joined: Thu Apr 25, 2013 17:29
Location: SP-Brasil
GitHub: BrunoMine
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 3 guests