OpenGL driver version is not 1.2 or better.

Post Reply
User avatar
equeim
New member
Posts: 2
Joined: Mon Nov 25, 2013 16:28

OpenGL driver version is not 1.2 or better.

by equeim » Post

I have Arch Linux with NVIDIA GeForce GT440 (proprietary driver 331.20).

Code: Select all

[alexey@boberarch ~]$ minetest
Irrlicht Engine version 1.8.1
Linux 3.12.1-1-ARCH #1 SMP PREEMPT Thu Nov 21 08:18:42 CET 2013 x86_64
Using renderer: OpenGL 
OpenGL driver version is not 1.2 or better.
Warning: OpenGL device only has one texture unit. Disabling multitexturing.
GLSL not available.
Screenshot of main menu:
Image

When I launch with --go it crashes:

Code: Select all

[alexey@boberarch ~]$ minetest --name equeim --go
Irrlicht Engine version 1.8.1
Linux 3.12.1-1-ARCH #1 SMP PREEMPT Thu Nov 21 08:18:42 CET 2013 x86_64
Using renderer: OpenGL 
OpenGL driver version is not 1.2 or better.
Warning: OpenGL device only has one texture unit. Disabling multitexturing.
GLSL not available.
20:36:04: ACTION[main]:         .__               __                   __   
20:36:04: ACTION[main]:   _____ |__| ____   _____/  |_  ____   _______/  |_ 
20:36:04: ACTION[main]:  /     \|  |/    \_/ __ \   __\/ __ \ /  ___/\   __\
20:36:04: ACTION[main]: |  Y Y  \  |   |  \  ___/|  | \  ___/ \___ \  |  |  
20:36:04: ACTION[main]: |__|_|  /__|___|  /\___  >__|  \___  >____  > |__|  
20:36:04: ACTION[main]:       \/        \/     \/          \/     \/        
20:36:04: ACTION[main]: World at [/home/alexey/.minetest/worlds/world]
20:36:04: ACTION[main]: Server for gameid="minetest" listening on port 30000.
20:36:04: ACTION[ServerThread]: equeim [127.0.0.1] joins game. List of players: equeim 
Could not open file of texture: character.png
Loaded mesh: character.x
PNG warning: Interlace handling should be turned on when using png_read_image
PNG warning: Interlace handling should be turned on when using png_read_image
Floating point exception (core dumped)
I have tried versions from git and from repository. Result is the same.

Other games works fine.
What could be the problem?

User avatar
Inocudom
Member
Posts: 3085
Joined: Sat Sep 29, 2012 01:14
IRC: Inocudom
In-game: Inocudom

by Inocudom » Post

Is it possible for you to update your OpenGL version? You really should if you can, so check on NVIDIA's website for up-to-date drivers.
You can now find my videos at BitChute: https://www.bitchute.com/channel/some_cheeky_jinuskian/

User avatar
Krock
Developer
Posts: 4508
Joined: Thu Oct 03, 2013 07:48
GitHub: SmallJoker
Location: Switzerland
Contact:

by Krock » Post

You could try out the Direct3D9 renderer, even if there is a small chance, that it will work for you.
Give it a try and open your minetest.conf and edit the renderer from "opengl" to "direct3d9"
Look, I programmed a bug for you. >> Mod Search Engine << - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>

User avatar
equeim
New member
Posts: 2
Joined: Mon Nov 25, 2013 16:28

by equeim » Post

Inocudom wrote:Is it possible for you to update your OpenGL version? You really should if you can, so check on NVIDIA's website for up-to-date drivers.
Drivers are latest, my OpenGL version is 4.4.0
Krock wrote:You could try out the Direct3D9 renderer, even if there is a small chance, that it will work for you.
Give it a try and open your minetest.conf and edit the renderer from "opengl" to "direct3d9"

Code: Select all

This driver is not available in Linux. Try OpenGL or Software renderer.

User avatar
KillerByte
New member
Posts: 1
Joined: Wed Nov 27, 2013 04:15

by KillerByte » Post

I am having the exact same problem. I have an Arch Linux system with a NVidia GeForce GT 610.

I was not having issues with this before however. I only upgraded yesterday and this problem started occouring. Irrlicht bug?

UPDATE:

I think this thread is related to the problem posted here: viewtopic.php?id=7828, I will try rebuilding.

UPDATE2:

Rebuilding didnt work for me...
Last edited by KillerByte on Wed Nov 27, 2013 05:16, edited 1 time in total.

User avatar
Zeg9
Member
Posts: 608
Joined: Fri Sep 21, 2012 11:02
Location: France

by Zeg9 » Post

I just downloaded the latest minetest from the arch repo...
And I have the exact same problem, with a GTX 660 !
The irrlicht demo (quake 3 map) uses OpenGL 4.4.0 and displays without any problem.
Please note that it works on another machine that doesn't have an nvidia card.

I'll rebuild it in a few minutes and edit this post.
EDIT: Ok, it works!
Built from git, checkout 0.4.8, and default compile options.
Last edited by Zeg9 on Wed Nov 27, 2013 17:56, edited 1 time in total.
I made a few (a lot of?) mods for minetest: here is a list.
See also the MT-Faithful texture pack (work in progress).

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest