error message, game won't even open

teke0884
New member
 
Posts: 1
Joined: Mon Jan 30, 2012 02:08

error message, game won't even open

by teke0884 » Mon Jan 30, 2012 02:12

here's the debug log i got when i tried to run minetest. I tried to run this tree times, and each time, it crashed without even loading the game.




Code: Select all
 -------------
  Separator 
-------------

Debug streams initialized, disable_stderr=1
21:04:18: ACTION[main]: minetest with SER_FMT_VER_HIGHEST=20, VER=0.3.1 RUN_IN_PLACE=1 USE_GETTEXT=0 INSTALL_PREFIX=//Vboxsvr/home-celeron55/minetest_install_win32 BUILD_TYPE=Release
21:04:18: INFO[main]: Parsing configuration file: "C:\Documents and Settings\Grant\Desktop\minetest-0.3.1-win32\minetest-0.3.1-win32\bin\..\minetest.conf"
INFO: Initial run of init_mapnode with g_texturesource=NULL. If this segfaults, there is a bug with something not checking for the NULL value.
21:04:18: INFO[main]: Settings: Setting not found: "enable-unittests"
21:04:18: INFO[main]: Settings: Setting not found: "server"
21:04:18: INFO[main]: TextureSource::buildMainAtlas()
21:04:18: INFO[main]: Creating texture atlas out of textures: "[noalpha:leaves.png" "apple.png" "bookshelf.png" "brick.png" "cactus_side.png" "cactus_top.png" "chest_front.png" "chest_lock.png" "chest_side.png" "chest_top.png" "clay.png" "cloud.png" "cobble.png" "fence.png" "furnace_front.png" "furnace_side.png" "glass.png" "grass.png" "grass_footsteps.png" "gravel.png" "junglegrass.png" "jungletree.png" "jungletree_top.png" "ladder.png" "lava.png" "mese.png" "mossycobble.png" "mud.png" "mud.png^grass_side.png" "nc_back.png" "nc_front.png" "nc_rb.png" "nc_side.png" "papyrus.png" "rail.png" "sand.png" "sandstone.png" "sapling.png" "sign_wall.png" "steel_block.png" "stone.png" "stone.png^mineral_coal.png" "stone.png^mineral_iron.png" "torch.png" "torch_on_ceiling.png" "torch_on_floor.png" "tree.png" "tree_top.png" "unknown_block.png" "unknown_block.png^mineral_coal.png" "unknown_block.png^mineral_iron.png" "wood.png"
21:04:18: INFO[main]: generate_image(): generating special modification "[noalpha:leaves.png"
21:04:18: INFO[main]: generate_image(): Loading path "C:\Documents and Settings\Grant\Desktop\minetest-0.3.1-win32\minetest-0.3.1-win32\bin\..\data/leaves.png"
21:04:18: INFO[main]: TextureSource::buildMainAtlas(): Adding "[noalpha:leaves.png" to texture atlas
In trans_func.
21:04:18: ERROR[main]: ERROR: An unhandled exception occurred: Illegal instruction

In thread f4:
C:\tmp\minetest\src\main.cpp:1712: main: Assertion '0' failed.
Debug stacks:
DEBUG STACK FOR THREAD f4:
#0  main


-------------
  Separator 
-------------

Debug streams initialized, disable_stderr=1
21:04:46: ACTION[main]: minetest with SER_FMT_VER_HIGHEST=20, VER=0.3.1 RUN_IN_PLACE=1 USE_GETTEXT=0 INSTALL_PREFIX=//Vboxsvr/home-celeron55/minetest_install_win32 BUILD_TYPE=Release
21:04:46: INFO[main]: Parsing configuration file: "C:\Documents and Settings\Grant\Desktop\minetest-0.3.1-win32\minetest-0.3.1-win32\bin\..\minetest.conf"
INFO: Initial run of init_mapnode with g_texturesource=NULL. If this segfaults, there is a bug with something not checking for the NULL value.
21:04:46: INFO[main]: Settings: Setting not found: "enable-unittests"
21:04:46: INFO[main]: Settings: Setting not found: "server"
21:04:46: INFO[main]: TextureSource::buildMainAtlas()
21:04:46: INFO[main]: Creating texture atlas out of textures: "[noalpha:leaves.png" "apple.png" "bookshelf.png" "brick.png" "cactus_side.png" "cactus_top.png" "chest_front.png" "chest_lock.png" "chest_side.png" "chest_top.png" "clay.png" "cloud.png" "cobble.png" "fence.png" "furnace_front.png" "furnace_side.png" "glass.png" "grass.png" "grass_footsteps.png" "gravel.png" "junglegrass.png" "jungletree.png" "jungletree_top.png" "ladder.png" "lava.png" "mese.png" "mossycobble.png" "mud.png" "mud.png^grass_side.png" "nc_back.png" "nc_front.png" "nc_rb.png" "nc_side.png" "papyrus.png" "rail.png" "sand.png" "sandstone.png" "sapling.png" "sign_wall.png" "steel_block.png" "stone.png" "stone.png^mineral_coal.png" "stone.png^mineral_iron.png" "torch.png" "torch_on_ceiling.png" "torch_on_floor.png" "tree.png" "tree_top.png" "unknown_block.png" "unknown_block.png^mineral_coal.png" "unknown_block.png^mineral_iron.png" "wood.png"
21:04:46: INFO[main]: generate_image(): generating special modification "[noalpha:leaves.png"
21:04:46: INFO[main]: generate_image(): Loading path "C:\Documents and Settings\Grant\Desktop\minetest-0.3.1-win32\minetest-0.3.1-win32\bin\..\data/leaves.png"
21:04:46: INFO[main]: TextureSource::buildMainAtlas(): Adding "[noalpha:leaves.png" to texture atlas
In trans_func.
21:04:46: ERROR[main]: ERROR: An unhandled exception occurred: Illegal instruction

In thread 518:
C:\tmp\minetest\src\main.cpp:1712: main: Assertion '0' failed.
Debug stacks:
DEBUG STACK FOR THREAD 518:
#0  main


-------------
  Separator 
-------------

Debug streams initialized, disable_stderr=1
21:05:54: ACTION[main]: minetest with SER_FMT_VER_HIGHEST=20, VER=0.3.1 RUN_IN_PLACE=1 USE_GETTEXT=0 INSTALL_PREFIX=//Vboxsvr/home-celeron55/minetest_install_win32 BUILD_TYPE=Release
21:05:54: INFO[main]: Parsing configuration file: "C:\Documents and Settings\Grant\Desktop\minetest-0.3.1-win32\minetest-0.3.1-win32\bin\..\minetest.conf"
INFO: Initial run of init_mapnode with g_texturesource=NULL. If this segfaults, there is a bug with something not checking for the NULL value.
21:05:54: INFO[main]: Settings: Setting not found: "enable-unittests"
21:05:54: INFO[main]: Settings: Setting not found: "server"
21:05:54: INFO[main]: TextureSource::buildMainAtlas()
21:05:54: INFO[main]: Creating texture atlas out of textures: "[noalpha:leaves.png" "apple.png" "bookshelf.png" "brick.png" "cactus_side.png" "cactus_top.png" "chest_front.png" "chest_lock.png" "chest_side.png" "chest_top.png" "clay.png" "cloud.png" "cobble.png" "fence.png" "furnace_front.png" "furnace_side.png" "glass.png" "grass.png" "grass_footsteps.png" "gravel.png" "junglegrass.png" "jungletree.png" "jungletree_top.png" "ladder.png" "lava.png" "mese.png" "mossycobble.png" "mud.png" "mud.png^grass_side.png" "nc_back.png" "nc_front.png" "nc_rb.png" "nc_side.png" "papyrus.png" "rail.png" "sand.png" "sandstone.png" "sapling.png" "sign_wall.png" "steel_block.png" "stone.png" "stone.png^mineral_coal.png" "stone.png^mineral_iron.png" "torch.png" "torch_on_ceiling.png" "torch_on_floor.png" "tree.png" "tree_top.png" "unknown_block.png" "unknown_block.png^mineral_coal.png" "unknown_block.png^mineral_iron.png" "wood.png"
21:05:54: INFO[main]: generate_image(): generating special modification "[noalpha:leaves.png"
21:05:54: INFO[main]: generate_image(): Loading path "C:\Documents and Settings\Grant\Desktop\minetest-0.3.1-win32\minetest-0.3.1-win32\bin\..\data/leaves.png"
21:05:54: INFO[main]: TextureSource::buildMainAtlas(): Adding "[noalpha:leaves.png" to texture atlas
In trans_func.
21:05:54: ERROR[main]: ERROR: An unhandled exception occurred: Illegal instruction

In thread 4b0:
C:\tmp\minetest\src\main.cpp:1712: main: Assertion '0' failed.
Debug stacks:
DEBUG STACK FOR THREAD 4b0:
#0  main
 

User avatar
jji7skyline
Member
 
Posts: 28
Joined: Tue Jan 31, 2012 01:39
 

User avatar
RabbiBob
Member
 
Posts: 335
Joined: Sat Jan 28, 2012 22:40
Location: /teleport 54,47,28

by RabbiBob » Tue Jan 31, 2012 02:49

Looks like WinXP.

I had the same issue and only found this post with any info on it:

http://c55.me/minetest/forum/viewtopic.php?id=406

Oddly enough, I put Ubuntu on the PC I was having that issue on and it's run MT fine since.
 


Return to Problems



Who is online

Users browsing this forum: MSN [Bot] and 3 guests