[ModPack] Necessary Mod Pack

User avatar
InterVi
Member
 
Posts: 32
Joined: Wed Jul 05, 2017 08:22
Location: Russia, Moscow
GitHub: InterVi
IRC: InterVi
In-game: InterVi

[ModPack] Necessary Mod Pack

by InterVi » Mon Oct 23, 2017 13:33

The most necessary mods. List:

  • Essentials - more commands (spawn, warps, homes, mutes, bans, vanish and etc)
  • Bug Report - GUI form for sending information to log
  • PVP Control - protect newbies and other
  • Superchat - chat channels and prefixes, filters
  • Stats - server online statistic
  • Query - easy socket server for sending server info
  • Coins - easy money
  • Group Perms - manage privs in player groups
  • Gui Menu - convenient control buttons
  • Mod Configs - libray for easy manage config files
  • Cuboids Lib - libray for coordinate operitions

Github: https://github.com/RuMinetestCoder/necessary_pack
Download latest: https://github.com/RuMinetestCoder/nece ... master.zip
 

User avatar
ManElevation
Member
 
Posts: 896
Joined: Tue Aug 02, 2016 22:04
Location: Madrid,Spain
GitHub: ManElevation
IRC: ManElevation
In-game: ManElevation
 

User avatar
azekill_DIABLO
Member
 
Posts: 7489
Joined: Wed Oct 29, 2014 20:05
Location: OMICRON
GitHub: azekillDIABLO
In-game: azekill_DIABLO
 

User avatar
TheGreatCoffeeKing99
Member
 
Posts: 26
Joined: Fri Sep 09, 2016 23:42
In-game: Coffee99

Re: [ModPack] Necessary Mod Pack

by TheGreatCoffeeKing99 » Sat Nov 25, 2017 19:27

I have a bug:
On attempting to load the world, it has an issue with
"require()" being disabled when mod security is on.

Thank you.
Hi. I don't have any published mods yet.
 

01savior10
New member
 
Posts: 8
Joined: Fri Apr 21, 2017 14:23
In-game: 01savior10
 

ShadMOrdre
Member
 
Posts: 471
Joined: Mon Dec 29, 2014 08:07
Location: USA
GitHub: ShadMOrdre
In-game: shadmordre

Re: [ModPack] Necessary Mod Pack

by ShadMOrdre » Wed Nov 29, 2017 23:37

I get the same issue regarding "require", but do not have mod security enabled, so I don't think it is related.

The require statement in the lua refers to minifs, inifile, lyaml, and rapidjson. None of these are included, and are certainly not part of Minetest. So what is actually "required" here.

This modpack does not work with v0500 dev release or v0416 stable on Windows.

What am I doing wrong, or is this modpack incomplete?
MY MODS: lib_ecology lib_materials lib_clouds lib_node_shapes ---- Inspired By: Open Source Virtual World Simulator Opensimulator.
 

01savior10
New member
 
Posts: 8
Joined: Fri Apr 21, 2017 14:23
In-game: 01savior10

Re: [ModPack] Necessary Mod Pack

by 01savior10 » Fri Dec 01, 2017 15:40

TheGreatCoffeeKing99 wrote:I have a bug:
On attempting to load the world, it has an issue with
"require()" being disabled when mod security is on.

Thank you.


x2
 

User avatar
InterVi
Member
 
Posts: 32
Joined: Wed Jul 05, 2017 08:22
Location: Russia, Moscow
GitHub: InterVi
IRC: InterVi
In-game: InterVi

Re: [ModPack] Necessary Mod Pack

by InterVi » Tue Dec 05, 2017 04:41

Need install librays. For mod_configs:
Code: Select all
luarocks-5.1 install minifs
luarocks-5.1 install inifile
luarocks-5.1 install lyaml
luarocks-5.1 install rapidjson


For Query:
Code: Select all
luarocks-5.1 install effil
pacman -S lua51-socket


This info is written in readme files. Ok, i will change main readme.
 


Return to WIP Mods



Who is online

Users browsing this forum: Steamed_Punk and 6 guests