[Mod] Petz [v14.5] [petz]

Replace lamb with new models [viewtopic.php?p=372165#p372165]?

Yeah!
6
35%
Nope.
11
65%
 
Total votes: 17

User avatar
runs
Member
Posts: 1637
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.0)

by runs » Post

Bread wrote:I like this mod(Mobkit Version).

I am playing with awards mod. I have seen this error.

Code: Select all

ModError: Failed to load and run script from U:\minetest\minetest-5.1.0-d77ea76-win64\bin\..\mods\petz\petz\init.lua:
....1.0-d77ea76-win64\bin\..\mods\petz\petz/misc/awards.lua:1: attempt to index global 'awards' (a nil value)
stack traceback:
	....1.0-d77ea76-win64\bin\..\mods\petz\petz/misc/awards.lua:1: in main chunk
	...etest-5.1.0-d77ea76-win64\bin\..\mods\petz\petz\init.lua:46: in main chunk
I think awards should be in optional_depends in mod.conf. It works when I do it.
No, awards is still not implemented so had to be not loaded. Fixed.
Day 42 of the quarantine

User avatar
rubenwardy
Moderator
Posts: 6156
Joined: Tue Jun 12, 2012 18:11
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy
Location: United Kingdom
Contact:

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.0)

by rubenwardy » Post

runs wrote:v4.1
- Fix: Remove awards.
The error is because the mod doesn't soft depend on awards, so awards isn't loaded first. However, given that there's only a single awards it's probably best to disable awards support for now

User avatar
runs
Member
Posts: 1637
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.0)

by runs » Post

rubenwardy wrote:
runs wrote:v4.1
- Fix: Remove awards.
The error is because the mod doesn't soft depend on awards, so awards isn't loaded first. However, given that there's only a single awards it's probably best to disable awards support for now
Ah, OK. I will work in awards soon.
Day 42 of the quarantine

User avatar
runs
Member
Posts: 1637
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1)

by runs » Post

v4.1.1
Fix thanks to fluxionary
- Fix order of operations for computing baby pony stats. The stats for a baby horse were half the father's stats +/- 1
Day 42 of the quarantine

User avatar
runs
Member
Posts: 1637
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1.1)

by runs » Post

v4.1.2
- 'Sperm' word changed to 'germ' to match the ContentDB terms of use and in aim to being more children friendly.
Day 42 of the quarantine

User avatar
Linuxdirk
Member
Posts: 2539
Joined: Wed Sep 17, 2014 11:21
In-game: Linuxdirk
Location: Germany
Contact:

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1.2)

by Linuxdirk » Post

"Sperm" and "germ" describe two completely different things. Sperm also is the scientifically correct term.

Maybe use "seed" to make it PG0 friendly. Still a wrong term but better than "germ". Or a slightly more general term like "fertilization fluid". But you totally wont get the same result from sperm and germs :)

User avatar
runs
Member
Posts: 1637
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1.2)

by runs » Post

v4.1.3
- 'Germ' word changed to 'Seed'. :-D
Day 42 of the quarantine

User avatar
runs
Member
Posts: 1637
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1.2)

by runs » Post

Linuxdirk wrote:"Sperm" and "germ" describe two completely different things. Sperm also is the scientifically correct term.

Maybe use "seed" to make it PG0 friendly. Still a wrong term but better than "germ". Or a slightly more general term like "fertilization fluid". But you totally wont get the same result from sperm and germs :)
Germ is not only a pathogen but the origin of something.

But you are right, it is better 'seed' :-D
Day 42 of the quarantine

User avatar
runs
Member
Posts: 1637
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1.3)

by runs » Post

v4.1.4
- Updated to mobkit version 191008
Day 42 of the quarantine

User avatar
runs
Member
Posts: 1637
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1.4)

by runs » Post

v4.1.5
Fixed regression: No swin animations. Now swin animations are defined as "def" as in mobkit.
Day 42 of the quarantine

User avatar
runs
Member
Posts: 1637
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1.5)

by runs » Post

Cooming soon...

Image

Downloads in ContentDB.

A new mob to celebrate.

Image
Day 42 of the quarantine

User avatar
cHyper-0815OL
Member
Posts: 75
Joined: Fri Sep 13, 2019 17:40
GitHub: cHyper-0815OL
In-game: cHyper cHyper-0815OL
Location: Austria
Contact:

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1.5)

by cHyper-0815OL » Post

runs wrote:Cooming soon...

Image

Downloads in ContentDB.

A new mob to celebrate.

Image
nice and awesome mob package!

User avatar
runs
Member
Posts: 1637
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1.5)

by runs » Post

v4.1.6
- Improved/recoded the fly behaviour, now less intensive.
- No more flying backwards.
- Flying mobs now recover from water.
Day 42 of the quarantine

User avatar
runs
Member
Posts: 1637
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by runs » Post

v4.2
Image
Toucan
-It lives in the jungle.
-It eats apples.
-Tamable. You can put it in a bird stand.

-API: Recoded the load of the settings. Now in a 'for' loop automatically.
Day 42 of the quarantine

Stronk
Member
Posts: 13
Joined: Sat Jul 20, 2019 08:13

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by Stronk » Post

Had no problems until I clicked the "update" button today. Now your mod is broken and says there needs to be an init file in textures.

"Failed to load and run script from .......petz/textures/init.lua
no such file or directory...

Any fix for this? Was this a mistake or?

Bread
Member
Posts: 39
Joined: Tue Mar 17, 2015 14:29

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by Bread » Post

Code: Select all

2019-10-14 15:12:14: ERROR[Server]: LuaEntity name "petz:bee" not defined
This error has been shown. And unknown entity is there in this world.
I have not touched any code(Mobkit Version).

Image
Attachments
petzbee.png
(302.16 KiB) Not downloaded yet

User avatar
runs
Member
Posts: 1637
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by runs » Post

Bread wrote:

Code: Select all

2019-10-14 15:12:14: ERROR[Server]: LuaEntity name "petz:bee" not defined
This error has been shown. And unknown entity is there in this world.
I have not touched any code(Mobkit Version).

Image
Its rare open petz.conf and check that "bee_spawn = false". Or maybe an old version spawned some bees (I remember that setting true by error). So kill them.
Day 42 of the quarantine

User avatar
runs
Member
Posts: 1637
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by runs » Post

Stronk wrote:Had no problems until I clicked the "update" button today. Now your mod is broken and says there needs to be an init file in textures.

"Failed to load and run script from .......petz/textures/init.lua
no such file or directory...

Any fix for this? Was this a mistake or?

Updated from ContentDB?

Android? PC?
Day 42 of the quarantine

Bread
Member
Posts: 39
Joined: Tue Mar 17, 2015 14:29

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by Bread » Post

runs wrote:Its rare open petz.conf and check that "bee_spawn = false". Or maybe an old version spawned some bees (I remember that setting true by error). So kill them.
I just downloaded Petz v4.2 Modpack and copied them into mods folder manualy, created a new world(v6) and only enabled Petz Modpack. However it happens again.

Code: Select all

2019-10-14 18:25:01: ERROR[Server]: LuaEntity name "petz:bee" not defined
My PC is Windwos10 64bit. It is singleplayer game.

Here is the Spawn Mobs section in the petz.conf.

Code: Select all

##Spawn Mobs?
kitty_spawn = true
puppy_spawn = true
ducky_spawn = true
beaver_spawn = true
lamb_spawn = true
lion_spawn = true
calf_spawn = true
panda_spawn = true
frog_spawn = true
grizzly_spawn = true
pony_spawn = true
parrot_spawn= true
chicken_spawn = true
chimp_spawn = true
pigeon_spawn = true
turtle_spawn = true
clownfish_spawn = true
tropicalfish_spawn = true
wolf_spawn = true
elephant_spawn = true
elephant_female_spawn = true
moth_spawn = true
camel_spawn = true
bat_spawn = true
silkworm_spawn = true
chimp_spawn = true
hamster_spawn = true
dolphin_spawn = true
toucan_spawn = true
bee_spawn = false

Stronk
Member
Posts: 13
Joined: Sat Jul 20, 2019 08:13

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by Stronk » Post

runs wrote:
Stronk wrote:Had no problems until I clicked the "update" button today. Now your mod is broken and says there needs to be an init file in textures.

"Failed to load and run script from .......petz/textures/init.lua
no such file or directory...

Any fix for this? Was this a mistake or?

Updated from ContentDB?

Android? PC?
PC and I clicked the "update" button from inside the game contentDB menu. I think the above person might have the same issue. I didn't realize it had been disabled and I was seeing that error being spammed everywhere. Checked and re-enabled.. Instant crash every time I start the server with it enabled now.

Edit: I see that they are JUST using the Petz mod. I did the same thing. Only mod running is Petz and it crashes instantly just the same.

User avatar
runs
Member
Posts: 1637
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2.1)

by runs » Post

v4.2.1
- Removed the bee references till released.
Day 42 of the quarantine

User avatar
runs
Member
Posts: 1637
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by runs » Post

Bread wrote:
runs wrote:Its rare open petz.conf and check that "bee_spawn = false". Or maybe an old version spawned some bees (I remember that setting true by error). So kill them.
I just downloaded Petz v4.2 Modpack and copied them into mods folder manualy, created a new world(v6) and only enabled Petz Modpack. However it happens again.

Code: Select all

2019-10-14 18:25:01: ERROR[Server]: LuaEntity name "petz:bee" not defined
My PC is Windwos10 64bit. It is singleplayer game.

Here is the Spawn Mobs section in the petz.conf.

Code: Select all

##Spawn Mobs?
kitty_spawn = true
puppy_spawn = true
ducky_spawn = true
beaver_spawn = true
lamb_spawn = true
lion_spawn = true
calf_spawn = true
panda_spawn = true
frog_spawn = true
grizzly_spawn = true
pony_spawn = true
parrot_spawn= true
chicken_spawn = true
chimp_spawn = true
pigeon_spawn = true
turtle_spawn = true
clownfish_spawn = true
tropicalfish_spawn = true
wolf_spawn = true
elephant_spawn = true
elephant_female_spawn = true
moth_spawn = true
camel_spawn = true
bat_spawn = true
silkworm_spawn = true
chimp_spawn = true
hamster_spawn = true
dolphin_spawn = true
toucan_spawn = true
bee_spawn = false
Check the aast version, please.
Day 42 of the quarantine

User avatar
runs
Member
Posts: 1637
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by runs » Post

Stronk wrote:
runs wrote:
Stronk wrote:Had no problems until I clicked the "update" button today. Now your mod is broken and says there needs to be an init file in textures.

"Failed to load and run script from .......petz/textures/init.lua
no such file or directory...

Any fix for this? Was this a mistake or?

Updated from ContentDB?

Android? PC?
PC and I clicked the "update" button from inside the game contentDB menu. I think the above person might have the same issue. I didn't realize it had been disabled and I was seeing that error being spammed everywhere. Checked and re-enabled.. Instant crash every time I start the server with it enabled now.

Edit: I see that they are JUST using the Petz mod. I did the same thing. Only mod running is Petz and it crashes instantly just the same.
Check the last version, please.
Day 42 of the quarantine

Stronk
Member
Posts: 13
Joined: Sat Jul 20, 2019 08:13

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2.1)

by Stronk » Post

How would I do that?

Bread
Member
Posts: 39
Joined: Tue Mar 17, 2015 14:29

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2.2)

by Bread » Post

runs wrote:Check the aast version, please.
Thanks. But other error has shown.

Code: Select all

2019-10-14 23:09:39: ERROR[Server]: LuaEntity name "petz:piggy" not defined
"piggy_spawn = true" needs to be in petz.conf?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest