[MOD] Petz (petz) [mobs_redo|mobkit] (v5.9)

Santa Claus should be a killer or a friendly guy?

Poll runs till Tue Dec 10, 2019 19:57

Killer
4
67%
Friendly
2
33%
 
Total votes : 6

User avatar
runs
Member
 
Posts: 886
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.0)

by runs » Sun Oct 06, 2019 14:44

Bread wrote:I like this mod(Mobkit Version).

I am playing with awards mod. I have seen this error.

Code: Select all
ModError: Failed to load and run script from U:\minetest\minetest-5.1.0-d77ea76-win64\bin\..\mods\petz\petz\init.lua:
....1.0-d77ea76-win64\bin\..\mods\petz\petz/misc/awards.lua:1: attempt to index global 'awards' (a nil value)
stack traceback:
   ....1.0-d77ea76-win64\bin\..\mods\petz\petz/misc/awards.lua:1: in main chunk
   ...etest-5.1.0-d77ea76-win64\bin\..\mods\petz\petz\init.lua:46: in main chunk


I think awards should be in optional_depends in mod.conf. It works when I do it.


No, awards is still not implemented so had to be not loaded. Fixed.
 

User avatar
rubenwardy
Moderator
 
Posts: 5859
Joined: Tue Jun 12, 2012 18:11
Location: United Kingdom
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.0)

by rubenwardy » Sun Oct 06, 2019 15:11

runs wrote:v4.1
- Fix: Remove awards.


The error is because the mod doesn't soft depend on awards, so awards isn't loaded first. However, given that there's only a single awards it's probably best to disable awards support for now
 

User avatar
runs
Member
 
Posts: 886
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.0)

by runs » Sun Oct 06, 2019 16:08

rubenwardy wrote:
runs wrote:v4.1
- Fix: Remove awards.


The error is because the mod doesn't soft depend on awards, so awards isn't loaded first. However, given that there's only a single awards it's probably best to disable awards support for now


Ah, OK. I will work in awards soon.
 

User avatar
runs
Member
 
Posts: 886
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1)

by runs » Mon Oct 07, 2019 15:11

v4.1.1
Fix thanks to fluxionary
- Fix order of operations for computing baby pony stats. The stats for a baby horse were half the father's stats +/- 1
 

User avatar
runs
Member
 
Posts: 886
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1.1)

by runs » Mon Oct 07, 2019 15:19

v4.1.2
- 'Sperm' word changed to 'germ' to match the ContentDB terms of use and in aim to being more children friendly.
 

User avatar
Linuxdirk
Member
 
Posts: 2200
Joined: Wed Sep 17, 2014 11:21
Location: Germany
In-game: Linuxdirk

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1.2)

by Linuxdirk » Mon Oct 07, 2019 15:29

"Sperm" and "germ" describe two completely different things. Sperm also is the scientifically correct term.

Maybe use "seed" to make it PG0 friendly. Still a wrong term but better than "germ". Or a slightly more general term like "fertilization fluid". But you totally wont get the same result from sperm and germs :)
 

User avatar
runs
Member
 
Posts: 886
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy
 

User avatar
runs
Member
 
Posts: 886
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1.2)

by runs » Mon Oct 07, 2019 15:39

Linuxdirk wrote:"Sperm" and "germ" describe two completely different things. Sperm also is the scientifically correct term.

Maybe use "seed" to make it PG0 friendly. Still a wrong term but better than "germ". Or a slightly more general term like "fertilization fluid". But you totally wont get the same result from sperm and germs :)


Germ is not only a pathogen but the origin of something.

But you are right, it is better 'seed' :-D
 

User avatar
runs
Member
 
Posts: 886
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy
 

User avatar
runs
Member
 
Posts: 886
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1.4)

by runs » Wed Oct 09, 2019 17:29

v4.1.5
Fixed regression: No swin animations. Now swin animations are defined as "def" as in mobkit.
 

User avatar
runs
Member
 
Posts: 886
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1.5)

by runs » Fri Oct 11, 2019 08:53

Cooming soon...

Image

Downloads in ContentDB.

A new mob to celebrate.

Image
 

cHyper-0815OL
Member
 
Posts: 28
Joined: Fri Sep 13, 2019 17:40
Location: Austria
GitHub: cHyper-0815OL
In-game: cHyper cHyper-0815OL

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1.5)

by cHyper-0815OL » Sat Oct 12, 2019 06:04

runs wrote:Cooming soon...

Image

Downloads in ContentDB.

A new mob to celebrate.

Image


nice and awesome mob package!
 

User avatar
runs
Member
 
Posts: 886
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.1.5)

by runs » Sat Oct 12, 2019 11:02

v4.1.6
- Improved/recoded the fly behaviour, now less intensive.
- No more flying backwards.
- Flying mobs now recover from water.
 

User avatar
runs
Member
 
Posts: 886
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by runs » Sun Oct 13, 2019 16:21

v4.2
Image
Toucan
-It lives in the jungle.
-It eats apples.
-Tamable. You can put it in a bird stand.

-API: Recoded the load of the settings. Now in a 'for' loop automatically.
 

Stronk
Member
 
Posts: 13
Joined: Sat Jul 20, 2019 08:13

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by Stronk » Mon Oct 14, 2019 05:15

Had no problems until I clicked the "update" button today. Now your mod is broken and says there needs to be an init file in textures.

"Failed to load and run script from .......petz/textures/init.lua
no such file or directory...

Any fix for this? Was this a mistake or?
 

Bread
Member
 
Posts: 19
Joined: Tue Mar 17, 2015 14:29

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by Bread » Mon Oct 14, 2019 06:49

Code: Select all
2019-10-14 15:12:14: ERROR[Server]: LuaEntity name "petz:bee" not defined


This error has been shown. And unknown entity is there in this world.
I have not touched any code(Mobkit Version).

Image
Attachments
petzbee.png
(302.16 KiB) Not downloaded yet
 

User avatar
runs
Member
 
Posts: 886
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by runs » Mon Oct 14, 2019 08:45

Bread wrote:
Code: Select all
2019-10-14 15:12:14: ERROR[Server]: LuaEntity name "petz:bee" not defined


This error has been shown. And unknown entity is there in this world.
I have not touched any code(Mobkit Version).

Image


Its rare open petz.conf and check that "bee_spawn = false". Or maybe an old version spawned some bees (I remember that setting true by error). So kill them.
 

User avatar
runs
Member
 
Posts: 886
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by runs » Mon Oct 14, 2019 08:48

Stronk wrote:Had no problems until I clicked the "update" button today. Now your mod is broken and says there needs to be an init file in textures.

"Failed to load and run script from .......petz/textures/init.lua
no such file or directory...

Any fix for this? Was this a mistake or?



Updated from ContentDB?

Android? PC?
 

Bread
Member
 
Posts: 19
Joined: Tue Mar 17, 2015 14:29

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by Bread » Mon Oct 14, 2019 09:42

runs wrote:Its rare open petz.conf and check that "bee_spawn = false". Or maybe an old version spawned some bees (I remember that setting true by error). So kill them.


I just downloaded Petz v4.2 Modpack and copied them into mods folder manualy, created a new world(v6) and only enabled Petz Modpack. However it happens again.
Code: Select all
2019-10-14 18:25:01: ERROR[Server]: LuaEntity name "petz:bee" not defined


My PC is Windwos10 64bit. It is singleplayer game.

Here is the Spawn Mobs section in the petz.conf.
Code: Select all
##Spawn Mobs?
kitty_spawn = true
puppy_spawn = true
ducky_spawn = true
beaver_spawn = true
lamb_spawn = true
lion_spawn = true
calf_spawn = true
panda_spawn = true
frog_spawn = true
grizzly_spawn = true
pony_spawn = true
parrot_spawn= true
chicken_spawn = true
chimp_spawn = true
pigeon_spawn = true
turtle_spawn = true
clownfish_spawn = true
tropicalfish_spawn = true
wolf_spawn = true
elephant_spawn = true
elephant_female_spawn = true
moth_spawn = true
camel_spawn = true
bat_spawn = true
silkworm_spawn = true
chimp_spawn = true
hamster_spawn = true
dolphin_spawn = true
toucan_spawn = true
bee_spawn = false
 

Stronk
Member
 
Posts: 13
Joined: Sat Jul 20, 2019 08:13

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by Stronk » Mon Oct 14, 2019 13:16

runs wrote:
Stronk wrote:Had no problems until I clicked the "update" button today. Now your mod is broken and says there needs to be an init file in textures.

"Failed to load and run script from .......petz/textures/init.lua
no such file or directory...

Any fix for this? Was this a mistake or?



Updated from ContentDB?

Android? PC?


PC and I clicked the "update" button from inside the game contentDB menu. I think the above person might have the same issue. I didn't realize it had been disabled and I was seeing that error being spammed everywhere. Checked and re-enabled.. Instant crash every time I start the server with it enabled now.

Edit: I see that they are JUST using the Petz mod. I did the same thing. Only mod running is Petz and it crashes instantly just the same.
 

User avatar
runs
Member
 
Posts: 886
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy
 

User avatar
runs
Member
 
Posts: 886
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by runs » Mon Oct 14, 2019 13:35

Bread wrote:
runs wrote:Its rare open petz.conf and check that "bee_spawn = false". Or maybe an old version spawned some bees (I remember that setting true by error). So kill them.


I just downloaded Petz v4.2 Modpack and copied them into mods folder manualy, created a new world(v6) and only enabled Petz Modpack. However it happens again.
Code: Select all
2019-10-14 18:25:01: ERROR[Server]: LuaEntity name "petz:bee" not defined


My PC is Windwos10 64bit. It is singleplayer game.

Here is the Spawn Mobs section in the petz.conf.
Code: Select all
##Spawn Mobs?
kitty_spawn = true
puppy_spawn = true
ducky_spawn = true
beaver_spawn = true
lamb_spawn = true
lion_spawn = true
calf_spawn = true
panda_spawn = true
frog_spawn = true
grizzly_spawn = true
pony_spawn = true
parrot_spawn= true
chicken_spawn = true
chimp_spawn = true
pigeon_spawn = true
turtle_spawn = true
clownfish_spawn = true
tropicalfish_spawn = true
wolf_spawn = true
elephant_spawn = true
elephant_female_spawn = true
moth_spawn = true
camel_spawn = true
bat_spawn = true
silkworm_spawn = true
chimp_spawn = true
hamster_spawn = true
dolphin_spawn = true
toucan_spawn = true
bee_spawn = false


Check the aast version, please.
 

User avatar
runs
Member
 
Posts: 886
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2)

by runs » Mon Oct 14, 2019 13:35

Stronk wrote:
runs wrote:
Stronk wrote:Had no problems until I clicked the "update" button today. Now your mod is broken and says there needs to be an init file in textures.

"Failed to load and run script from .......petz/textures/init.lua
no such file or directory...

Any fix for this? Was this a mistake or?



Updated from ContentDB?

Android? PC?


PC and I clicked the "update" button from inside the game contentDB menu. I think the above person might have the same issue. I didn't realize it had been disabled and I was seeing that error being spammed everywhere. Checked and re-enabled.. Instant crash every time I start the server with it enabled now.

Edit: I see that they are JUST using the Petz mod. I did the same thing. Only mod running is Petz and it crashes instantly just the same.


Check the last version, please.
 

Stronk
Member
 
Posts: 13
Joined: Sat Jul 20, 2019 08:13
 

Bread
Member
 
Posts: 19
Joined: Tue Mar 17, 2015 14:29

Re: [MOD] Petz (petz) [mobs_redo|mobkit] (v4.2.2)

by Bread » Mon Oct 14, 2019 14:15

runs wrote:Check the aast version, please.


Thanks. But other error has shown.

Code: Select all
2019-10-14 23:09:39: ERROR[Server]: LuaEntity name "petz:piggy" not defined


"piggy_spawn = true" needs to be in petz.conf?
 

PreviousNext

Return to WIP Mods



Who is online

Users browsing this forum: No registered users and 4 guests