[Mod] Dragons & Wyverns [0.11] [draconis]

User avatar
TheNetYeti
New member
Posts: 2
Joined: Tue May 21, 2019 21:12
GitHub: growlf
In-game: netyeti
Location: Washington State
Contact:

Re: [Mod] Dragons & Wyverns [0.11] [draconis]

by TheNetYeti » Post

Imk wrote:
Thu Feb 13, 2020 19:26

Code: Select all

2020-02-13 21:06:46: ERROR[Main]: ServerError: ....[clipped]
This bug occurs when a user sitting on a dragon leaves the server
I am getting this error too, on a MT 5.1 server with all requirements up to date. Has anyone figured out why this happens or how to prevent it?

Also, I cannot seem to be able to dismount the wyvern either... I have right-clicked everywhere (both with and without either dragon staff and/or mobs:saddle in hand/inventory) - any clues?
*Y*

User avatar
runs
Member
Posts: 1804
Joined: Sat Oct 27, 2018 08:32
GitHub: runsy

Re: [Mod] Dragons & Wyverns [0.11] [draconis]

by runs » Post

TheNetYeti wrote:
Sun May 31, 2020 22:32
Imk wrote:
Thu Feb 13, 2020 19:26

Code: Select all

2020-02-13 21:06:46: ERROR[Main]: ServerError: ....[clipped]
This bug occurs when a user sitting on a dragon leaves the server
I am getting this error too, on a MT 5.1 server with all requirements up to date. Has anyone figured out why this happens or how to prevent it?

Also, I cannot seem to be able to dismount the wyvern either... I have right-clicked everywhere (both with and without either dragon staff and/or mobs:saddle in hand/inventory) - any clues?
mobs_redo has an intrincated bug in the mount api that causes that (crash, in my case just to the main menu, not to the desktop, WTF, when abandon and mounted). I use that code for my petz mod and I thought I was never going to solve it, or that it was caused by the engine. Even it was random. After a lot of testing and changes (it took me literally months), I discovered that it was in the order of force_detach, attach and assign the driver, something really trivial but very difficult to see clear. I can't say exactly how, because it was a long time ago and my version is too tuned, precisely because of the attempts to solve that bug.
Day 42 of the quarantine

User avatar
ElCeejo
Member
Posts: 75
Joined: Thu Feb 28, 2019 23:29
GitHub: ElCeejo
In-game: ElCeejo
Location: In a Dragons Lair

Re: [Mod] Dragons & Wyverns [0.11] [draconis]

by ElCeejo » Post

TheNetYeti wrote:
Sun May 31, 2020 22:32
Imk wrote:
Thu Feb 13, 2020 19:26

Code: Select all

2020-02-13 21:06:46: ERROR[Main]: ServerError: ....[clipped]
This bug occurs when a user sitting on a dragon leaves the server
I am getting this error too, on a MT 5.1 server with all requirements up to date. Has anyone figured out why this happens or how to prevent it?

Also, I cannot seem to be able to dismount the wyvern either... I have right-clicked everywhere (both with and without either dragon staff and/or mobs:saddle in hand/inventory) - any clues?
It's a mobs_redo issue, and at the moment kind of unavoidable by any means short of rewriting mobs_redo or rewriting Draconis. Neither of those are easy but one is inevitable. For now don't expect any updates to fix or add anything but a big update will come this summer that'll fix some things, including the biggest issue of all ;)

eye
New member
Posts: 1
Joined: Tue Jul 14, 2020 07:42
IRC: eye
In-game: eye harvs

Re: [Mod] Dragons & Wyverns [0.11] [draconis]

by eye » Post

i have a problem, once i extract it from a zipped file, the file has a - in it which is apparently disallowed, so it doesn't work, what should i rename the file, or make another file and place it in that? what do i call the file?

User avatar
ElCeejo
Member
Posts: 75
Joined: Thu Feb 28, 2019 23:29
GitHub: ElCeejo
In-game: ElCeejo
Location: In a Dragons Lair

Re: [Mod] Dragons & Wyverns [0.11] [draconis]

by ElCeejo » Post

Rename the folder to "draconis".

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests