Minetest Fedora Error after Compiling

User avatar
cHyper
Member
 
Posts: 842
Joined: Fri May 06, 2011 08:49
Location: Austria
GitHub: cHyper-0815OL
IRC: cHyper
In-game: cHyper cHyper_0815

Minetest Fedora Error after Compiling

by cHyper » Mon Feb 11, 2013 12:07

I got following error after sucessfully compiling of minetest.

celeron55-minetest-ab06fca/

$ ./minetest
Warning: The library version of the Irrlicht Engine (1.7.3) does not match the version the application was compiled with (y�P+). This may cause problems.
Speicherzugriffsfehler (Speicherabzug geschrieben)


What can i do??
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam
 

User avatar
cHyper
Member
 
Posts: 842
Joined: Fri May 06, 2011 08:49
Location: Austria
GitHub: cHyper-0815OL
IRC: cHyper
In-game: cHyper cHyper_0815

by cHyper » Mon Feb 11, 2013 16:44

PilzAdam wrote:Can you post the commands you used to compile?


only 2 commands:

$ cmake . -DRUN_IN_PLACE=1
$ make
 

ckoch786
New member
 
Posts: 1
Joined: Tue Feb 19, 2013 23:41

by ckoch786 » Tue Feb 19, 2013 23:44

I used
cmake . -DRUN_IN_PLACE=1 -DENABLE_SOUND=0
make -j4

and I am getting the same error in Fedora 18


I used -DENABLE_SOUND=0 because of this:

-- Could NOT find OpenAL (missing: OPENAL_LIBRARY OPENAL_INCLUDE_DIR)
-- Could NOT find VORBIS (missing: OGG_INCLUDE_DIR VORBIS_INCLUDE_DIR OGG_LIBRARY VORBIS_LIBRARY VORBISFILE_LIBRARY)
-- Sound enabled, but OpenAL not found!
-- Sound enabled, but Vorbis libraries not found!
CMake Error at src/CMakeLists.txt:65 (message):
Sound enabled, but cannot be used.

To continue, either fill in the required paths or disable sound.
(-DENABLE_SOUND=0)


-- Configuring incomplete, errors occurred!
 

rarkenin
Member
 
Posts: 668
Joined: Tue Nov 20, 2012 20:48

by rarkenin » Wed Feb 20, 2013 13:13

ckock786, can you please try installing `openal`, `openal-dev`, `libopenal-dev`, or the equivalent, as well as `libvorbis` and `libvorbis-dev`?(or the equivalent in your package manager)
Admin pro tempore on 0gb.us:30000. Ask me if you have a problem, or just want help.
This is a signature virus. Add me to your signature so that I can multiply.
Now working on my own clone, Mosstest.
I guess I'm back for some time.
 

Lejufe
New member
 
Posts: 1
Joined: Wed Mar 13, 2013 20:09

by Lejufe » Wed Mar 13, 2013 20:24

ckock786, you must install `openal-soft-devel` and `libvorbis-devel` .
I am getting the same error in Fedora 18. This two package are installed:
- irrlicht.x86_64 0:1.7.3-12.fc18
- irrlicht-devel.x86_64 0:1.7.3-12.fc18
Last edited by Lejufe on Wed Mar 13, 2013 20:27, edited 1 time in total.
 

User avatar
Redden
Member
 
Posts: 12
Joined: Fri Dec 09, 2011 15:33
Location: Slovakia

by Redden » Fri Mar 29, 2013 06:37

same problem on fedora 18
Home sweet Home..
Griefers sux!!!
 

ssieb
Member
 
Posts: 14
Joined: Mon Apr 08, 2013 19:51
GitHub: ssieb
IRC: ssieb

by ssieb » Mon Apr 08, 2013 19:54

See the bug I filed at https://bugzilla.redhat.com/show_bug.cgi?id=928037
They added the new irrlicht version while keeping the old one. But the new headers replaced the old ones, so when you compile minetest, it gets the wrong headers. I put a patch for the spec file in the bug.
 

User avatar
sfan5
Moderator
 
Posts: 3801
Joined: Wed Aug 24, 2011 09:44
Location: Germany
GitHub: sfan5
IRC: sfan5

by sfan5 » Mon Apr 08, 2013 19:56

The "y�P+" looks suspicious, maybe your Irrlicht library is broken?
Mods: Mesecons | WorldEdit | Nuke & Minetest builds for Windows (32-bit & 64-bit)
 

cheapie
Member
 
Posts: 315
Joined: Mon May 14, 2012 00:59
GitHub: cheapie
IRC: cheapie
In-game: cheapie

by cheapie » Tue Apr 09, 2013 04:59

sfan5 wrote:The "y�P+" looks suspicious, maybe your Irrlicht library is broken?


Didn't you hear? Everything is moving over to random gibberish for version numbers!

Just kidding, of course. "y�P+" is a lot easier to remember than "1.5.2.7.13124235.475856745655236547b3453467547" or whatever though...

Try reinstalling Irrlicht and recompiling.
-- This account is no longer active --
My mods have moved to: https://cheapiesystems.com/git
 

ssieb
Member
 
Posts: 14
Joined: Mon Apr 08, 2013 19:51
GitHub: ssieb
IRC: ssieb

by ssieb » Tue Apr 09, 2013 05:15

sfan5 wrote:The "y�P+" looks suspicious, maybe your Irrlicht library is broken?

Yes, the reason you get random garbage is because the structure changed between versions. Minetest is compiled against the new headers so thinks the version string pointer is at a certain position, but the library actually has it elsewhere.
 

User avatar
sfan5
Moderator
 
Posts: 3801
Joined: Wed Aug 24, 2011 09:44
Location: Germany
GitHub: sfan5
IRC: sfan5

by sfan5 » Fri Apr 26, 2013 05:24

ssieb wrote:
sfan5 wrote:The "y�P+" looks suspicious, maybe your Irrlicht library is broken?

Yes, the reason you get random garbage is because the structure changed between versions. Minetest is compiled against the new headers so thinks the version string pointer is at a certain position, but the library actually has it elsewhere.

Minetest compiles fine for me with Irrlicht 1.7.2 and 1.8
Mods: Mesecons | WorldEdit | Nuke & Minetest builds for Windows (32-bit & 64-bit)
 

ssieb
Member
 
Posts: 14
Joined: Mon Apr 08, 2013 19:51
GitHub: ssieb
IRC: ssieb

by ssieb » Fri Apr 26, 2013 06:52

sfan5 wrote:
ssieb wrote:
sfan5 wrote:The "y�P+" looks suspicious, maybe your Irrlicht library is broken?

Yes, the reason you get random garbage is because the structure changed between versions. Minetest is compiled against the new headers so thinks the version string pointer is at a certain position, but the library actually has it elsewhere.

Minetest compiles fine for me with Irrlicht 1.7.2 and 1.8


Unless you're compiling on Fedora, that's irrelevant... The issue is that the Fedora Irrlicht package has the headers mixed up.
 

Xcelsior
New member
 
Posts: 7
Joined: Wed Nov 14, 2012 01:10

by Xcelsior » Fri Apr 26, 2013 14:13

I have the same problem with Fedora 18

Code: Select all
./minetest
Warning: The library version of the Irrlicht Engine (1.7.3) does not match the version the application was compiled with ($�). This may cause problems.
Erreur de segmentation (core dumped)


Code: Select all
(gdb) run
Starting program: /home/alexandre/Téléchargements/Minetest/minetest-master/bin/minetest
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Warning: The library version of the Irrlicht Engine (1.7.3) does not match the version the application was compiled with ($�). This may cause problems.

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7c6a169 in irr::gui::CGUIEditBox::CGUIEditBox(wchar_t const*, bool, irr::gui::IGUIEnvironment*, irr::gui::IGUIElement*, int, irr::core::rect<int> const&) () from /lib64/libIrrlicht.so.1
Missing separate debuginfos, use: debuginfo-install bzip2-libs-1.0.6-7.fc18.x86_64 cyrus-sasl-lib-2.1.23-37.fc18.x86_64 glibc-2.16-30.fc18.x86_64 irrXML-1.2-12.fc18.x86_64 irrlicht-1.7.3-12.fc18.x86_64 keyutils-libs-1.5.5-3.fc18.x86_64 krb5-libs-1.10.3-15.fc18.x86_64 libICE-1.0.8-2.fc18.x86_64 libSM-1.2.1-2.fc18.x86_64 libX11-1.5.0-3.fc18.x86_64 libXau-1.0.6-4.fc18.x86_64 libXcursor-1.1.13-2.fc18.x86_64 libXext-1.3.1-2.fc18.x86_64 libXfixes-5.0-3.fc18.x86_64 libXrender-0.9.7-2.fc18.x86_64 libXxf86vm-1.1.2-2.fc18.x86_64 libaesgm-20090429-6.fc18.x86_64 libcom_err-1.42.5-1.fc18.x86_64 libcurl-7.27.0-8.fc18.x86_64 libgcc-4.7.2-8.fc18.x86_64 libidn-1.26-1.fc18.x86_64 libjpeg-turbo-1.2.90-1.fc18.x86_64 libogg-1.3.0-2.fc18.x86_64 libpng-1.5.13-1.fc18.x86_64 libselinux-2.1.12-7.3.fc18.x86_64 libssh2-1.4.3-2.fc18.x86_64 libstdc++-4.7.2-8.fc18.x86_64 libuuid-2.22.2-6.fc18.x86_64 libvorbis-1.3.3-3.fc18.x86_64 libxcb-1.9-1.fc18.x86_64 mesa-libGLU-9.0.0-1.fc18.x86_64 nspr-4.9.5-2.fc18.x86_64 nss-3.14.3-1.fc18.x86_64 nss-softokn-freebl-3.14.3-1.fc18.x86_64 nss-util-3.14.3-1.fc18.x86_64 openal-soft-1.15.1-1.fc18.x86_64 openldap-2.4.34-1.fc18.x86_64 openssl-libs-1.0.1e-4.fc18.x86_64 pcre-8.31-4.fc18.x86_64 zlib-1.2.7-9.fc18.x86_64
(gdb) bt full
#0  0x00007ffff7c6a169 in irr::gui::CGUIEditBox::CGUIEditBox(wchar_t const*, bool, irr::gui::IGUIEnvironment*, irr::gui::IGUIElement*, int, irr::core::rect<int> const&) () from /lib64/libIrrlicht.so.1
No symbol table info available.
#1  0x00007ffff7c6dbcb in irr::gui::CGUIEnvironment::addEditBox(wchar_t const*, irr::core::rect<int> const&, bool, irr::gui::IGUIElement*, int) ()
   from /lib64/libIrrlicht.so.1
No symbol table info available.
#2  0x000000000048f13a in main ()
No symbol table info available.
(gdb)
Spec: AMD FX-8350 8x4 GHz, nVidia GTX670 2 Gb, 16 GB Ram and Corsair H60 with Fedora 18(x86_64)
Minetest Server (0.4.6): AviActu.info:30000
 

qznc
Member
 
Posts: 55
Joined: Tue Jul 03, 2012 09:02

by qznc » Mon Apr 29, 2013 21:00

ssieb wrote:See the bug I filed at https://bugzilla.redhat.com/show_bug.cgi?id=928037
They added the new irrlicht version while keeping the old one. But the new headers replaced the old ones, so when you compile minetest, it gets the wrong headers. I put a patch for the spec file in the bug.


The bug in the irrlicht package is not fixed so far. Alternatively, you can use the irrlicht18 package, but this requires a little bit more configuration via cmake:

Code: Select all
cmake . -DRUN_IN_PLACE=1 -DIRRLICHT_INCLUDE_DIR=/usr/include/irrlicht18 -DIRRLICHT_LIBRARY=/usr/lib64/libIrrlicht18.so
make -j9


On a 32bit system, you probably must replace "lib64" with "lib".

This builds minetest with irrlicht 1.8 instead of the default 1.7. Should work just as good.
 

Xcelsior
New member
 
Posts: 7
Joined: Wed Nov 14, 2012 01:10

by Xcelsior » Fri May 24, 2013 19:50

Using Irrlicht 1.8 worked for me, but the command to compile was this one on Fedora 18 x86_64

Code: Select all
cmake . -DRUN_IN_PLACE=1 -DIRRLICHT_INCLUDE_DIR=/usr/include/irrlicht -DIRRLICHT_LIBRARY=/usr/lib64/libIrrlicht18.so.1
make -j9
Spec: AMD FX-8350 8x4 GHz, nVidia GTX670 2 Gb, 16 GB Ram and Corsair H60 with Fedora 18(x86_64)
Minetest Server (0.4.6): AviActu.info:30000
 

qznc
Member
 
Posts: 55
Joined: Tue Jul 03, 2012 09:02

by qznc » Sat May 25, 2013 17:11

On Fedora 18: Remove the irrlicht(-devel) package and install the irrlicht18(-devel) package.
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 4 guests