ERROR[main]: WARNING: updateListener: invalid value

User avatar
deivan
Member
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

ERROR[main]: WARNING: updateListener: invalid value

by deivan » Post

This happened here many times. After this my game don't start very well and I need teleport myself to some place, like 0,0,0 to come back to the world. I think is the same bug who change the position to big values...

The window is clear, no object and this message is spawning every time...
"ERROR[main]: WARNING: updateListener: invalid value'

Start in the 0.4.5. :-/

User avatar
PilzAdam
Member
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
GitHub: PilzAdam
IRC: PilzAdam
Location: Germany

by PilzAdam » Post

Seems like a problem with the sound.
What OS do you use?

User avatar
deivan
Member
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Post

GNU Debian, kernell 3.2.0-4-486. Start in the 0.4.5, I never saw it before.
Last edited by deivan on Fri Mar 29, 2013 10:49, edited 1 time in total.

User avatar
deivan
Member
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Post

I am thinking if this bug is caused by the position change, I have the message "ERROR[main]: WARNING: updateListener: invalid value'" only after my position is changed to "(inf, <big negative number>,0)". When I use the key F5 to see the position I found this "inf" in the X, I hope this will be solved soon, after the last week I have more incidents here... :-/

The X is away inf, the y is changing after the initial value (a big negative value), I am falling... The Z value is a small value, positive or sometimes zero (maybe is different, I don't remember).

I don't found the trigger, sometimes I am walking, a two minutes ago I am working in the furnace. :-/

User avatar
sfan5
Moderator
Posts: 3892
Joined: Wed Aug 24, 2011 09:44
GitHub: sfan5
IRC: sfan5
Location: Germany

by sfan5 » Post

This has happened to me twice, but I haven't found a fix for it.
Mods: Mesecons | WorldEdit | Nuke & Minetest builds for Windows (32-bit & 64-bit)

User avatar
PilzAdam
Member
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
GitHub: PilzAdam
IRC: PilzAdam
Location: Germany

by PilzAdam » Post

Does teleporting to (0,0,0) help?

User avatar
sfan5
Moderator
Posts: 3892
Joined: Wed Aug 24, 2011 09:44
GitHub: sfan5
IRC: sfan5
Location: Germany

by sfan5 » Post

PilzAdam wrote:Does teleporting to (0,0,0) help?
That obviously teleports you to (0,0,0), but does not fix the bug
Mods: Mesecons | WorldEdit | Nuke & Minetest builds for Windows (32-bit & 64-bit)

User avatar
Topywo
Member
Posts: 1721
Joined: Fri May 18, 2012 20:27

by Topywo » Post

Maybe something with collision detection in localplayer.cpp?

User avatar
PilzAdam
Member
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
GitHub: PilzAdam
IRC: PilzAdam
Location: Germany

by PilzAdam » Post

Topywo wrote:Maybe something with collision detection in localplayer.cpp?
What makes you think that the bug is there?

User avatar
Topywo
Member
Posts: 1721
Joined: Fri May 18, 2012 20:27

by Topywo » Post

PilzAdam wrote:
Topywo wrote:Maybe something with collision detection in localplayer.cpp?
What makes you think that the bug is there?
A few months ago (at the moment physics was introduced) I was playing a bit with the code in there. Inspired by flying players on servers (without fly-privilege). Since I don't know C++ I could only change minor things like putting a ! (not-sign) and // in front of some checks and lines and changing some && (and) and || (or). Some times, after starting a game I 'dropped' with speed far greater than fast down.

Since I've only 1 computer to test on, I tested it once on gameboom. At the time everything was loaded, My player appeared a few hundred thousand below 0 and still descending. After some sweating I solved it (in a hacky?) way by activating being attached in localplayer.cpp, giving that position coordinates I knew. That transported me (after recompiling) back to normal heights (after that I needed to detach myself, because I couldn't move).

I didn't see warnings and don't think I got stuck at the specified coordinates. But the superfast descending (without being able to stop it) looked familiair enough to post here, hoping to help solve this bug.

User avatar
cypher-neo
Member
Posts: 46
Joined: Wed Oct 17, 2012 12:15

by cypher-neo » Post

sfan5 wrote:
PilzAdam wrote:Does teleporting to (0,0,0) help?
That obviously teleports you to (0,0,0), but does not fix the bug
Sometimes teleporting works. Other times it does nothing and I keep falling through nothing.
PilzAdam wrote:
Topywo wrote:Maybe something with collision detection in localplayer.cpp?
What makes you think that the bug is there?
The only thing I can say I've noticed before the most recent updateListener fails, is a bug with water. I don't use Finite Water because I don't like it, prefering the old Minetest method of water. Sometimes I'll be digging around water, and water doesn't react the way it should. Sometimes it remains frozen in a block hanging in air, or doesn't flowing_water doesn't disappear once the source is removed.

Then, usually within a few seconds I get an updateListener error and start falling.

User avatar
basith374
New member
Posts: 1
Joined: Wed May 29, 2013 07:30

by basith374 » Post

i have the same problem. i was digging rocks when the same error showed up. after that i was falling and couldn't see anything but the stars in the night sky. i tried teleporting to a location i noted before but the game was too laggy to do that. i have minetest v0.4.6 running on ubuntu 12.10 quantal quetzal. someone please fix this problem :(

User avatar
DeepGaze
Member
Posts: 332
Joined: Fri May 10, 2013 00:49
GitHub: DeepGaze
IRC: DeepGaze
In-game: DeepGaze
Location: Take your best guess

by DeepGaze » Post

i repeatedly get this error in my project map. (i have backups) it causes me to lose days worth of work in my map ( link it annoys me to a point of discontinuing. mabye?) i emailed screenshosts to the developer plizadam in the hope it helps
there's no place like 127.0.0.1
The deep life Minetest text page
minetest cards

User avatar
deivan
Member
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Post

The evasive action to this problem is the command teleport, use it to transport you back to the map. In the version 0.4.7 I don't see this problem at this moment. Alternatively is possible a small mod fix to check your location and "move" you back to your last position if one of your values become the "inf". Maybe is possible, maybe not.

User avatar
deivan
Member
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Post

This problem still occurring here and now I see another problem after this one. All blocks still invisible after a teleport, I see borders but don't see textures. :-/

User avatar
Zeg9
Member
Posts: 608
Joined: Fri Sep 21, 2012 11:02
Location: France

by Zeg9 » Post

deivan wrote:This problem still occurring here and now I see another problem after this one. All blocks still invisible after a teleport, I see borders but don't see textures. :-/
The invisible blocks might be caused by "camera update disabled", try hitting F4.
I made a few (a lot of?) mods for minetest: here is a list.
See also the MT-Faithful texture pack (work in progress).

User avatar
deivan
Member
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Post

The problem vanished only after close the game... To bad, new bug. :-/

User avatar
Dopium
Member
Posts: 233
Joined: Sat Jun 09, 2012 15:43
Location: Australia

by Dopium » Post

I have had the same error for the last couple of devs and using xp, however most the time it just displays the error about 15 times then goes away like nothing happened. On a rare occasion it will show another "access violated" straight after and crash the game to menu.

Once it crashes to the menu and you rejoin the map the sounds start going into infinite loops getting faster the more sounds created. I usually just exit to OS and its all good again, i have also noticed it seams to happen on a individual block.
Anyway here is a debug report that i get:

Code: Select all

Font size: 8 17
In trans_func.
Access violation at 005BDCB2 write?=0 address=553574400
In trans_func.
Access violation at 005BDCB2 write?=0 address=553574400
14:40:39: ERROR[main]: Some exception: "Access violation"
Font size: 8 17
14:41:14: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:14: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:14: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:14: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:14: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:14: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:14: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:15: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:15: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:15: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:15: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:15: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:15: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:15: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:15: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:15: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:15: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:16: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:16: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:16: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:16: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:16: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:16: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:16: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:16: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:16: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:16: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:18: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:18: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:18: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:18: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:18: ERROR[main]: WARNING: updateListener: invalid name
14:41:19: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:19: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:19: ERROR[main]: WARNING: updateListener: invalid name
14:41:19: ERROR[main]: WARNING: updateListener: invalid name
14:41:19: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:19: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:19: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:19: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:20: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:20: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:20: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:20: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:21: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:21: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:21: ERROR[main]: WARNING: updateListener: invalid name
14:41:21: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:21: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:21: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:21: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:22: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:22: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:22: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:22: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:23: ERROR[main]: WARNING: updateListener: invalid name
14:41:23: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:23: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:23: ERROR[main]: WARNING: updateListener: invalid name
14:41:24: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:24: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:24: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:24: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:24: ERROR[main]: WARNING: updateListener: invalid name
14:41:24: ERROR[main]: WARNING: updateListener: invalid name
14:41:25: ERROR[main]: WARNING: updateListener: invalid name
14:41:25: ERROR[main]: WARNING: updateListener: invalid name
14:41:25: ERROR[main]: WARNING: updateListener: invalid name
14:41:25: ERROR[main]: WARNING: updateListener: invalid name
14:41:25: ERROR[main]: WARNING: updateListener: invalid name
14:41:25: ERROR[main]: WARNING: updateListener: invalid name
14:41:26: ERROR[main]: WARNING: updateListener: invalid name
14:41:26: ERROR[main]: WARNING: updateListener: invalid name
14:41:27: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:27: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:27: ERROR[main]: WARNING: updateListener: invalid name
14:41:27: ERROR[main]: WARNING: updateListener: invalid name
14:41:27: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:27: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:27: ERROR[main]: WARNING: updateListener: invalid name
14:41:27: ERROR[main]: WARNING: updateListener: invalid name
14:41:27: ERROR[main]: WARNING: updateListener: invalid name
14:41:28: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:28: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:28: ERROR[main]: WARNING: updateListener: invalid name
14:41:28: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:28: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:28: ERROR[main]: WARNING: updateListener: invalid name
14:41:29: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:29: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:29: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:29: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:30: ERROR[main]: WARNING: updateListener: invalid name
14:41:30: ERROR[main]: WARNING: updateListener: invalid name
14:41:30: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:30: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:31: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:31: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:31: ERROR[main]: WARNING: updateListener: invalid name
14:41:32: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:32: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:33: ERROR[main]: WARNING: updateListener: invalid name
14:41:34: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:34: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:34: ERROR[main]: WARNING: updateListener: invalid name
14:41:34: ERROR[main]: WARNING: updateListener: invalid name
14:41:35: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:35: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:35: ERROR[main]: WARNING: updateListener: invalid name
14:41:36: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:36: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:36: ERROR[main]: WARNING: updateListener: invalid name
14:41:36: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:36: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:36: ERROR[main]: WARNING: updateListener: invalid name
14:41:37: ERROR[main]: WARNING: updateListener: invalid name
14:41:37: ERROR[main]: WARNING: updateListener: invalid name
14:41:37: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:37: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:37: ERROR[main]: WARNING: updateListener: invalid name
14:41:38: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:38: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:39: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:39: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:39: ERROR[main]: WARNING: updateListener: invalid name
14:41:39: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:39: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:40: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:40: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:40: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:40: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:40: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:40: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:41: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:41: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:41: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:41: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:41: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:41: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:42: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:42: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:42: ERROR[main]: WARNING: updateListener: invalid name
14:41:42: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:42: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:42: ERROR[main]: WARNING: updateListener: invalid name
14:41:43: ERROR[main]: WARNING: updateListener: invalid name
14:41:43: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:43: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:45: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:45: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:46: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:46: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:46: ERROR[main]: WARNING: updateListener: invalid name
14:41:46: ERROR[main]: WARNING: updateListener: invalid name
14:41:46: ERROR[main]: WARNING: updateListener: invalid name
14:41:47: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:47: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:48: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:48: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:49: ERROR[main]: WARNING: before createPlayingSound: invalid name
14:41:49: ERROR[main]: WARNING: createPlayingSound: invalid name
14:41:51: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:51: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
14:41:51: ERROR[main]: WARNING: updateListener: invalid name
14:41:52: ERROR[main]: WARNING: before createPlayingSoundAt: invalid name
14:41:52: ERROR[main]: WARNING: createPlayingSoundAt: invalid name
deivan wrote:This problem still occurring here and now I see another problem after this one. All blocks still invisible after a teleport, I see borders but don't see textures. :-/
Sounds more like you have teleported under the ground, make sure noclip is enabled(H) and fly up. Just depends if the map gen created land over 0,0,0
Running @1.19 MHz, 128 bytes of RAM and interchangeable 4kb ROM carts!

User avatar
deivan
Member
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Post

I have a room at 0,0,0 only to cover this problem... :-/

After arrive in a new area, after a teleport I see blocks, but don't see textures, I know the location of the blocks only when the mouse is over him, then I see the border of each block. Is a new bug... :-/

User avatar
deivan
Member
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Post

This topic is newer than the one posted by me, I don't understand the motivation of the transference of this posts but ok... Don't is a problem, anyway.

User avatar
sfan5
Moderator
Posts: 3892
Joined: Wed Aug 24, 2011 09:44
GitHub: sfan5
IRC: sfan5
Location: Germany

by sfan5 » Post

deivan wrote:This topic is newer than the one posted by me, I don't understand the motivation of the transference of this posts but ok... Don't is a problem, anyway.
..My bad.

Edit: I moved all posts to the older topic
Last edited by sfan5 on Thu Jun 20, 2013 20:04, edited 1 time in total.
Mods: Mesecons | WorldEdit | Nuke & Minetest builds for Windows (32-bit & 64-bit)

mauvebic
Member
Posts: 1550
Joined: Fri Jan 27, 2012 11:32

by mauvebic » Post

I can confirm this bug on two of my rigs. It always happens when i'm digging, and/or not in free move.

4aiman
Member
Posts: 1208
Joined: Mon Jul 30, 2012 05:47

by 4aiman » Post

This still happens. Was at Xanadu server ~2 weeks ago when this happened to me. Teleporting didn't work. Neither was I in fly mode nor had noclip on. I just jumped and.... start to fall down.
Well, the description is pretty much the same as by anyone else.

User avatar
deivan
Member
Posts: 452
Joined: Fri Feb 15, 2013 10:16
Location: Brazil. :D

by deivan » Post

Is a very old bug... :-/

mauvebic
Member
Posts: 1550
Joined: Fri Jan 27, 2012 11:32

by mauvebic » Post

the updatelistener warning is from a sound function, the invalid value is the position which is inf on one of the axes. So something, somewhere is doing some weird math on your position, throwing people off the map and causing updatelistener to flood the log/chat. I wonder if this bug started happening around the same time physics were rejigged? Wish I could offer more insight.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest