[Résolu] Création de serveur sur Debian Wheezy

French
User avatar
shiva
Member
 
Posts: 108
Joined: Tue Sep 16, 2014 22:00
Location: En Bretagne :-)
In-game: shiva35

[Résolu] Création de serveur sur Debian Wheezy

by shiva » Tue Sep 16, 2014 22:11

Slt à tous,
Je viens d'installer sur une debian wheezy (serveur dédié en ligne avec accès root, etc...) minetest-server et minetest-common.
J'ai créé le fichier minetest.conf car sinon y a une erreur. une fois cela fait je le lance en user non root, donc :
Code: Select all
/usr/games/minetestserver

Pas d'erreurs apparentes, je test une connexion depuis chez moi, connexion ok mais ensuite le jeu reste avec le message suivant : Définitions d'objets... et ça ne bouge plus.
ai je oublié quelque chose ?

Merci
Last edited by shiva on Wed Sep 17, 2014 07:55, edited 1 time in total.
 

User avatar
Minetestforfun
Member
 
Posts: 936
Joined: Tue Aug 05, 2014 14:09
Location: On earth
GitHub: Darcidride
IRC: Darcidride + MinetestForFun
In-game: Darcidride + MinetestForFun

Re: Création de serveur sur Debian Wheezy

by Minetestforfun » Tue Sep 16, 2014 23:00

Voici un lien qui devrait t'aider : viewtopic.php?f=3&t=3837

Si tu penses avoir effectué l'installation correctement :
Depuis ton Minetest client, essai de te connecter à ton serveur en cochant le minimum de paramètres graphiques.

Attention aussi aux droits, si tu as effectué l'installation du serveur en root (ce qui peut arriver par mégarde/fainéantise/inexpérience), et que tu lances le serveur depuis un utilisateur n'étant ni propriétaire ni membre d'un groupe lui permettant l'exécution de fichiers du serveur, cela sera fatale...

Enfin, pour ce qui est de la version du client, le mieux reste d'aller la chercher ici : viewforum.php?f=42
(les versions officiels ou compiler sois même à la va-vite manque de stabilité)
 

User avatar
shiva
Member
 
Posts: 108
Joined: Tue Sep 16, 2014 22:00
Location: En Bretagne :-)
In-game: shiva35

Re: Création de serveur sur Debian Wheezy

by shiva » Wed Sep 17, 2014 07:35

J'ai testé en décochant le minimum de paramètres graphiques : marche toujours pas
J'ai effectivement fais l'installation en root car je suis passé par "apt-get install" et je pense savoir pourquoi ça ne fonctionne pas : la version installée est el 0.3.1. Donc, est-ce que la version du client doit être identique à celle du serveur ?
En attendant je vais faire une compilation des sources, ça sera plus simple :-)
 

User avatar
shiva
Member
 
Posts: 108
Joined: Tue Sep 16, 2014 22:00
Location: En Bretagne :-)
In-game: shiva35

Re: Création de serveur sur Debian Wheezy

by shiva » Wed Sep 17, 2014 07:54

Je viens de faire une compilation des sources sur mon linux local, et là ça fonctionne nickel, c'était bien un problème de version. Me reste plus qu'à mettre le tout sur mon dédié :-)

Merci à toi pour ton aide.
 

User avatar
Minetestforfun
Member
 
Posts: 936
Joined: Tue Aug 05, 2014 14:09
Location: On earth
GitHub: Darcidride
IRC: Darcidride + MinetestForFun
In-game: Darcidride + MinetestForFun

Re: [Résolu] Création de serveur sur Debian Wheezy

by Minetestforfun » Wed Sep 17, 2014 10:40

Oui en effet, il faut que la version du client corresponde à la version du serveur ! (à peu près)

un client en version 0.4.10 pour un serveur en 0.4.10 est par exemple la meilleur solution, cependant il m'est arrivé de pouvoir me connecté à un serveur en 0.4.10 avec un client en version 0.4.9 et vis-versa,

Quoiqu'il en soit, la version disponible depuis le dépt que tu as chopé n'es vraiment pas a jours ! (0.3.1 => 0.4.10 actuellement)

Si tout fonctionne, c'est parfait ! Bon jeu :)
 


Return to Français



Who is online

Users browsing this forum: No registered users and 0 guests