Multiple errors

Ochotre
Member
 
Posts: 11
Joined: Sun Feb 15, 2015 20:08
In-game: Ochotre

Multiple errors

by Ochotre » Sat Feb 28, 2015 23:52

Hello I am trying to use some mods, but when i activate this happend,
the mods are farming, beds, wool, nature, flowers, panes, wool,:

17:02:11: ERROR[main]: Invalid character ' ' found in setting name
17:02:11: ERROR[main]: MAINMENU ERROR: Invalid sequence found in setting parameters
17:02:11: ERROR[main]: stack traceback:
17:02:11: ERROR[main]: [C]: in function 'set'
17:02:11: ERROR[main]: /usr/share/minetest/builtin/mainmenu/dlg_config_world.lua:190: in function 'handle_buttons'
17:02:11: ERROR[main]: /usr/share/minetest/builtin/fstk/ui.lua:118: in function 'handle_buttons'
17:02:11: ERROR[main]: /usr/share/minetest/builtin/fstk/ui.lua:155: in function </usr/share/minetest/builtin/fstk/ui.lua:148>
 

User avatar
maikerumine
Member
 
Posts: 1350
Joined: Mon Aug 04, 2014 14:27
GitHub: maikerumine
In-game: maikerumine

Re: Multiple errors

by maikerumine » Sun Mar 01, 2015 00:37

Ochotre wrote:Hello I am trying to use some mods, but when i activate this happend,
the mods are farming, beds, wool, nature, flowers, panes, wool,:

17:02:11: ERROR[main]: Invalid character ' ' found in setting name
17:02:11: ERROR[main]: MAINMENU ERROR: Invalid sequence found in setting parameters
17:02:11: ERROR[main]: stack traceback:
17:02:11: ERROR[main]: [C]: in function 'set'
17:02:11: ERROR[main]: /usr/share/minetest/builtin/mainmenu/dlg_config_world.lua:190: in function 'handle_buttons'
17:02:11: ERROR[main]: /usr/share/minetest/builtin/fstk/ui.lua:118: in function 'handle_buttons'
17:02:11: ERROR[main]: /usr/share/minetest/builtin/fstk/ui.lua:155: in function </usr/share/minetest/builtin/fstk/ui.lua:148>


Try ti re-install minetest to a different location? I hope that helps.
 

User avatar
Krock
Developer
 
Posts: 4416
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: Multiple errors

by Krock » Sun Mar 01, 2015 12:17

Open the file world.mt with a text editor and find the setting "load_mod_XYZ = false/true" (the XYZ-Part contains a space)
Remove that line and rename the directory of that XYZ mod.
Look, I programmed a bug for you. >> Mod Search Engine << - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>
 

Ochotre
Member
 
Posts: 11
Joined: Sun Feb 15, 2015 20:08
In-game: Ochotre

Re: Multiple errors

by Ochotre » Fri Mar 13, 2015 03:11

Thanks I reinstall and it appears to be ok... but then:

21:05:37: ERROR[main]: ModError: ModError: Failed to load and run /home/arjuna/.minetest/mods/animals/factions/init.lua

21:11:09: ERROR[main]: ModError: ModError: Failed to load and run /home/arjuna/.minetest/mods/farming/init.lua
 

User avatar
Krock
Developer
 
Posts: 4416
Joined: Thu Oct 03, 2013 07:48
Location: Switzerland
GitHub: SmallJoker

Re: Multiple errors

by Krock » Fri Mar 13, 2015 20:16

I ihink those mods are only directories with nothing inside.
Disable those and check if there's an init.lua inside of those directories.
Look, I programmed a bug for you. >> Mod Search Engine << - Mods by Krock - DuckDuckGo mod search bang: !mtmod <keyword here>
 

Ochotre
Member
 
Posts: 11
Joined: Sun Feb 15, 2015 20:08
In-game: Ochotre

Re: Multiple errors

by Ochotre » Sun Mar 22, 2015 01:09

Yep they are good, i just realized that the version i have is not the latest, is from ubuntu software center, but i dond find the way to install the 4.12... i have 4.09 in ubuntu studio...

Thanks
 

User avatar
Topywo
Member
 
Posts: 1721
Joined: Fri May 18, 2012 20:27

Re: Multiple errors

by Topywo » Sun Mar 22, 2015 10:33

Ochotre wrote: but i dond find the way to install the 4.12... i have 4.09 in ubuntu studio...


Scroll down here for instructions: https://github.com/minetest/minetest how to build minetest on Linux.
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 3 guests