Warning! Maps opened in 0.4.15-dev will not work in older MT

Locked
User avatar
paramat
Developer
Posts: 3626
Joined: Sun Oct 28, 2012 00:05
GitHub: paramat
IRC: paramat
Location: UK

Warning! Maps opened in 0.4.15-dev will not work in older MT

by paramat » Post

See viewtopic.php?f=18&t=16595 for more details.
This PR is now being merged.

"To introduce the new flags I had to increase the map block serialization version, this is why you can not play on your maps on other versions of Minetest after you opened them in this version.
Of course old clients still can play, just the server has to be new to be able to read the map."

This includes singleplayer.
Last edited by paramat on Mon Feb 13, 2017 00:48, edited 1 time in total.

User avatar
Fixer
Member
Posts: 895
Joined: Sun Jul 31, 2011 11:23
IRC: Fixer
In-game: Fixer
Location: Ukraine

Re: Increase in mapblock serialisation version going ahead

by Fixer » Post

In simple words, if you open your world with today's dev build (as of f17c9c4), there's no easy way back to older minetest version. If you want to be safe - make a backup of your world.

Why devs decided this? Those changes are needed to fix long standing annoying lighting/shadows bugs that plagued minetest for years, they will fix:
+ ghost light after lava casts (with this PR)
soon:
+ L-system trees incorrect shadows, moretrees will work out of the box
+ incorrect light after tnt in water explosion
+ squarish shadows induced by tnt blown over to far horizon
+ ghost light after sofar's lightning mod strike
+ lighting bugs in other scenarios

User avatar
Wuzzy
Member
Posts: 3933
Joined: Mon Sep 24, 2012 15:01
GitHub: Wuzzy2
IRC: Wuzzy
In-game: Wuzzy

Re: Warning! Maps opened in 0.4.15-dev will not work in olde

by Wuzzy » Post

Good to know you are going actively killing all those light bugs. :-)
It is totally worth it to introduce the incompability IMO, because those light bugs are, as you put it nicely, quite a plague.


By the way: So once I go to the dev version, there's no way back, but what about the other way around?
What happens if I use a 0.4.15 world with the development version? Could there be possible problems?
My creations. I gladly accept bitcoins: 17fsUywHxeMHKG41UFfu34F1rAxZcrVoqH

User avatar
burli
Member
Posts: 1641
Joined: Fri Apr 10, 2015 13:18

Re: Warning! Maps opened in 0.4.15-dev will not work in olde

by burli » Post

The L-system tree bug is fixed? YEAH

User avatar
Fixer
Member
Posts: 895
Joined: Sun Jul 31, 2011 11:23
IRC: Fixer
In-game: Fixer
Location: Ukraine

Re: Warning! Maps opened in 0.4.15-dev will not work in olde

by Fixer » Post

What happens if I use a 0.4.15 world with the development version? Could there be possible problems?
Should be no problems, it just works...

User avatar
paramat
Developer
Posts: 3626
Joined: Sun Oct 28, 2012 00:05
GitHub: paramat
IRC: paramat
Location: UK

Re: Warning! Maps opened in 0.4.15-dev will not work in olde

by paramat » Post

Correct, no problems with that.

Locked

Who is online

Users browsing this forum: No registered users and 0 guests