[Mod] Elevator shafts [elevator]

User avatar
aximx51v
Member
Posts: 60
Joined: Fri Dec 07, 2012 03:47

[Mod] Elevator shafts [elevator]

by aximx51v » Post

Here's a mod to create an 'anti gravity' field for easy, well lit, vertical transportation.
It works like a typical ladder block, except that you place a single 'generator block' at the top of the space you want to climb, and it generates the field underneath.
It will only generate the field within loaded (visible) chunks, and if you cut out material underneath the field, the resulting space does not get the 'anti gravity' field.
To remedy this, you can use the calibrator unit to fill any open space under a gravity generator. all you have to do is stand inside the field and use (left click) the calibrator.
It is a wonderful tool for digging vertical shafts, because the gravity field is also light emitting.
Image


space under the 'anti gravity' field before using the calibrator:
Image


and after:
Image


here's a vertical shaft i dug while standing inside the 'anti gravity' field:
Image


and here it is after recalibrating the field:
Image


generator blocks placed side by side to create a wider field:
Image


here's what the old version of the generator field looks like:
Image


The field texture displays a little weird. it'll sparkle as your perspective changes. that's because it's a really high res picture of a bunch of tiny dots. I wanted to be able to see the field, but still see through it.

If you place a generator block above another, the lower one will disappear. you can't place nodes inside the field, or dig the field, but you can push it using the mesecons mod. i recommend adding the field node to the 'unmovables' exceptions in the mesecons lua

here's the recipes:

Generator Block:
(Mese Block, Mese Block, Mese Block)
(Mese Block, nothing, Mese Block)
(Mese Block, Mese Block, Mese Block)

Calibrator:
(nothing, Steel Ingot, nothing)
(Steel Ingot, Mese Block, nothing)
(Steel Ingot, Steel Ingot, nothing)

The code license is: WTFPL, and the textures license is CC BY

Mod dependencies: default


EDIT:
so here's the updated version, which (hopefully) is finished!
it adds animated anti-grav field and humming generator node (thanks Ragnarock and Bzab for your help in making this possible!)
you also travel vertically much faster than before. (via attachment to a high-speed entity)

IMPORTANT!!!
the new version is now fully working, but i don't know how it performs in multi-player yet. there still may be a few hiccups, so if anybody finds a bug please let me know! i'd like it to be stable before i put it in the releases.

EDIT:
Here's a bug; wherever the generator and field is placed, it makes a shadow on the nodes that touch it. anybody know how to stop this?

so here it is:
https://www.dropbox.com/s/785y2nqnroimjzq/elevator.zip

here's the older, boringer version:
https://www.dropbox.com/s/qb6o7382w39pm ... evator.zip
any ideas on how to make it better, let me know.
enjoy!
Last edited by aximx51v on Sun Mar 03, 2013 21:41, edited 1 time in total.

User avatar
Aqua
Member
Posts: 641
Joined: Wed Aug 22, 2012 09:11
Location: Sydney~Singapore
Contact:

by Aqua » Post

Interesting idea! +2
Hi there ^.~

User avatar
jojoa1997
Member
Posts: 2890
Joined: Thu Dec 13, 2012 05:11
Location: Earth

by jojoa1997 » Post

i like it +3
Coding;
1X coding
3X debugging
12X tweaking to be just right

User avatar
Mito551
Member
Posts: 1271
Joined: Sat Jun 16, 2012 15:03

by Mito551 » Post

+4 just to continue the order :D
actually, i like it.

User avatar
rubenwardy
Moderator
Posts: 6288
Joined: Tue Jun 12, 2012 18:11
GitHub: rubenwardy
IRC: rubenwardy
In-game: rubenwardy
Location: United Kingdom
Contact:

by rubenwardy » Post

+5

It's similar to the rope mod

User avatar
VanessaE
Moderator
Posts: 4549
Joined: Sun Apr 01, 2012 12:38
GitHub: VanessaE
IRC: VanessaE
In-game: VanessaE
Location: Western NC
Contact:

by VanessaE » Post

Awesome!
You might like some of my stuff: Plantlife ~ More Trees ~ Home Decor ~ Pipeworks ~ HDX Textures (64-512px)

User avatar
Likwid H-Craft
Member
Posts: 1113
Joined: Sun Jan 06, 2013 14:20
Location: Lost in Crypt

by Likwid H-Craft » Post

Hey if it all, fine with you I, will use this for my Portaltest.
My Domain's/others:
http://likwidtest.hj.cx/ (Not Done)

User avatar
Jalo
Member
Posts: 15
Joined: Sun Jan 27, 2013 22:46

by Jalo » Post

Idea make it cooler! you add a door on one side, and a glass roof, so you can go in lava and, water then we can make a just water world and, make Bioshock.

User avatar
aximx51v
Member
Posts: 60
Joined: Fri Dec 07, 2012 03:47

by aximx51v » Post

Likwid H-Craft wrote:Hey if it all, fine with you I, will use this for my Portaltest.
yeah, i suppose you might be able to throw it in there.
were you wanting to change anything in this mod, cosmetic or otherwise?
I'd love to hear any ideas.

User avatar
kaeza
Moderator
Posts: 2162
Joined: Thu Oct 18, 2012 05:00
GitHub: kaeza
IRC: kaeza diemartin blaaaaargh
In-game: kaeza
Location: Montevideo, Uruguay
Contact:

by kaeza » Post

Mito551 wrote:+4 just to continue the order :D
actually, i like it.
rubenwardy wrote:+5

It's similar to the rope mod
VanessaE wrote:Awesome!
^^^^^ C-C-C-C-COMBO BREAKER

Seriously though, a creative way to implement an elevator.
+6 :D
Your signature is not the place for a blog post. Please keep it as concise as possible. Thank you!

Check out my stuff! | Donations greatly appreciated! PayPal

User avatar
VanessaE
Moderator
Posts: 4549
Joined: Sun Apr 01, 2012 12:38
GitHub: VanessaE
IRC: VanessaE
In-game: VanessaE
Location: Western NC
Contact:

by VanessaE » Post

fine, +7 :-)
You might like some of my stuff: Plantlife ~ More Trees ~ Home Decor ~ Pipeworks ~ HDX Textures (64-512px)

User avatar
Likwid H-Craft
Member
Posts: 1113
Joined: Sun Jan 06, 2013 14:20
Location: Lost in Crypt

by Likwid H-Craft » Post

Well, why don't you make, it pushs players, or make a new one that will, since I am trying make this.
Image the Excursion Funnel.

Portal 2!
Last edited by Likwid H-Craft on Tue Jan 29, 2013 13:27, edited 1 time in total.
My Domain's/others:
http://likwidtest.hj.cx/ (Not Done)

User avatar
aximx51v
Member
Posts: 60
Joined: Fri Dec 07, 2012 03:47

by aximx51v » Post

yeah, that'd be cool. but i have no idea how to implement that.
maybe create a node that spawns invisible entities that move inside of a 'beam', and attach themselves to the player and 'drag' the player along inside the beam.
But i am completely new to Lua, i have no idea how to do that.

User avatar
Likwid H-Craft
Member
Posts: 1113
Joined: Sun Jan 06, 2013 14:20
Location: Lost in Crypt

by Likwid H-Craft » Post

Ok. Hmm I maybe can do the block and, see if I can program with your's Elevator see, if I can make it work.

Oh and since I just started this I rating system, I will give you 500+ MESE since I never have seen anyone, tryed do this.
Last edited by Likwid H-Craft on Wed Jan 30, 2013 13:24, edited 1 time in total.
My Domain's/others:
http://likwidtest.hj.cx/ (Not Done)

User avatar
Ragnarok
Member
Posts: 216
Joined: Thu Mar 22, 2012 12:56
Location: Poland
Contact:

by Ragnarok » Post

@aximx51v
I'm in love with your mod :D I replaced almost all long ladders in my cubic world. What do you think about animating beam texture?

EDIT:
I have this issue after using calibrator (in not all cases):

Code: Select all

20:29:18: ERROR[main]: ServerError: LuaError: error: /usr/local/share/minetest/builtin/misc.lua:10: C stack overflow
20:29:18: ERROR[main]: stack traceback:
20:29:18: ERROR[main]:     [C]: in function 'remove_node'
20:29:18: ERROR[main]:     /usr/local/share/minetest/builtin/item.lua:333: in function </usr/local/share/minetest/builtin/item.lua:299>
20:29:18: ERROR[main]:     (tail call): ?
20:29:18: ERROR[main]:     [C]: in function 'dig_node'
20:29:18: ERROR[main]:     ...home/radek/.minetest/mods/minetest/elevator/init.lua:82: in function <...home/radek/.minetest/mods/minetest/elevator/init.lua:78>
20:29:18: ERROR[main]:     [C]: in function 'remove_node'
20:29:18: ERROR[main]:     /usr/local/share/minetest/builtin/item.lua:333: in function </usr/local/share/minetest/builtin/item.lua:299>
20:29:18: ERROR[main]:     (tail call): ?
20:29:18: ERROR[main]:     [C]: in function 'dig_node'
20:29:18: ERROR[main]:     ...home/radek/.minetest/mods/minetest/elevator/init.lua:82: in function <...home/radek/.minetest/mods/minetest/elevator/init.lua:78>
20:29:18: ERROR[main]:     [C]: in function 'remove_node'
20:29:18: ERROR[main]:     ...
20:29:18: ERROR[main]:     /usr/local/share/minetest/builtin/item.lua:201: in function </usr/local/share/minetest/builtin/item.lua:124>
20:29:18: ERROR[main]:     (tail call): ?
20:29:18: ERROR[main]:     (tail call): ?
20:29:18: ERROR[main]:     [C]: in function 'place_node'
20:29:18: ERROR[main]:     ...home/radek/.minetest/mods/minetest/elevator/init.lua:69: in function 'after_place_node'
20:29:18: ERROR[main]:     /usr/local/share/minetest/builtin/item.lua:201: in function </usr/local/share/minetest/builtin/item.lua:124>
20:29:18: ERROR[main]:     (tail call): ?
20:29:18: ERROR[main]:     (tail call): ?
20:29:18: ERROR[main]:     [C]: in function 'place_node'
20:29:18: ERROR[main]:     ...home/radek/.minetest/mods/minetest/elevator/init.lua:103: in function <...home/radek/.minetest/mods/minetest/elevator/init.lua:92>
Last edited by Ragnarok on Tue Feb 05, 2013 19:33, edited 1 time in total.

User avatar
BZab
Member
Posts: 126
Joined: Mon Jan 28, 2013 10:04
Location: Poland

by BZab » Post

Ragnarok wrote:@aximx51v
I'm in love with your mod :D I replaced almost all long ladders in my cubic world. What do you think about animating beam texture?

EDIT:
I have this issue after using calibrator (in not all cases):

Code: Select all

20:29:18: ERROR[main]: ServerError: LuaError: error: /usr/local/share/minetest/builtin/misc.lua:10: C stack overflow
20:29:18: ERROR[main]: stack traceback:
20:29:18: ERROR[main]:     [C]: in function 'remove_node'
20:29:18: ERROR[main]:     /usr/local/share/minetest/builtin/item.lua:333: in function </usr/local/share/minetest/builtin/item.lua:299>
20:29:18: ERROR[main]:     (tail call): ?
20:29:18: ERROR[main]:     [C]: in function 'dig_node'
20:29:18: ERROR[main]:     ...home/radek/.minetest/mods/minetest/elevator/init.lua:82: in function <...home/radek/.minetest/mods/minetest/elevator/init.lua:78>
20:29:18: ERROR[main]:     [C]: in function 'remove_node'
20:29:18: ERROR[main]:     /usr/local/share/minetest/builtin/item.lua:333: in function </usr/local/share/minetest/builtin/item.lua:299>
20:29:18: ERROR[main]:     (tail call): ?
20:29:18: ERROR[main]:     [C]: in function 'dig_node'
20:29:18: ERROR[main]:     ...home/radek/.minetest/mods/minetest/elevator/init.lua:82: in function <...home/radek/.minetest/mods/minetest/elevator/init.lua:78>
20:29:18: ERROR[main]:     [C]: in function 'remove_node'
20:29:18: ERROR[main]:     ...
20:29:18: ERROR[main]:     /usr/local/share/minetest/builtin/item.lua:201: in function </usr/local/share/minetest/builtin/item.lua:124>
20:29:18: ERROR[main]:     (tail call): ?
20:29:18: ERROR[main]:     (tail call): ?
20:29:18: ERROR[main]:     [C]: in function 'place_node'
20:29:18: ERROR[main]:     ...home/radek/.minetest/mods/minetest/elevator/init.lua:69: in function 'after_place_node'
20:29:18: ERROR[main]:     /usr/local/share/minetest/builtin/item.lua:201: in function </usr/local/share/minetest/builtin/item.lua:124>
20:29:18: ERROR[main]:     (tail call): ?
20:29:18: ERROR[main]:     (tail call): ?
20:29:18: ERROR[main]:     [C]: in function 'place_node'
20:29:18: ERROR[main]:     ...home/radek/.minetest/mods/minetest/elevator/init.lua:103: in function <...home/radek/.minetest/mods/minetest/elevator/init.lua:92>
If I won't forget, and sb will code it - i maybe will tomorrow make animated dots/stripes texture for it ;)

PS Can I slowly fall by it? or only go up?

User avatar
lord_james
Member
Posts: 51
Joined: Sun Mar 11, 2012 22:06

by lord_james » Post

Sci-fi ideas for a minetest game, +8

User avatar
aximx51v
Member
Posts: 60
Joined: Fri Dec 07, 2012 03:47

by aximx51v » Post

Ragnarok:
interesting problem. can you give me some idea of when it happens, and what's around the field that you're calibrating?
and are you running 0.4.4?

BZab:
if you want to animate the beam texture, by all means, go ahead!
I tried at one point, but this stuff's all new to me and i didn't get it working.

you can go up and down inside the beam, just like a ladder. i initially tried to make the field act like water, so you'd slowly fall inside it. but that init.lua was getting super messy, and not working too well, so i ditched it for a simpler method.

User avatar
Ragnarok
Member
Posts: 216
Joined: Thu Mar 22, 2012 12:56
Location: Poland
Contact:

by Ragnarok » Post

@aximx51v
In certain situations, when I moving inside the beam, from time to time I see a wall of dots. As if the two beams tied at this point (one over the other). This error occurs when trying to calibrate such field. I using 0.4.4-d1
i initially tried to make the field act like water


What do you think about field acting like... ufo mod? When player is inside the beam and press up/down button, starts moving faster and faster in specified direction, and he moves as far as he doesn't meet generator block. It can be usefull in deep shafts. For example mine is 1024 nodes long and travel takes some time, when I have to constantly press up button to get out to the surface (yes, this is frustrating).
Last edited by Ragnarok on Wed Feb 06, 2013 07:30, edited 1 time in total.

User avatar
BZab
Member
Posts: 126
Joined: Mon Jan 28, 2013 10:04
Location: Poland

by BZab » Post

@up: So i make 2x1 holes to travel up/down - in one cube ladders, in second nothing
At lowest part of it i put a bit of water, so down -> i can fall w/o risk of death/being hurt... But traveling up back...

User avatar
Ragnarok
Member
Posts: 216
Joined: Thu Mar 22, 2012 12:56
Location: Poland
Contact:

by Ragnarok » Post

Sure BZab I using the same technique, but traveling to the surface (through 1024 nodes shaft) is horrible. Thus the idea.

User avatar
BZab
Member
Posts: 126
Joined: Mon Jan 28, 2013 10:04
Location: Poland

by BZab » Post

Code: Select all

{name="grav_suppress_field_animated.png", animation={type="vertical_frames", aspect_w=16, aspect_h=16, length=2.0}}
},
Here's code for animated texture instead of not-animated...
It's got 13 frames... Should I change sth in code? (of course i dont ask about file's name)

I made 3 versions (one is yellow base, with moving orange dots, 2nd and 3rd v. are moving yellow/orange dots only):
Base with moving orange
Dots1
Dots2
All 3 versions are edited original ;O

@EDIT: Maybe I'll also try to make better 64x64 and 16x16 textures for that block ;)
@EDIT2: Imageshack destroyed it 'a bit' - to see textures download it and then look...
Last edited by BZab on Wed Feb 06, 2013 12:18, edited 1 time in total.

User avatar
BZab
Member
Posts: 126
Joined: Mon Jan 28, 2013 10:04
Location: Poland

by BZab » Post

Found bug:

Code: Select all

23:38:25: ACTION[ServerThread]:  places node elevator:grav_suppress_field at (-312,-388,-63)
terminate called after throwing an instance of 'LuaError'
  what():  LuaError: error running function get_staticdata: /home/BZab/minetest/bin/../builtin/serialize.lua:71: C stack overflow

stack traceback:
    [C]: in function 'place_node'
    ...ome/BZab/.minetest/mods/minetest/elevator/init.lua:69: in function 'after_place_node'
    /home/BZab/minetest/bin/../builtin/item.lua:201: in function 'old_item_place_node'
    ...e/BZab/.minetest/mods/minetest/node_owner/init.lua:26: in function <...e/BZab/.minetest/mods/minetest/node_owner/init.lua:14>
    (tail call): ?
    (tail call): ?
    (tail call): ?
    [C]: in function 'place_node'
    ...ome/BZab/.minetest/mods/minetest/elevator/init.lua:69: in function 'after_place_node'
    /home/BZab/minetest/bin/../builtin/item.lua:201: in function 'old_item_place_node'
    ...e/BZab.minetest/mods/minetest/node_owner/init.lua:26: in function <...e/BZab/.minetest/mods/minetest/node_owner/init.lua:14>
    ...
    (tail call): ?
    (tail call): ?
    (tail call): ?
    [C]: in function 'place_node'
    ...ome/BZab/.minetest/mods/minetest/elevator/init.lua:32: in function 'after_place_node'
    /home/BZab/minetest/bin/../builtin/item.lua:201: in function 'old_item_place_node'
    ...e/BZab/.minetest/mods/minetest/node_owner/init.lua:26: in function <...e/BZab/.minetest/mods/minetest/node_owner/init.lua:14>
    (tail call): ?
    (tail call): ?
    (tail call): ?
Przerwane (core dumped)
I tried to put on top of elevator to mine... around 1000-1100 nodes height
It crashed game and when i restarted it anti-gravity field was only from top to around 200 nodes under top...

User avatar
aximx51v
Member
Posts: 60
Joined: Fri Dec 07, 2012 03:47

by aximx51v » Post

DZab:
thanks for the animations, i'll take a look and let you know what's good.
as for new tile images, I'm open to suggestions, but i perfer the simpler 16x16 look over anything else

Ragnarok:
the idea of the players moving up/down inside the field similar to the ufo mod sounds like a really cool idea!
i'd probably end up re-writing most of the init.lua script, but hey, if it works...

the reason you see the field image when standing inside the field and looking up/down is (i think) just a glitch in the terrain generator. i will try to remedy that by removing the images from the top/bottom of the field node.

as for your errors, i'll take a look and try to replicate them. I'm not an experienced coder by any stretch of the imagination. I built this mod with a lot of trial and error, after studying other mods. If anybody wants to help me with this, they're welcome :)

User avatar
aximx51v
Member
Posts: 60
Joined: Fri Dec 07, 2012 03:47

by aximx51v » Post

BZab wrote:

Code: Select all

{name="grav_suppress_field_animated.png", animation={type="vertical_frames", aspect_w=16, aspect_h=16, length=2.0}}
},
Here's code for animated texture instead of not-animated...
It's got 13 frames... Should I change sth in code? (of course i dont ask about file's name)

I made 3 versions (one is yellow base, with moving orange dots, 2nd and 3rd v. are moving yellow/orange dots only):
Base with moving orange
Dots1
Dots2
All 3 versions are edited original ;O

@EDIT: Maybe I'll also try to make better 64x64 and 16x16 textures for that block ;)
@EDIT2: Imageshack destroyed it 'a bit' - to see textures download it and then look...
i tried your animations, but they don't work for me. in fact they look the same way mine did when i attempted to do my own.
here's what i see, no movement whatsoever:
Image

maybe it's a problem with the way the game works with my video drivers? idk. any ideas?

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests