video_driver = direct3d9 causes game to crash [Solved]

User avatar
markbe
Member
 
Posts: 23
Joined: Thu Jun 06, 2013 23:00
Location: Auckland, New Zealand

video_driver = direct3d9 causes game to crash [Solved]

by markbe » Thu Jun 06, 2013 23:10

Windows 8, Minetest 0.4.7

Game opens OK in OpenGL but has usual Windows performance issue of 7fps

When "video_driver = direct3d9" is added to minetest.conf the game crashes after selecting your world. This happens in single player and server modes

Nothing of usefulness appears on the error log
Last edited by markbe on Fri Jun 07, 2013 23:51, edited 1 time in total.
 

User avatar
Inocudom
Member
 
Posts: 3031
Joined: Sat Sep 29, 2012 01:14
IRC: Inocudom
In-game: Inocudom

by Inocudom » Thu Jun 06, 2013 23:27

Most Windows builds don't have Direct X compatibility. If you want to be able to use Direct X, you must use builds made by either xyz (I don't think he makes builds anymore) or Fess (his builds are only 64-bit and he is having trouble making them these days.)
Recovering from the abomination I am. Clocking time for Garry's Mod I am too.
 

User avatar
PilzAdam
Member
 
Posts: 4026
Joined: Fri Jul 20, 2012 16:19
Location: Germany
GitHub: PilzAdam
IRC: PilzAdam

by PilzAdam » Thu Jun 06, 2013 23:29

Inocudom wrote:Most Windows builds don't have Direct X compatibility. If you want to be able to use Direct X, you must use builds made by either xyz (I don't think he makes builds anymore) or Fess (his builds are only 64-bit and he is having trouble making them these days.)

xyz does the official release builds. And I guess markbe uses them.
 

User avatar
markbe
Member
 
Posts: 23
Joined: Thu Jun 06, 2013 23:00
Location: Auckland, New Zealand

by markbe » Thu Jun 06, 2013 23:30

the previous version (0.4.6) worked without resorting to "unofficial" build. Was it compiled differently?
 

User avatar
markbe
Member
 
Posts: 23
Joined: Thu Jun 06, 2013 23:00
Location: Auckland, New Zealand

by markbe » Thu Jun 06, 2013 23:34

Yes, I used the official build
PilzAdam wrote:
Inocudom wrote:Most Windows builds don't have Direct X compatibility. If you want to be able to use Direct X, you must use builds made by either xyz (I don't think he makes builds anymore) or Fess (his builds are only 64-bit and he is having trouble making them these days.)

xyz does the official release builds. And I guess markbe uses them.
 

User avatar
markbe
Member
 
Posts: 23
Joined: Thu Jun 06, 2013 23:00
Location: Auckland, New Zealand

by markbe » Fri Jun 07, 2013 06:39

Just in case, I tried the following:
- disabled all downloaded mods - no change
- re-downloaded the ZIP in case there was some corruption - no change
- created new Minetest world and started game using that - no change
- created new Minimal world and started game using that - no change

I'm going to have a go at compiling it myself but that's a bit of a learning curve :-)
 

User avatar
Calinou
Moderator
 
Posts: 3145
Joined: Mon Aug 01, 2011 14:26
Location: Troyes, France
GitHub: Calinou
IRC: Calinou
In-game: Calinou

by Calinou » Fri Jun 07, 2013 07:58

markbe wrote:Game opens OK in OpenGL but has usual Windows performance issue of 7fps


If you have 7 FPS, you might as well blame your hardware or your setup (did you press "R" to toggle full viewing range?).

There is no "usual Windows performance issue".
 

User avatar
xyz
Member
 
Posts: 450
Joined: Thu Nov 10, 2011 14:25

by xyz » Fri Jun 07, 2013 11:28

markbe wrote:Windows 8, Minetest 0.4.7

Game opens OK in OpenGL but has usual Windows performance issue of 7fps

When "video_driver = direct3d9" is added to minetest.conf the game crashes after selecting your world. This happens in single player and server modes

Nothing of usefulness appears on the error log

I've fixed it, try redownloading the official build http://minetest.ru/builds/minetest-0.4.7.zip
 

User avatar
markbe
Member
 
Posts: 23
Joined: Thu Jun 06, 2013 23:00
Location: Auckland, New Zealand

by markbe » Fri Jun 07, 2013 22:23

Calinou wrote:
markbe wrote:Game opens OK in OpenGL but has usual Windows performance issue of 7fps


If you have 7 FPS, you might as well blame your hardware or your setup (did you press "R" to toggle full viewing range?).

There is no "usual Windows performance issue".


Sorry ... to be fair, I should have said "My usual OpenGL performance issue" .... My hardware works best with Direct X.

Yes, I am aware of the full-range toggle ... I use that sparingly (usually when I get lost and want to find a recognizable landmark) :-)
 

User avatar
markbe
Member
 
Posts: 23
Joined: Thu Jun 06, 2013 23:00
Location: Auckland, New Zealand

by markbe » Fri Jun 07, 2013 22:31

xyz wrote:
markbe wrote:Windows 8, Minetest 0.4.7

Game opens OK in OpenGL but has usual Windows performance issue of 7fps

When "video_driver = direct3d9" is added to minetest.conf the game crashes after selecting your world. This happens in single player and server modes

Nothing of usefulness appears on the error log

I've fixed it, try redownloading the official build http://minetest.ru/builds/minetest-0.4.7.zip


Thanks! That's sorted it ... Direct X now works. Most grateful
 


Return to Problems



Who is online

Users browsing this forum: No registered users and 1 guest