Problemas con los mods

Spanish
Ochotre
Member
 
Posts: 11
Joined: Sun Feb 15, 2015 20:08
In-game: Ochotre

Problemas con los mods

by Ochotre » Sun Feb 15, 2015 21:50

Baje los siguientes mods:
PilzAdam-beds-9a4a4a9

PilzAdam-farming_plus-7e0d976

Y no puede entrar a jugar pues me dice que hay un error en
ModError: ModError: Failed to load and run /home/arjuna/.minetest/mods/PilzAdam-beds-9a4a4a9/init.lua

Lo único que me parecería es que no se si tengo el wool, ni el farming que dicen son depenendecy....

Gracias de antemano.
 

User avatar
Bas080
Member
 
Posts: 398
Joined: Mon May 21, 2012 15:54
Location: Netherlands
GitHub: bas080
IRC: bas080
In-game: bas080

Re: Problemas con los mods

by Bas080 » Sat Feb 21, 2015 01:16

Debes recordar cambiar el nombre del directorio. Busca en el init.lua para la siguente.

minetest.register_node( '<nombre>:....

Usa el nombre para el nombre de tu directorio. Perdoname para mi espanol horrible.
 

Ochotre
Member
 
Posts: 11
Joined: Sun Feb 15, 2015 20:08
In-game: Ochotre

Re: Problemas con los mods

by Ochotre » Sat Feb 28, 2015 23:06

Excelente español, está mejor que mi inglés, de hecho no note fallas jeje :)

Ahora me sale lo siguiente :(

/usr/share/minetest/builtin/fstk/ui.lua:155: in function </usr/share/minetest/builtin/fstk/ui.lua:148>
 

User avatar
ever
Member
 
Posts: 31
Joined: Wed Feb 19, 2014 03:50
Location: Argentina

Re: Problemas con los mods

by ever » Sun Mar 08, 2015 20:07

Haz renombrado la carpeta de cada mod o las has dejado con el nombre que te pone al descomprimirlas?
La carpeta "PilzAdam-beds-9a4a4a9" debe llamarse "beds"
y "PilzAdam-farming_plus-7e0d976", debe llamarse "farming_plus"
 

Ochotre
Member
 
Posts: 11
Joined: Sun Feb 15, 2015 20:08
In-game: Ochotre

Re: Problemas con los mods

by Ochotre » Fri Mar 13, 2015 03:08

Sip ahora el problema es por ejemplo el siguiente:
21:05:37: ERROR[main]: ModError: ModError: Failed to load and run /home/arjuna/.minetest/mods/animals/factions/init.lua

...y así con otros como el de farming.
 

User avatar
ever
Member
 
Posts: 31
Joined: Wed Feb 19, 2014 03:50
Location: Argentina

Re: Problemas con los mods

by ever » Fri Mar 13, 2015 04:44

Tal vez te falten mod dependencia. Fijate en la solapa mods, en el mod que tengas instalado te dice la dependencia de cada uno.
Inicia la partida? ese mensaje te sale cuando estas jugando no?

que versión de minetest usas y en que sistema operativo? Estimo que usas linux
 

carlosr
New member
 
Posts: 4
Joined: Mon Mar 16, 2015 19:15

Re: Problemas con los mods

by carlosr » Mon Mar 16, 2015 19:24

Hola, estoy tratando de usar un subjuego llamado Clonecraft, puse ne la carpeta games y por ahi no hay problema sin embargo al tratar de jugar me sale un error, que lo puse en la imagen de abajo.
me sucede igual con cualquier mod que he intentado instalar.
alguien me puede dar alguna idea de como solucionar esto?
gracias

https://drive.google.com/file/d/0B7WOlWk8WyA7ekdnRzFCS3BQQTQ/view?usp=sharing
 

Ochotre
Member
 
Posts: 11
Joined: Sun Feb 15, 2015 20:08
In-game: Ochotre

Re: Problemas con los mods

by Ochotre » Thu Mar 19, 2015 01:06

ever wrote:Tal vez te falten mod dependencia. Fijate en la solapa mods, en el mod que tengas instalado te dice la dependencia de cada uno.
Inicia la partida? ese mensaje te sale cuando estas jugando no?

que versión de minetest usas y en que sistema operativo? Estimo que usas linux


Sip, estoy con ubuntu studio... en los mods de dependencia en teoría no falta ninguno, no puede entrar al juego, elimine una carpeta y me sale luaEntity name "creatures:sheep" not defined y así copn cada animal... y el farming igual...
 

User avatar
ever
Member
 
Posts: 31
Joined: Wed Feb 19, 2014 03:50
Location: Argentina

Re: Problemas con los mods

by ever » Thu Mar 19, 2015 03:43

No están dando la información completa y es casi como estar adivinando.
Hagan lo siguiente. Con minetest cerrado: Entren a la carpeta de configuración .minetest en su usuario (esta oculta) y borren el archivo debug.txt; luego abran minetest y repitan los pasos para que salga el error que tienen.

Adjunten el archivo debug.txt en el siguiente mensaje
 

carlosr
New member
 
Posts: 4
Joined: Mon Mar 16, 2015 19:15

Re: Problemas con los mods

by carlosr » Thu Mar 19, 2015 13:32

Hola Ever gracias por responder. El error que mencione en el mensaje anterior lo solucione al encontrar que la version que tenia de minetest no era la mas reciente, parece que la que se descarga del centro de software de ubuntu no esta actualizada. Sin embargo ahora algunos mods no me funcionan, en particular quiero intalar uno lamado Beds, abajo pongo el error.

Irrlicht log: Irrlicht Engine version 1.8.1
Irrlicht log: Linux 3.13.0-46-generic #79-Ubuntu SMP Tue Mar 10 20:08:14 UTC 2015 i686
Irrlicht log: Using renderer: OpenGL 3.0
Irrlicht log: Gallium 0.4 on AMD RS780: X.Org
Irrlicht log: OpenGL driver version is 1.2 or better.
Irrlicht log: GLSL version: 1.3
08:27:02: ACTION[main]: WARNING: Mod name conflict detected: "beds"
08:27:02: ACTION[main]: Will not load: /usr/share/minetest/games/minetest_game/mods/beds
08:27:02: ACTION[main]: Overridden by: /home/carlos/.minetest/mods/beds
08:27:03: ERROR[main]: ========== ERROR FROM LUA ===========
08:27:03: ERROR[main]: Failed to load and run script from
08:27:03: ERROR[main]: /home/carlos/.minetest/mods/beds/init.lua:
08:27:03: ERROR[main]: cannot open /home/carlos/.minetest/mods/beds/init.lua: Permiso denegado
08:27:03: ERROR[main]: ======= END OF ERROR FROM LUA ========
08:27:03: ERROR[main]: Server: Failed to load and run /home/carlos/.minetest/mods/beds/init.lua
08:27:03: ERROR[main]: ModError: ModError: Failed to load and run /home/carlos/.minetest/mods/beds/init.lua
 

Ochotre
Member
 
Posts: 11
Joined: Sun Feb 15, 2015 20:08
In-game: Ochotre

Re: Problemas con los mods

by Ochotre » Sun Mar 22, 2015 01:08

Me acabo de dar cuenta de lo mismo jajaja, pero cómo la actualizo, yo tengo ubuntustudio...????
 

User avatar
ever
Member
 
Posts: 31
Joined: Wed Feb 19, 2014 03:50
Location: Argentina

Re: Problemas con los mods

by ever » Sun Mar 22, 2015 05:53

Bien, primero hagan una copia de los mundos que tengan creados y no quieran perder en la actualización. Se supone que la actualización los va a conservar, pero por las dudas hagan una copia de los mismos. Si quieren hacer una actualización limpia, purguen la intalacion anterior desde consola o desinstalen por completo con Synaptic.

Luego actualicen a la ultima versión de minetest. La mejor opción, en mi opinión es desde repositorios. Este proceso es para Ubuntu, Linux mint y derivados.

1° Agregar el repositorio de minetest. En la terminal copian la siguiente linea, después les va a pedir su clave de usuario. Esto agrega el repositorio a la lista de repositorios de su sistema y descarga la clave del mismo

sudo add-apt-repository ppa:minetestdevs/stable

2° Actualizan la lista de paquetes del sistema

sudo apt-get update

3° Instalan actualizaciones de paquetes (si es que existen). Este paso no es necesario para la instalación, pero es bueno tener el sistema actualizado ;)

sudo apt-get upgrade

4° Instalan minetest desde el repositorio recién instalado. También se instalan automáticamente otros paquetes necesarios si no los tienen(libleveldb1 libluajit-5.1-2 libluajit-5.1-common libsnappy1)

sudo apt-get install minetest

- Cada vez que se haga una actualización del repositorio, se instalara en su sistema. El repositorio y lo que les acabo de decir se puede ver acá https://code.launchpad.net/~minetestdev ... ntu/stable

Vuelvan a instalar los mods que quieren usar.
Contesten el mensaje si funciono y si no, ya saben como reportar el error.
 

User avatar
ever
Member
 
Posts: 31
Joined: Wed Feb 19, 2014 03:50
Location: Argentina

Re: Problemas con los mods

by ever » Tue Mar 24, 2015 13:17

Ayer actualice en linux mint desde la versión 0.4.9 a la 0.4.12 sin problemas. Conserva las partidas y la configuración.
 

carlosr
New member
 
Posts: 4
Joined: Mon Mar 16, 2015 19:15

Re: Problemas con los mods

by carlosr » Thu Mar 26, 2015 02:12

Hola, como les comente instalando con el repositorio he podido jugar, he usado los mods que se descargan del menu en la pesta;a mods sin problema, pero los mods que se instalan guardando en la carpeta correspondiente simpre me dan error. Pero ahora he tenido un problema mayor y es que en cualquier momento desaparece el mapa y solo queda el cielo azul y el sol, y no puedo moverme ni hacer nada mas, mire el debug txt y al final me sale esto

20:59:21: ACTION[ServerThread]: singleplayer places node default:desert_cobble at (152,32,-70)
Irrlicht log: Could not open file of texture: UV_rat.png
Irrlicht log: Could not open file of texture: UV_rat.png
Irrlicht log: Could not open file of texture: boat.png
20:59:26: ACTION[ServerThread]: singleplayer places node default:desert_cobble at (151,32,-70)
Irrlicht log: Could not open file of texture: UV_rat.png
20:59:36: ACTION[ServerThread]: singleplayer places node default:desert_cobble at (154,31,-70)
20:59:37: ACTION[ServerThread]: singleplayer places node default:desert_cobble at (153,31,-70)
20:59:38: ACTION[ServerThread]: singleplayer places node default:desert_cobble at (152,31,-70)
20:59:39: ACTION[ServerThread]: singleplayer places node default:desert_cobble at (151,31,-70)
20:59:43: ACTION[ServerThread]: singleplayer places node default:desert_cobble at (150,31,-70)
21:00:12: ACTION[ServerThread]: singleplayer digs default:desert_sand at (150,28,-66)
21:00:14: ACTION[ServerThread]: singleplayer digs default:desert_sand at (150,27,-65)
21:00:15: ACTION[ServerThread]: singleplayer digs default:desert_sand at (150,27,-66)
21:00:38: ERROR[main]: WARNING: updateListener: invalid value
21:00:38: ERROR[main]: WARNING: updateListener: invalid value
21:00:38: ERROR[main]: WARNING: updateListener: invalid value
21:00:38: ERROR[main]: WARNING: updateListener: invalid value
21:00:38: ERROR[main]: WARNING: updateListener: invalid value
21:00:38: ERROR[main]: WARNING: updateListener: invalid value
21:00:38: ERROR[main]: WARNING: updateListener: invalid value
21:00:38: ERROR[main]: WARNING: updateListener: invalid value
21:00:38: ERROR[main]: WARNING: updateListener: invalid value
21:00:38: ERROR[main]: WARNING: updateListener: invalid value
21:00:38: ERROR[main]: WARNING: updateListener: invalid value
21:00:38: ERROR[main]: WARNING: updateListener: invalid value
21:00:38: ERROR[main]: WARNING: updateListener: invalid value
21:00:38: ERROR[main]: WARNING: updateListener: invalid value

y este mensaje de error se repite al infinito.
 

User avatar
ever
Member
 
Posts: 31
Joined: Wed Feb 19, 2014 03:50
Location: Argentina

Re: Problemas con los mods

by ever » Fri Mar 27, 2015 03:13

Y la partida ya no se puede recuperar no? por mas que salgar y vuelvas a entrar? Si es así, me paso lo mismo. Creo que es un bug en el código del juego y no tiene nada que ver con los mod. Surgió posiblemente en la versión 0.4.11. Voy a preguntar y me doy una vuelta por acá de nuevo
 

User avatar
ever
Member
 
Posts: 31
Joined: Wed Feb 19, 2014 03:50
Location: Argentina

Re: Problemas con los mods

by ever » Fri Mar 27, 2015 03:34

Es un bug de larga data y no saben que lo causa
viewtopic.php?f=6&t=5301&start=25

Si hablas ingles repórtalo en el mensaje que te pase.
 

carlosr
New member
 
Posts: 4
Joined: Mon Mar 16, 2015 19:15
 


Return to Español



Who is online

Users browsing this forum: No registered users and 1 guest