[Archlinux] Unable to start Minetest

Post Reply
User avatar
simsor
New member
Posts: 6
Joined: Sun Mar 25, 2012 10:29

[Archlinux] Unable to start Minetest

by simsor » Post

Hello,

I recently installed Minetest on my Archlinux x64, and the game runs without errors in the console, but I just have a grey screen, with no menu...
I use the latest stable version from AUR, and I just did an update of my system.

The same problem happens with the latest dev build.

Here is what shows in the console:
Irrlicht Engine version 1.7.3
Linux 3.2.6-2-ARCH #1 SMP PREEMPT Thu Feb 16 10:10:02 CET 2012 x86_64
Creating X window...
Visual chosen: : 276
Using renderer: OpenGL 2.1
Gallium 0.4 on AMD RS880: X.Org
OpenGL driver version is 1.2 or better.
GLSL version: 1.2
Unsupported texture format
Loaded texture: /usr/share/minetest/mud.png
Loaded texture: /usr/share/minetest/menulogo.png
locale has been set to:fr_FR.UTF-8
locale has been set to:C
locale has been set to:fr_FR.UTF-8
locale has been set to:C
locale has been set to:fr_FR.UTF-8
locale has been set to:C
Does anybody know how to fix this error ? I already played minetest before, on the same system, and it worked...I don't know why it doesn't anymore :-(

Thank you for reading me,
Simsor

User avatar
bgsmithjr
Member
Posts: 436
Joined: Thu Mar 08, 2012 23:21
Location: USA,Michigan

by bgsmithjr » Post

Find the location of your console textures, it is weird that you have them in minetest base directory, they were in minetest/data/clienttextures. I just had that error and it was because I didn't have the textures it was trying to load. I wouldn't put much faith in the AUR. I would compile it from source in new, empty directories. If you find you have the textures add texture_path = foundpath to minetest.conf

User avatar
simsor
New member
Posts: 6
Joined: Sun Mar 25, 2012 10:29

by simsor » Post

Ok I'll try to compile it from the sources and keep you informed

EDIT: 0.4.dev gives the exact same problem. :-(
Last edited by simsor on Sun Mar 25, 2012 15:21, edited 1 time in total.

User avatar
Calinou
Moderator
Posts: 3162
Joined: Mon Aug 01, 2011 14:26
GitHub: Calinou
IRC: Calinou
In-game: Calinou
Location: Troyes, France
Contact:

by Calinou » Post

Compile the game, cd into the bin folder, run the Minetest binary, it should work.
Also, I wouldn't recommend using AMD GPUs on Linux.

User avatar
simsor
New member
Posts: 6
Joined: Sun Mar 25, 2012 10:29

by simsor » Post

Ok, I compiled and had the same problem...just to see that if I change tag and then go back, everything works fine ^^
This thing ate my afternoon, but it's worth it ! Yeepee ~ !

User avatar
cosarara97
Member
Posts: 180
Joined: Tue Nov 01, 2011 18:53

by cosarara97 » Post

simsor wrote:Ok, I compiled and had the same problem...just to see that if I change tag and then go back, everything works fine ^^
This thing ate my afternoon, but it's worth it ! Yeepee ~ !
"change tag and then go back"? What tag?
:D

User avatar
simsor
New member
Posts: 6
Joined: Sun Mar 25, 2012 10:29

by simsor » Post

I'm using WMFS, and a

User avatar
Calinou
Moderator
Posts: 3162
Joined: Mon Aug 01, 2011 14:26
GitHub: Calinou
IRC: Calinou
In-game: Calinou
Location: Troyes, France
Contact:

by Calinou » Post

He's probably speaking about renaming the game's folder to "celeron55-minetest-<random letters and numbers here>" then compiling, I had to do that too.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest