[Mod] Enchanting [git] [enchanting]

User avatar
jp
Member
 
Posts: 714
Joined: Wed Dec 18, 2013 09:03
Location: France
GitHub: kilbith

[Mod] Enchanting [git] [enchanting]

by jp » Sat Feb 20, 2016 22:44

Enchanting


A mod adding a Minecraft-inspired Enchantment Table.

3 enchants are proposed for the default tools, and 2 enchants for the armors from 3D Armor.

You can also easily register your own enchanted tools or tweak the enchants.

This mod is originating from X-Decor (license : GPLv3).

Depends : default.
Recommends : 3d_armor.

Image Download | Github

Image Image
Last edited by jp on Mon Feb 29, 2016 18:39, edited 10 times in total.
 

User avatar
MineYoshi
Member
 
Posts: 5357
Joined: Wed Jul 08, 2015 13:20

Re: [Mod] Enchanting [enchanting]

by MineYoshi » Sun Feb 21, 2016 01:31

Wow , the mod looks great, maybe i can include it in my new server!
nire patata zurea da, kide :-)
 

User avatar
firefox
Member
 
Posts: 1440
Joined: Wed Jan 14, 2015 07:34
Location: Xanadu
In-game: Red_Fox

Re: [Mod] Enchanting [git] [enchanting]

by firefox » Sun Feb 21, 2016 18:40

eeehhhh sugoi!

i will include it in my subgame
(whenever i finish the basics and get to add other mods ...)
my game: viewtopic.php?f=49&t=15860 --- building inspiration: viewtopic.php?f=3&t=15550 --- =(^.^)= nya~
 

User avatar
RickMcFarley
Member
 
Posts: 10
Joined: Mon Dec 23, 2013 11:51
 

User avatar
Minetestforfun
Member
 
Posts: 936
Joined: Tue Aug 05, 2014 14:09
Location: On earth
GitHub: Darcidride
IRC: Darcidride + MinetestForFun
In-game: Darcidride + MinetestForFun
 

User avatar
LazerRay
Member
 
Posts: 147
Joined: Sun Jul 27, 2014 01:32
GitHub: LazerRay

Re: [Mod] Enchanting [git] [enchanting]

by LazerRay » Mon Apr 18, 2016 15:22

I'm getting a bug were enchanted armor from 3D-Armor is not rendering properly on the player, instead it comes out as a solid purple blob.
 

User avatar
jp
Member
 
Posts: 714
Joined: Wed Dec 18, 2013 09:03
Location: France
GitHub: kilbith
 

KCoombes
Member
 
Posts: 405
Joined: Thu Jun 11, 2015 23:19
Location: SW Florida, USA
In-game: Knatt
 

User avatar
jp
Member
 
Posts: 714
Joined: Wed Dec 18, 2013 09:03
Location: France
GitHub: kilbith

Re: [Mod] Enchanting [git] [enchanting]

by jp » Wed Apr 20, 2016 11:28

KCoombes wrote:Are shields included?

No, these are not supported.
 

User avatar
LazerRay
Member
 
Posts: 147
Joined: Sun Jul 27, 2014 01:32
GitHub: LazerRay

Re: [Mod] Enchanting [git] [enchanting]

by LazerRay » Fri Apr 22, 2016 14:55

Here are screenshots of the rendering bug I reported:

Default Steel Armor (No enchants)
Image


Same Steel Armor after enchanting
Image

You can see the error message in the second screenshot of what might be happening
 

User avatar
jp
Member
 
Posts: 714
Joined: Wed Dec 18, 2013 09:03
Location: France
GitHub: kilbith
 

kosmonautik
Member
 
Posts: 28
Joined: Fri Jun 24, 2016 10:40
Location: Czech Republic
In-game: kosmonautik

Re: [Mod] Enchanting [git] [enchanting]

by kosmonautik » Mon Dec 05, 2016 14:04

Hello,
I use a 1.4.13 minetest version and it doesn't work. Minetest writes a lua error.

Thanks, kosmonautik
 

kniffo80
New member
 
Posts: 2
Joined: Mon Nov 28, 2016 13:08
GitHub: kniffo80

Re: [Mod] Enchanting [git] [enchanting]

by kniffo80 » Sun Dec 11, 2016 14:34

Same for me. Getting the following error on 0.14.4 Server (Debian):

Code: Select all
2016-12-11 09:32:47: ERROR[Main]: ModError: Failed to load and run script from /root/.minetest/mods/enchanting/init.lua:
2016-12-11 09:32:47: ERROR[Main]: /root/.minetest/mods/enchanting/init.lua:44: attempt to call field 'colorize' (a nil value)
2016-12-11 09:32:47: ERROR[Main]: stack traceback:
2016-12-11 09:32:47: ERROR[Main]:    /root/.minetest/mods/enchanting/init.lua:44: in function 'get_tooltip'
2016-12-11 09:32:47: ERROR[Main]:    /root/.minetest/mods/enchanting/init.lua:268: in function 'register_tools'
2016-12-11 09:32:47: ERROR[Main]:    /root/.minetest/mods/enchanting/init.lua:309: in main chunk
 

User avatar
Napiophelios
Member
 
Posts: 941
Joined: Mon Jul 07, 2014 01:14
GitHub: Napiophelios
IRC: Nappi
In-game: Nappi
 

User avatar
pithy
Member
 
Posts: 251
Joined: Wed Apr 13, 2016 17:34
GitHub: pithydon

Re: [Mod] Enchanting [git] [enchanting]

by pithy » Mon Dec 12, 2016 00:56

kosmonautik wrote:Hello,
I use a 1.4.13 minetest version and it doesn't work. Minetest writes a lua error.

Thanks, kosmonautik


kniffo80 wrote:Same for me. Getting the following error on 0.14.4 Server (Debian):

Code: Select all
2016-12-11 09:32:47: ERROR[Main]: ModError: Failed to load and run script from /root/.minetest/mods/enchanting/init.lua:
2016-12-11 09:32:47: ERROR[Main]: /root/.minetest/mods/enchanting/init.lua:44: attempt to call field 'colorize' (a nil value)
2016-12-11 09:32:47: ERROR[Main]: stack traceback:
2016-12-11 09:32:47: ERROR[Main]:    /root/.minetest/mods/enchanting/init.lua:44: in function 'get_tooltip'
2016-12-11 09:32:47: ERROR[Main]:    /root/.minetest/mods/enchanting/init.lua:268: in function 'register_tools'
2016-12-11 09:32:47: ERROR[Main]:    /root/.minetest/mods/enchanting/init.lua:309: in main chunk


Time travelers can avoid a lot of bugs by only using software from one time.
 

kniffo80
New member
 
Posts: 2
Joined: Mon Nov 28, 2016 13:08
GitHub: kniffo80

Re: [Mod] Enchanting [git] [enchanting]

by kniffo80 » Tue Dec 13, 2016 14:18

pithy wrote:
kosmonautik wrote:Hello,
I use a 1.4.13 minetest version and it doesn't work. Minetest writes a lua error.

Thanks, kosmonautik


kniffo80 wrote:Same for me. Getting the following error on 0.14.4 Server (Debian):

Code: Select all
2016-12-11 09:32:47: ERROR[Main]: ModError: Failed to load and run script from /root/.minetest/mods/enchanting/init.lua:
2016-12-11 09:32:47: ERROR[Main]: /root/.minetest/mods/enchanting/init.lua:44: attempt to call field 'colorize' (a nil value)
2016-12-11 09:32:47: ERROR[Main]: stack traceback:
2016-12-11 09:32:47: ERROR[Main]:    /root/.minetest/mods/enchanting/init.lua:44: in function 'get_tooltip'
2016-12-11 09:32:47: ERROR[Main]:    /root/.minetest/mods/enchanting/init.lua:268: in function 'register_tools'
2016-12-11 09:32:47: ERROR[Main]:    /root/.minetest/mods/enchanting/init.lua:309: in main chunk


Time travelers can avoid a lot of bugs by only using software from one time.


Hmmm ... explain please ;)
 

User avatar
pithy
Member
 
Posts: 251
Joined: Wed Apr 13, 2016 17:34
GitHub: pithydon

Re: [Mod] Enchanting [git] [enchanting]

by pithy » Tue Dec 13, 2016 15:39

kniffo80 wrote:Hmmm ... explain please ;)


It is common for software from deferent times to not work well together.

They must be time travelers to have versions 1.4.13 and 0.14.4 of minetest.
 


Return to Mod Releases



Who is online

Users browsing this forum: Google [Bot], sofar and 7 guests