Unsupported texture format

Post Reply
User avatar
RobSis
Member
Posts: 13
Joined: Fri Jul 08, 2011 23:08
Location: Czech Republic
Contact:

Unsupported texture format

by RobSis » Post

Hello.

I installed all the dependencies required, the code compiles, but I cannot run it.
Here's the output of ./minetest:

Code: Select all

...
INFO: getTextureIdDirect(): Loading path "/home/data/celeron55-minetest-c5f7f456afb1/bin/../data/stone.png"
INFO: Setting stone.png as base
INFO: generate_image_from_scratch(): name=stone.png
last_part_of_name=stone.png
INFO: getTextureIdDirect(): Loading path "/home/data/celeron55-minetest-c5f7f456afb1/bin/../data/stone.png"
INFO: Setting stone.png as base
INFO: generate_image_from_scratch(): name=stone.png
last_part_of_name=stone.png
INFO: getTextureIdDirect(): Loading path "/home/data/celeron55-minetest-c5f7f456afb1/bin/../data/stone.png"
INFO: Setting stone.png as base
Unsupported texture format
FBO error
FBO incomplete

In thread ef5d4780:
/home/data/celeron55-minetest-c5f7f456afb1/src/tile.cpp:1105: bool generate_image(std::string, irr::video::IImage*&, irr::IrrlichtDevice*): Assertion 'rtt' failed.
Debug stacks:
DEBUG STACK FOR THREAD ef5d4780:
#0  int main(int, char**)
Aborted
Any ideas? Thanks!
Last edited by RobSis on Sat Jul 09, 2011 11:42, edited 1 time in total.
7w^6R1 ddTz`C

User avatar
Karlas
Member
Posts: 150
Joined: Fri Jul 08, 2011 20:08

by Karlas » Post

It might be something with your texture pack,try a new one.

User avatar
mstoykov
Member
Posts: 22
Joined: Mon Jun 13, 2011 20:11

by mstoykov » Post

if it isn't from the texture pack ( and it won't be if you haven't installed one :) ) pls tell us what your OS + how you got irrlicht and what version it is :) (also any other kind of information like version of libpng (as the textures are pngs) may prove important :))

User avatar
RobSis
Member
Posts: 13
Joined: Fri Jul 08, 2011 23:08
Location: Czech Republic
Contact:

by RobSis » Post

My OS is GNU/Linux, Debian 6.0.2 (Squeeze).

All required packages are available in official repositories.

Versions:
libirrlicht-dev: 1.7.1
libpng12-dev: 1.2.44-1
libbz2-dev: 1.0.5-6
7w^6R1 ddTz`C

User avatar
mstoykov
Member
Posts: 22
Joined: Mon Jun 13, 2011 20:11

by mstoykov » Post

If you have used texturepack - undo it (probably recompiling it again will be the fastest way) and after this I'm lost :).
There is the wildest idea that you can install dev packages without having the not dev (aka the ones you need for running) but now that I think about it libpng is way too used if it can be told from my system :) and I have the same version as you :S.

User avatar
RobSis
Member
Posts: 13
Joined: Fri Jul 08, 2011 23:08
Location: Czech Republic
Contact:

by RobSis » Post

I never used any texture pack. I believe, that the problem will be in Render-To-Texture. I heard that not every hardware supports that. Also, my laptop is not fully supported by official linux acpi, nor is the graphic adapter... The error is in tile.cpp:1108 (in latest stable). Can I bypass this piece of code somehow? :D
7w^6R1 ddTz`C

kahrl
Member
Posts: 236
Joined: Fri Sep 02, 2011 07:51
Location: Rös̓̇chenhof

by kahrl » Post

If you don't mind rebuilding, you could try replacing the line tile.cpp:1083

Code: Select all

if(driver->queryFeature(video::EVDF_RENDER_TO_TARGET) == false)
with

Code: Select all

if(true || driver->queryFeature(video::EVDF_RENDER_TO_TARGET) == false)

User avatar
RobSis
Member
Posts: 13
Joined: Fri Jul 08, 2011 23:08
Location: Czech Republic
Contact:

by RobSis » Post

Hell yeah! It works!

Thanks, man. I should have paid more attention on my c++ class :)
7w^6R1 ddTz`C

Post Reply

Who is online

Users browsing this forum: Mobilex1122 and 3 guests