Problème installation serveur - Atelier Master [résolu]

French
senzo53
New member
 
Posts: 9
Joined: Mon Jan 23, 2017 14:02

Problème installation serveur - Atelier Master [résolu]

by senzo53 » Mon Jan 23, 2017 14:30

Bonjour,

Je suis étudiant en Master 2 d'urbanisme. Nous réalisons un travail de recherche et actions sur la concertation et le numérique. En ce sens, nous voudrions utiliser l'outil Minetest pour tester la concertation chez les jeunes. J'ai créé une map mais je n'arrive pas a créer un serveur. Je vous explique, je n'arrive pas du tout à configurer, mon parefeu sur ma box, cela ne marche pas du tout, j'ai tout essayé, mais rien ne va. Je fais appel à vous car c'est un projet important dans le cadre de mes études. Je me tiens à votre entière disposition pour des questions et des informations
Last edited by senzo53 on Thu Jan 26, 2017 17:03, edited 1 time in total.
 

User avatar
fwhcat
Member
 
Posts: 15
Joined: Thu Aug 04, 2016 14:36
GitHub: fwhcat
IRC: fwhcat
In-game: fwhcat

Re: Problème installation serveur - Atelier Master

by fwhcat » Mon Jan 23, 2017 16:44

Bonjour senzo53.
Pour démarrer un serveur public, il te faut effectivement ouvrir un port sur ta box qui serait redirigé sur ta machine, le port à ouvrir est UDP, et par défaut pour minetest c'est le 30000 mais ça n'est pas une obligation.
Sinon, si tu n'as pas de serveur, reviens vers moi et je te proposerai un hébergement.
 

senzo53
New member
 
Posts: 9
Joined: Mon Jan 23, 2017 14:02

Re: Problème installation serveur - Atelier Master

by senzo53 » Mon Jan 23, 2017 21:57

Merci d'avoir répondu rapidement ^^
Je dois vous expliquer, le contexte, je veux ouvrir le serveur sur ma propre machine en fait pour pouvoir, le modifier etc. Or selon les structures auquel je serais confronté je veux pouvoir bénéficier d'un accès public sans avoir à configurer d'autorisation ex : école.

Pour vous dire où je suis bloqué. Actuellement j'ai réussi à lancer le serveur. J'ai créé une autorisation sur ma box pour le parefeu et pour le protocole DHCP pour les ports 30000 lié à mon adresse ip interne que j'ai rendu fixe. Je suis sur une Bbox.

En revanche, il m'est impossible de rejoindre le server, par l'accès public(internet) ou par l'accès local, depuis mon pc ou un de ceux branchés sur le réseau. En plus j'ai paumé le site qui expliquait comment rejoindre le serveur en local. Quand j'essaye de me connecter, le message suivant s'affiche : connection timed out.

Est ce que c'est un problème de parefeu interne ?

J'ai déjà eu ce problème d'accès public avec minecraft aussi. J'arrivais à gérer le serveur en local, mais impossible de me connecter par le biais d'internet, avec toujours le message : connection timed out. J'ai parcouru énormément de sites, et je n'ai jamais trouvé la solution à ce problème jusqu'à maintenant.

Encore merci :)
 

User avatar
fwhcat
Member
 
Posts: 15
Joined: Thu Aug 04, 2016 14:36
GitHub: fwhcat
IRC: fwhcat
In-game: fwhcat

Re: Problème installation serveur - Atelier Master

by fwhcat » Tue Jan 24, 2017 09:10

1) s'assurer que ta machine ait une adresse ip fixe assignée (le DHCP permet d'attribuer des ips fixes selon certaines adresses MAC, normalement).

2) Forwarder le port externe 30000 vers le port 30000 de ta machine, en TCP et UDP (il faut les 2 !)

3) bien lire http://wiki.minetest.net/Setting_up_a_server/fr
 

senzo53
New member
 
Posts: 9
Joined: Mon Jan 23, 2017 14:02

Re: Problème installation serveur - Atelier Master

by senzo53 » Wed Jan 25, 2017 16:20

Bonjour,
merci de votre réponse, j'ai eu une journée chargée hier

Donc j’ai forwardé le port externe 30000 vers le port 30000 de ma machine en tcp/udp. Je me suis assuré d’avoir attribué une adresse fixe via ma box.
Et j’ai vérifié le parefeu de ma box et j’ai bien mis une règle sur mon adresse qui autorise les connexions sur TCP et DUP.
Voici le debug de ce que j’ai quand je me suis connecté en local. Via 0.0.0.0.
2017-01-25 15:32:11: [Main]: Automatically selecting world at [C:\Users\Pierre-Louis\Desktop\minetest-0.4.14-win64\minetest-0.4.14\bin\..\worlds\Voila]
2017-01-25 15:32:11: WARNING[Main]: NodeDefManager: Ignoring CONTENT_IGNORE redefinition
2017-01-25 15:32:11: WARNING[Main]: Field "maxwear" is deprecated; replace with uses=1/maxwear
2017-01-25 15:32:11: WARNING[Main]: Field "maxwear" is deprecated; replace with uses=1/maxwear
2017-01-25 15:32:11: WARNING[Main]: Field "maxwear" is deprecated; replace with uses=1/maxwear
2017-01-25 15:32:11: ACTION[Main]: .__ __ __
2017-01-25 15:32:11: ACTION[Main]: _____ |__| ____ _____/ |_ ____ _______/ |_
2017-01-25 15:32:11: ACTION[Main]: / \| |/ \_/ __ \ __\/ __ \ / ___/\ __\
2017-01-25 15:32:11: ACTION[Main]: | Y Y \ | | \ ___/| | \ ___/ \___ \ | |
2017-01-25 15:32:11: ACTION[Main]: |__|_| /__|___| /\___ >__| \___ >____ > |__|
2017-01-25 15:32:11: ACTION[Main]: \/ \/ \/ \/ \/
2017-01-25 15:32:11: ACTION[Main]: World at [C:\Users\Pierre-Louis\Desktop\minetest-0.4.14-win64\minetest-0.4.14\bin\..\worlds\Voila]
2017-01-25 15:32:11: ACTION[Main]: Server for gameid="minetest" listening on 0.0.0.0:30000.


-------------
Separator
-------------

2017-01-25 15:32:29: [Main]: Automatically selecting world at [C:\Users\Pierre-Louis\Desktop\minetest-0.4.14-win64\minetest-0.4.14\bin\..\worlds\Voila]
2017-01-25 15:32:40: ACTION[Server]: John [127.0.0.1] joins game.
2017-01-25 15:32:40: ACTION[Server]: John joins game. List of players: John
2017-01-25 15:34:24: ACTION[Server]: John leaves game. List of players:

Pour ouvrir mes ports, sur ma machine, je suis allé dans les paramètres avancées des règle de parefeu, j’ai crée une nouvelle règle, j’ai choisi le protocole tcp, j’ai cliqué sur autoriser les connnexions. Et j’ai validé, j’ai refait la manip avec le protocole udp pour les règles de trafic entrant. Ensuite j’ai refait la manipulation pour les règles de trafic sortant.

Sur la box voici ce que j’ai concernat la redirection des ports : La règle "Minestest" redirige tous les protocoles pour les flux provenant de l'adresse IP 192.168.1.63 ayant le port 30000 de la bbox vers le port 30000 du périphérique 192.168.1.63.

Pour le pare feu de ma box voici ce que la règle dit : La règle "Minetest" autorise les paquets ayant le protocole TCP et UDP provenant de l'adresse IP 192.168.1.63 et le port 30000 vers l'adresse IP 192.168.1.63 et vers le port 30000. Est-ce bon ?

Pour le dhcp voilà ce qui est écris : attribution d’adresse statique : j’ai bien renseigné mon adresse map, j’ai choisi l’adresse ip statique que j’ai actuellement, et le l’equipement correspond au miens ?

Pourtant j’ai testé le port via : yougetsignal, et il me dis que le port est fermé via mon adresse ip. Pour tester le port j’ai tenté de me connecter à mon server via mon adresse IP externe sur minetest.
Et le message suivant s’affiche toujours : « connection timed out »

J’ai réussi à me connecter via mon adresse , j’ai relu toutes mes règles sur la box, et il semblait bien qu’il y avait une mauvaise correspondance de l’adresse ip inscrite dans les règles sur ma box et celle que j’avais actuellement.

en revanche quand j’ai essayé de me connecter avec un autre ordinateur de mon réseau et le serveur à planter impossible de lancer le serveur voila le debug pour re tester.

2017-01-25 17:10:44: [Main]: Automatically selecting world at [C:\Users\Pierre-Louis\Desktop\minetest-0.4.14-win64\minetest-0.4.14\bin\..\worlds\Voila]
2017-01-25 17:10:44: WARNING[Main]: NodeDefManager: Ignoring CONTENT_IGNORE redefinition
2017-01-25 17:10:44: WARNING[Main]: Field "maxwear" is deprecated; replace with uses=1/maxwear
2017-01-25 17:10:44: WARNING[Main]: Field "maxwear" is deprecated; replace with uses=1/maxwear
2017-01-25 17:10:44: WARNING[Main]: Field "maxwear" is deprecated; replace with uses=1/maxwear
2017-01-25 17:10:44: [ConnectionSend]: 136: Bind failed: No error
2017-01-25 17:10:44: ACTION[Main]: .__ __ __
2017-01-25 17:10:44: ACTION[Main]: _____ |__| ____ _____/ |_ ____ _______/ |_
2017-01-25 17:10:44: ACTION[Main]: / \| |/ \_/ __ \ __\/ __ \ / ___/\ __\
2017-01-25 17:10:44: ACTION[Main]: | Y Y \ | | \ ___/| | \ ___/ \___ \ | |
2017-01-25 17:10:44: ACTION[Main]: |__|_| /__|___| /\___ >__| \___ >____ > |__|
2017-01-25 17:10:44: ACTION[Main]: \/ \/ \/ \/ \/
2017-01-25 17:10:44: ACTION[Main]: World at [C:\Users\Pierre-Louis\Desktop\minetest-0.4.14-win64\minetest-0.4.14\bin\..\worlds\Voila]
2017-01-25 17:10:44: ACTION[Main]: Server for gameid="minetest" listening on 0.0.0.0:30000.
2017-01-25 17:10:44: ERROR[Main]: ServerError: Failed to bind socket (port already in use?)
 

User avatar
fwhcat
Member
 
Posts: 15
Joined: Thu Aug 04, 2016 14:36
GitHub: fwhcat
IRC: fwhcat
In-game: fwhcat

Re: Problème installation serveur - Atelier Master

by fwhcat » Wed Jan 25, 2017 21:22

Pour le pare feu de ma box voici ce que la règle dit : La règle "Minetest" autorise les paquets ayant le protocole TCP et UDP provenant de l'adresse IP 192.168.1.63 et le port 30000 vers l'adresse IP 192.168.1.63 et vers le port 30000. Est-ce bon ?


Non, il faut autoriser tout le monde à se connecter à ton port 30000, sinon seul toi pourra joindre ton serveur.
Donc: autoriser les adresses ip "Toutes" ou * sur le port 30000, et les redirigez vers 192.168.1.63 port 30000.
 

senzo53
New member
 
Posts: 9
Joined: Mon Jan 23, 2017 14:02

Re: Problème installation serveur - Atelier Master

by senzo53 » Wed Jan 25, 2017 21:32

Ok, je vais faire ça. Mais pourquoi je n'arrivais plus à lancer le serveur, depuis mon pc, est ce qu'il y a un rapport ?
 

senzo53
New member
 
Posts: 9
Joined: Mon Jan 23, 2017 14:02

Re: Problème installation serveur - Atelier Master

by senzo53 » Thu Jan 26, 2017 15:21

Ok, bon pour l'instant j'arrive à me connecter via mon pc sur mon adresse ip externe, et le serveur le plante pas donc cela à l'air presque bon. Mais j'ai une autre question, est ce qu'un autre pc de mon réseau local peut se connecter à mon serveur via l'adresse ip externe ? Car j'ai essayé mais le message m'affiche connection timed out.

merci :)
 

senzo53
New member
 
Posts: 9
Joined: Mon Jan 23, 2017 14:02

Re: Problème installation serveur - Atelier Master

by senzo53 » Thu Jan 26, 2017 15:50

J'ai vérifié et je peux me connecter à mon serveur via l'adresse locale depuis un autre ordinateur
 

senzo53
New member
 
Posts: 9
Joined: Mon Jan 23, 2017 14:02

Re: Problème installation serveur - Atelier Master

by senzo53 » Thu Jan 26, 2017 16:42

j'ai essayé de me connecter depuis mon téléphone et cela ne marche pas
 

senzo53
New member
 
Posts: 9
Joined: Mon Jan 23, 2017 14:02

Re: Problème installation serveur - Atelier Master

by senzo53 » Thu Jan 26, 2017 17:02

D'accord, j'ai effectué les vérifications sur ma box. Et j'avais mal configuré la box. j'avais mis une adresse externe sur la règle. Je suis vraiment déçu de l'interface de la Bbox qui n'explique rien du tout à la comparaison de la live_Box chez Orange.

j'ai testé la connexion via mon mobile et sur mon autre pc sur le réseau via l'adresse ip externe et c'est bon j'ai réussi à me connecter dessus. Donc c'est mission réussi je pense !

merci beaucoup pour votre aide. J'avais passé beaucoup de temps à chercher une solution sur internet via google et qwant et je n'avais rien trouvé. Donc je vous remercie d'avoir passé ce précieux temps à m'aider dans mon travail ! :)
 


Return to Français



Who is online

Users browsing this forum: No registered users and 1 guest