[Game] XaEnvironment 7.2 [xaenvironment]

CraftologieNatan
New member
Posts: 2
Joined: Fri May 15, 2020 11:12

Re: [Game] XaEnvironment 7.2 [xaenvironment]

by CraftologieNatan » Post

Hey,
I really like your subgame.

I got a few coredumps without me doing anything special in the latest minetest (5.1.1) version. Also my game crashed everytime when I placed a cmd block.

"AsyncErr: ServerThread::run Lua: Runtime error from mod 'exatec' in callback item_OnPlace(): Runtime error from mod 'exatec' in callback node_on_construct(): ...aver/.minetest/games/xaenvironment/mods/exatec/nodes.lua:1554: attempt to call global 'set_string' (a nil value)
stack traceback:
...aver/.minetest/games/xaenvironment/mods/exatec/nodes.lua:1554: in function <...aver/.minetest/games/xaenvironment/mods/exatec/nodes.lua:1553>
[C]: in function 'add_node'
/usr/share/games/minetest/builtin/game/item.lua:368: in function </usr/share/games/minetest/builtin/game/item.lua:258>
stack traceback:
[C]: in function 'add_node'
/usr/share/games/minetest/builtin/game/item.lua:368: in function </usr/share/games/minetest/builtin/game/item.lua:258>"
When standing on stone (not stone block, but the stone "object") the jump&climbe thingy doesnt work.

User avatar
AiTechEye
Member
Posts: 775
Joined: Fri May 29, 2015 21:14
GitHub: AiTechEye
Location: ¯\_(ツ)_/¯

Re: [Game] XaEnvironment 7.2 [xaenvironment]

by AiTechEye » Post

fixed the cmd (missing ":"), and in the last mt versions i fixed lots of random crashes caused by the mt engine, cuz objects randomly not returns their velocity, dont be suprised of it.

the wall climbing is an invisiable ladder block, it can only be placed in air, so if you light a torch (makes an light block) the climbing wont work, same in gas

User avatar
AiTechEye
Member
Posts: 775
Joined: Fri May 29, 2015 21:14
GitHub: AiTechEye
Location: ¯\_(ツ)_/¯

Re: [Game] XaEnvironment 7.2 [xaenvironment]

by AiTechEye » Post

finally the glowing stones are working and also spikes and drops, the spikes are traps and checking for targets.

are those lagging? i need to know.

try to explore the new caves and always looking over your head

Image
Attachments
screenshot_20200517_174942.png
(362.12 KiB) Not downloaded yet

User avatar
goats
Member
Posts: 19
Joined: Thu Nov 21, 2019 05:29

Re: [Game] XaEnvironment 7.2 [xaenvironment]

by goats » Post

Can you clarify: Which version(s) of the Minetest engine are needed for proper function of XaE current v7.2? Is the MT 5 & 5.01 the full and accurate list? Thanks!

(Several things do not work at all with MT 5.1, so i would hope to know if the answer is earlier 5.01 version or later 5.2 version. Too bad it is such an ordeal to keep multiple versions of anything such as MT on a Linux box.)

User avatar
AiTechEye
Member
Posts: 775
Joined: Fri May 29, 2015 21:14
GitHub: AiTechEye
Location: ¯\_(ツ)_/¯

Re: [Game] XaEnvironment 7.2 [xaenvironment]

by AiTechEye » Post

I dont know how any of the XaE versions works with mt versions (dont looking through logs and lists), just use the newest XaE version with the newest mt version.
But i should atleast tell what mt version the release is made with :)

i have been fixing lots of crashes caused by entities that randomly not returning their velocity.
the latest unreleased version is 99% bug-free and has lots of stuff added


im running win10 64, stuff just crashes in different os, i just keeps fixing bugs and adding stuff.
just report the errors you gets :)
Last edited by AiTechEye on Sat May 23, 2020 14:09, edited 1 time in total.

User avatar
Lone_Wolf
Member
Posts: 2326
Joined: Sun Apr 09, 2017 05:50
GitHub: LoneWolfHT
IRC: Lone_Wolf or LoneWolfHT
In-game: Lone_Wolf
Location: Not there, THERE!

Re: [Game] XaEnvironment 7.2 [xaenvironment]

by Lone_Wolf » Post

If an object doesn't return its velocity then I think it was removed or something similar. You need to use self when storing the object instead and check self.object for nil IIRC

User avatar
AiTechEye
Member
Posts: 775
Joined: Fri May 29, 2015 21:14
GitHub: AiTechEye
Location: ¯\_(ツ)_/¯

Re: [Game] XaEnvironment 7.2 [xaenvironment]

by AiTechEye » Post

it is caused in the mobs mainloop, not stored objects.
this bug didnt exist in mt 0.5

User avatar
goats
Member
Posts: 19
Joined: Thu Nov 21, 2019 05:29

Re: [Game] XaEnvironment 7.2 [xaenvironment]

by goats » Post

Thanks! I haven't had any crashes or errors logged. Just things like i cannot seem to shear a sheep, i get one-shot killed by birds hiding in grass (or on the seabed, lol), and for ages i could not get a rain barrel to work, but that finally did work since i posted. Maybe it was the surface the barrel was sitting on? (Dirt with grass vs. sand or a wooden roof of an npc house.) ¯\_㋡_/¯

User avatar
AiTechEye
Member
Posts: 775
Joined: Fri May 29, 2015 21:14
GitHub: AiTechEye
Location: ¯\_(ツ)_/¯

Re: [Game] XaEnvironment 7.2 [xaenvironment]

by AiTechEye » Post

sometimes wierd things happens, i often see white lines flashing on my screen,(maybe a glitshy model idk), i havent added some info about how things works yet, but you can shear a sheep if you gives it grass first.

just noticed & fixed a bug, the barrel should be filled after 30 s in rain but did only work when it was loaded

User avatar
goats
Member
Posts: 19
Joined: Thu Nov 21, 2019 05:29

Re: [Game] XaEnvironment 7.2 [xaenvironment]

by goats » Post

The barrels seemed to work fine as long i was in a properly rainy environment and the barrel was on the ground.

The sheep i finally managed to sheer. I had tried a few things before, but went back to persisting with the same methods until it worked. I just stocked up on default grass to keep trying. Like i had given up on bows before, but found out if i kept moving the bow to a different slot or trying at another time, eventually it loaded an arrow on left-click. (But if i change to a different activity, i usually have to repeat the process until the bow works again.)

I occasionally get a little screen tearing. The jungle grass certainly is visually weird, but i don't know if that is an intended effect or not. Bits close to the ground look as if they are moving. Maybe it is an effect of lots of overlapping textures?

Anyway, cool game, i'm having a lot of fun investigating it. The crates are a bit extreme with the craters they leave in the environment. Kind of on par with endermen in mcl2. :D Maybe a mobs griefing setting so they can damage/kill the player without such extreme damage to environmental nodes? It really adds up if you are hanging out in one area for an extended time. Been trying to kill them myself either over deep water or by chasing me and falling into a pit. But sometimes they pick a fight with a piranha or something and boom! :D :D

Seriously, though, it is a lot of fun.

User avatar
AiTechEye
Member
Posts: 775
Joined: Fri May 29, 2015 21:14
GitHub: AiTechEye
Location: ¯\_(ツ)_/¯

Re: [Game] XaEnvironment 7.2 [xaenvironment]

by AiTechEye » Post

Image
the bows works the opposite to mc, arrow left of bow
junglegrass: double size blocks, can fix the glitshy look later
crates: i have no idea why

and thanks for your response, it's very encouraging when you says what you think :)
Attachments
namnlö22s.gif
(941.06 KiB) Not downloaded yet

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests