Odd connection issues.

Post Reply
User avatar
DevFerret
New member
Posts: 5
Joined: Fri Dec 27, 2019 21:59
In-game: DevFerret

Odd connection issues.

by DevFerret » Post

I'm having a really weird problem whilist trying to run my server. I've done all the port forwarding and taken any neccesary steps to run and maintain my server. However, I can connect to my server once, and no other players can. Plus if I leave, I can't recconect. Both me and other players get to the "Connecting" phase and then get timed out for no apparent reason. I've searched the internet and forums for solutions but none seem very relevant, or at least don't have the answer to this problem. I want to start a public server and possibly play with friends and siblings, but I don't request any speedy help. Your time is more important than this. Thank you!
My profile picture is a ferret with a fadora; what could be better?

User avatar
Walker
Member
Posts: 1146
Joined: Tue Oct 03, 2017 09:22
In-game: Walker

Re: Odd connection issues.

by Walker » Post

first: pleas post you Minetest.conf here ( but blank all personly information )
second: can you ping you PC from the Internet ?
please show ( screenshot ) you Router-Port-Forwarding-Page

User avatar
DevFerret
New member
Posts: 5
Joined: Fri Dec 27, 2019 21:59
In-game: DevFerret

Re: Odd connection issues.

by DevFerret » Post

server_announce = false
server_name = Ferretville
server_address =
port = 30000
server_url = http://minetest.net
server_description = Join this amazing server!
motd = Welcome to this amazing minetest server!
enable_pvp = true
enable_damage = true
creative_mode = false
max_users = 15
enable_rollback_recording = true
mg_flags = trees, caves, v6_biome_blend, v6_jungles, dungeons
disallow_empty_password = true
static_spawnpoint = 0, 16, 0
that one?
My profile picture is a ferret with a fadora; what could be better?

User avatar
DevFerret
New member
Posts: 5
Joined: Fri Dec 27, 2019 21:59
In-game: DevFerret

Re: Odd connection issues.

by DevFerret » Post

I found this in minetest.conf.example.
# Timeout for client to remove unused map data from memory.
# type: int
# client_unload_unused_data_timeout = 600
My profile picture is a ferret with a fadora; what could be better?

Festus1965
Member
Posts: 1430
Joined: Sun Jan 03, 2016 11:58
In-game: bye bye

Re: Odd connection issues.

by Festus1965 » Post

* forwarding rules
Some Router need a restart to enable and work with set forwarding rules (like mine)
* login, relog
you need to check also server terminal what happen when you logout (is it shown in terminal) and main what happen when try relog (as is server see this, or not even got to this position - if not seen a try log here, the paket does not reach mtserver at all)
* ip
sure your "server_address = x.x.x.x" is set to the IP that is used forwarding and also available on the mts server as network connection ?
* client_unload_unused_data_timeout = 600 is no problem, as this is set or not, is just a caching feature, not important now.
Minetest has no future

User avatar
Walker
Member
Posts: 1146
Joined: Tue Oct 03, 2017 09:22
In-game: Walker

Re: Odd connection issues.

by Walker » Post

DevFerret wrote:server_announce = false
what ? do you wont that ? ... this mean that the server didnt show up in the server-list
DevFerret wrote:server_name = Ferretville
good
DevFerret wrote:server_address =
insert two "-" before the line or remove it
DevFerret wrote:port = 30000
good
DevFerret wrote:server_url = http://minetest.net
make no sense but is ok ^^
DevFerret wrote:server_description = Join this amazing server!
good
DevFerret wrote:motd = Welcome to this amazing minetest server!
also good
DevFerret wrote:enable_pvp = true
good too
DevFerret wrote:enable_damage = true
good
DevFerret wrote:creative_mode = false
good
DevFerret wrote:max_users = 15
very good for the begining
DevFerret wrote:enable_rollback_recording = true
safty ... good ^^
DevFerret wrote:mg_flags = trees, caves, v6_biome_blend, v6_jungles, dungeons
good
DevFerret wrote:disallow_empty_password = true
good
DevFerret wrote:static_spawnpoint = 0, 16, 0
good
DevFerret wrote:that one?
yes ^^

ok ... you schould by fin to connection from the lokal network and anyone who knows you ip ... but with server_announce = false you server didnt show up in the serverlist ... do you want that ?

and yes ... please send the log as well ( thanks Festus1965 ) ... or better the tail: cat debug.txt | tail -n 128 >debugtail.txt

User avatar
DevFerret
New member
Posts: 5
Joined: Fri Dec 27, 2019 21:59
In-game: DevFerret

Re: Odd connection issues.

by DevFerret » Post

I set the server announce to false so I can build the world with my aforementioned siblings before it goes public.

Debug.txt usually just looks like this:
2019-12-28 18:37:26: [Main]: Using world specified by --worldname on the command line
2019-12-28 18:37:27: ACTION[Main]: World at [C:\Users\*private*\Downloads\minetest-5.1.0-win64\minetest-5.1.0-win64\bin\..\worlds\Ferretville]
2019-12-28 18:37:27: ACTION[Main]: Server for gameid="minetest" listening on 0.0.0.0:30000.
2019-12-28 18:38:04: ACTION[Server]: Moving DevFerret to static spawnpoint at (0,16,0)
2019-12-28 18:38:04: ACTION[Server]: DevFerret [*Private IP Adress*] joins game.
2019-12-28 18:38:04: ACTION[Server]: DevFerret joins game. List of players: DevFerret
2019-12-28 18:38:05: ACTION[Server]: DevFerret damaged by 6 hp at (0,6.796,0)
2019-12-28 18:38:15: ACTION[Server]: DevFerret damaged by 3 hp at (14.31,2.37,-14.19)
2019-12-28 18:38:35: ACTION[Server]: DevFerret leaves game. List of players:
2019-12-28 18:38:53: ERROR[Main]: Connection timed out.
My profile picture is a ferret with a fadora; what could be better?

User avatar
DevFerret
New member
Posts: 5
Joined: Fri Dec 27, 2019 21:59
In-game: DevFerret

Re: Odd connection issues.

by DevFerret » Post

Ok so now I feel really stupid and I'm sorry for wasting everyone's time. Somehow I was using the incorrect ip (I was copy/pasting from IpKitten) but when I tried ipconfig I got a totally different IP that allowed me to reconnect/disconnect as many times as I want. What I don't understand is why the incorrect IP even worked at all. I have previously run Minetest servers (privately) in different locations before I moved so that might have something to do with it, but I doubt that.
My profile picture is a ferret with a fadora; what could be better?

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests