New Server

splaq
Member
 
Posts: 21
Joined: Tue Nov 29, 2011 06:49

New Server

by splaq » Tue Nov 29, 2011 06:56

I just put up a server if anyone is interested it's at squark.servegame.com port 30000.

Also looking for some information about generating the map. I'm only getting small resolutions (368x320) I'm curious how I can increase the resolution. [EDIT] Ok so I'm an idiot, The more of the map thats been viewed the more it displays in the created map image hence the larger resolution. here's the current map http://squark.servegame.com/map.png

ALSO What would be the best way to implement signups...Basicly what encryption does the password hash use? I looked through the source and I see the code for the password hash but C++ isn't my thing. I'm looking to implement signups via a webform and also thinking about creating a site that will hold server stats etc for any given time in PHP/JQuery.

[UPDATE] The server will update the map image every hour..or should if I setup the crontab correctly!
Last edited by splaq on Tue Nov 29, 2011 15:46, edited 1 time in total.
 

Derpy
New member
 
Posts: 2
Joined: Sun Nov 27, 2011 21:19

by Derpy » Tue Nov 29, 2011 21:53

At what times is the server up? I just tried connecting and I'm just getting connection timed out.
 

splaq
Member
 
Posts: 21
Joined: Tue Nov 29, 2011 06:49

by splaq » Tue Nov 29, 2011 23:56

It should be up now..Generally if you can get to http://squark.servegame.com you should be able to get into the game..I'll be home in about an hour(at school right now) and I can check to make sure it's up..But there are no times it should just BE up..I'll be making some mods to the server that it's on tonight and tomorrow to ensure I'll be able to keep the status good
 

splaq
Member
 
Posts: 21
Joined: Tue Nov 29, 2011 06:49

by splaq » Wed Nov 30, 2011 01:09

Yep, It crashed. It should be back up and running now..Apperantly I forgot to start it in the background and when I logged out in a hurry to head to school this morning I closed it.
 

User avatar
IPushButton2653
Member
 
Posts: 666
Joined: Wed Nov 16, 2011 22:47
Location: Mississippi

by IPushButton2653 » Wed Nov 30, 2011 03:09

awesome, its up, cant wait to make my house
 

splaq
Member
 
Posts: 21
Joined: Tue Nov 29, 2011 06:49

by splaq » Wed Nov 30, 2011 03:11

Enjoy, have fun with it..I'm really just testing to see how well it runs from my home connection or if I need to find better hosting for it...I have some friends with co-located server's so if I need to go that route I will but for now..yeah
 

splaq
Member
 
Posts: 21
Joined: Tue Nov 29, 2011 06:49

by splaq » Wed Nov 30, 2011 06:17

Ok, so I've been doing some configuring of the server tonight and have created two simple scripts that do are basicly helper scripts... One script just combines the genmap.py and minetestmapper.py scripts, creates the maps and save's it to a directory on your web server. The other script checks to see if the mintest server is running, if it's not then it will run it(there needs to be an active either attached or detached screen session running)..Setup both of these scripts on as cron jobs and it automates two tasks. 1. Updating the world map as often as you like(I set mine at 1 hour apart) and 2. KEEP THE SERVER RUNNING..I had this issue today. The two scripts are shell scripts for linux and will be posted below...

[genmap.sh]
#!/bin/sh

cd /directory/where/minetest-c55/util/ && /directory/where/minetest-c55/util/genmap.py && /directory/where/minetest-c55/utill/minetestmapper.py --output=/directory/of/webserver/www/map.png

Obviously you will need to change the directory structure to fit your needs..

[is_running.sh]
#!/bin/sh

if [ $(pidof minetestserver) ]
then
exit 0;
else
screen -dRR -X exec /directory/of/minetest-c55/bin/minetestserver
fi

[my crontab setup]
0 */1 * * * /directory/of/minetest-c55/util/genmap.sh #Run every hour
*/5 * * * * /directory/of/minetest-c55/util/is_running.sh #Run every 5 minutes to make sure server is still running if not make it run..

I'm sure these could be made a little nicer..But it's just something I threw together quick..I'm currently looking at other options I can add in to make it more robust as a server setup. Any suggestions are welcome
 

splaq
Member
 
Posts: 21
Joined: Tue Nov 29, 2011 06:49

by splaq » Wed Nov 30, 2011 06:28

Not tonight bro, Maybe tomorrow I'm heading off to bed with the wife
 

splaq
Member
 
Posts: 21
Joined: Tue Nov 29, 2011 06:49

by splaq » Wed Nov 30, 2011 21:07

Ok so my server is still up and running no issues so far..

I'm thinking about updating it to 0.4. My question is though, How many of you have 0.4 installed as clients and are looking for a 0.4 server to run on?
 

bwog
Member
 
Posts: 283
Joined: Wed Nov 30, 2011 14:09
Location: United States

by bwog » Wed Nov 30, 2011 21:16

I don't have 1.4.

I'll come on in a little bit.
 

bwog
Member
 
Posts: 283
Joined: Wed Nov 30, 2011 14:09
Location: United States

by bwog » Wed Nov 30, 2011 21:27

I found a weird object in a house:
Image

Whatever it is, it acts like a shovel.
 

splaq
Member
 
Posts: 21
Joined: Tue Nov 29, 2011 06:49

by splaq » Wed Nov 30, 2011 21:28

HAHA..oh yeah..that was me messing around with the user file trying to add a MesePick..Didn't work to well..So I just dumped it and left it there, but I thought I left it outside the house further inland.
Last edited by splaq on Wed Nov 30, 2011 21:29, edited 1 time in total.
 

splaq
Member
 
Posts: 21
Joined: Tue Nov 29, 2011 06:49

by splaq » Wed Nov 30, 2011 22:04

Made some improvements to the website http://squark.servegame.com it needs some visual enhancement but it functions. Shows the current map and the last time it was updated. Shows weather the server is up or not and a brief instruction about how to connect. Also a link to download MineTest-c55.
 

bwog
Member
 
Posts: 283
Joined: Wed Nov 30, 2011 14:09
Location: United States

by bwog » Wed Nov 30, 2011 22:07

You should come on, I've started on a lighthouse on the island the bridge connects to.
 

bwog
Member
 
Posts: 283
Joined: Wed Nov 30, 2011 14:09
Location: United States

by bwog » Sat Dec 03, 2011 16:10

Here's a cropped version of the map with labels:
Image

Ahhh... I messed up and forgot to put the Bwogland label up higher... just pretend it's pointing at the land all the way north.
 

Wolfgang
Member
 
Posts: 37
Joined: Thu Jun 23, 2011 11:21

by Wolfgang » Sun Dec 04, 2011 12:36

That server has the fastest griefers so far. I built a tower and came back after about 20 minutes to find it destroyed. :-(
Last edited by Wolfgang on Sun Dec 04, 2011 13:04, edited 1 time in total.
 

bwog
Member
 
Posts: 283
Joined: Wed Nov 30, 2011 14:09
Location: United States

by bwog » Sun Dec 04, 2011 14:04

Wolfgang wrote:That server has the fastest griefers so far. I built a tower and came back after about 20 minutes to find it destroyed. :-(

I haven't noticed any griefers. I should probably come on to make sure my stuff is still there.

EDIT: Dang it, they destroyed the house on my private island. Completely gone, even the dirt below it. At least they can't take locked chests.
Last edited by bwog on Sun Dec 04, 2011 14:07, edited 1 time in total.
 

SelfishCar
Member
 
Posts: 137
Joined: Sun Dec 04, 2011 12:22
Location: Sweden

by SelfishCar » Sun Dec 04, 2011 19:04

awesome server! I've build a floating castle with my friends on this server!
In-game Username: Axel
In-game Username #2: SelfishCar

SoLA: Part 1: Angela's Disappearance: http://minetest.net/forum/viewtopic.php?id=1586
 

bwog
Member
 
Posts: 283
Joined: Wed Nov 30, 2011 14:09
Location: United States

by bwog » Sun Dec 04, 2011 19:10

Griefers destroyed Lemming's home. Only suspect I have is a person named _ who joined and was chopping trees near his house.
 

User avatar
Menche
Member
 
Posts: 997
Joined: Sat Jul 02, 2011 00:43
Location: An island in a lava lake.
IRC: Menche
In-game: Menche

by Menche » Sun Dec 04, 2011 21:17

Someone completely demolished the house across the river from my house, then stole stuff from mine. I hope they had fun with the dungeon master in my basement.
An innocent kitten dies every time you top-post.
 

bwog
Member
 
Posts: 283
Joined: Wed Nov 30, 2011 14:09
Location: United States

by bwog » Sun Dec 04, 2011 21:19

Menche wrote:Someone completely demolished the house across the river from my house, then stole stuff from mine. I hope they had fun with the dungeon master in my basement.

If you use locked chests (Just put an iron bar in the middle when you create a chest) then they can't steal anything.
 

User avatar
Menche
Member
 
Posts: 997
Joined: Sat Jul 02, 2011 00:43
Location: An island in a lava lake.
IRC: Menche
In-game: Menche

by Menche » Sun Dec 04, 2011 22:47

I know, they didn't steal anything from the chests, they took out my brick floor and fences.
An innocent kitten dies every time you top-post.
 

User avatar
RAPHAEL
Member
 
Posts: 627
Joined: Tue Nov 01, 2011 09:09
Location: Earth

by RAPHAEL » Sun Dec 04, 2011 23:08

hmm, connected and seems a bit messed up... screenshot:
http://www1.picturepush.com/photo/a/7101459/img/7101459.png
"Before you speak, ask yourself: Is it kind, is it true, is it necessary, does it improve upon the silence?"
My mods: http://goo.gl/n4kpn
(Currently Various, Industrial, Fakeblocks, Jail, MoarCraft, Christmas, Replicator, minetest dev installer for linux, bash mod installer, windows mod installer)
 

bwog
Member
 
Posts: 283
Joined: Wed Nov 30, 2011 14:09
Location: United States

by bwog » Sun Dec 04, 2011 23:18

RAPHAEL wrote:hmm, connected and seems a bit messed up... screenshot:
http://www1.picturepush.com/photo/a/7101459/img/7101459.png

You're using 0.4, but the server isn't set up to be run with 0.4.

Hopefully splaq will give me some sort of way to ban people if necessary, or at least get rid of their build privileges.
 

User avatar
Menche
Member
 
Posts: 997
Joined: Sat Jul 02, 2011 00:43
Location: An island in a lava lake.
IRC: Menche
In-game: Menche

by Menche » Sun Dec 04, 2011 23:22

RAPHAEL wrote:hmm, connected and seems a bit messed up... screenshot:
http://www1.picturepush.com/photo/a/7101459/img/7101459.png

Are you connecting with 0.4? 0.4 clients expect textures to be sent to them by the server, and this is a 0.3 server which doesn't do that.
An innocent kitten dies every time you top-post.
 

Next

Return to Servers



Who is online

Users browsing this forum: No registered users and 5 guests