Game crashes on startup

Post Reply
User avatar
warmaster4z2
New member
Posts: 3
Joined: Mon Mar 04, 2013 01:51

Game crashes on startup

by warmaster4z2 » Post

I'm using lubuntu 12.04 and I download minetest using the software center. As soon as I click on the game icon a blank window appears and it immediately closes. This happens every time I've tried to open the game, I completely removed and reinstalled it but the same thing keeps happening. Could someone help me?

User avatar
VanessaE
Moderator
Posts: 4580
Joined: Sun Apr 01, 2012 12:38
GitHub: VanessaE
IRC: VanessaE
In-game: VanessaE
Location: Western NC
Contact:

by VanessaE » Post

Minetest as included in the Ubuntu repositories is out of date.

Compile it yourself from the git source code repository, or use the daily builds PPA.
You might like some of my stuff: Plantlife ~ More Trees ~ Home Decor ~ Pipeworks ~ HDX Textures (64-512px)

User avatar
0gb.us
Member
Posts: 841
Joined: Sun Sep 16, 2012 01:55
Location: 0gb.us:30000
Contact:

by 0gb.us » Post

Or use one of the official stable packages.

https://code.launchpad.net/~minetestdev ... /+packages

User avatar
warmaster4z2
New member
Posts: 3
Joined: Mon Mar 04, 2013 01:51

by warmaster4z2 » Post

I used this link to download the game http://www.youtube.com/watch?v=D9U0k_1H3eQ and it actually worked but it lags like crazy which is weird.

And once I enter the world it says "this is minimal development test game use [minetest game] for the real thing"

I thought I had the real thing, in my bin folder theres only one "minetest" executable file

User avatar
kaeza
Moderator
Posts: 2162
Joined: Thu Oct 18, 2012 05:00
GitHub: kaeza
IRC: kaeza diemartin blaaaaargh
In-game: kaeza
Location: Montevideo, Uruguay
Contact:

by kaeza » Post

Your signature is not the place for a blog post. Please keep it as concise as possible. Thank you!

Check out my stuff! | Donations greatly appreciated! PayPal

User avatar
metalfanat
New member
Posts: 1
Joined: Fri Mar 08, 2013 08:40

by metalfanat » Post

The game closes with a critical error. Note that this problem occurs when the path to the folder goes through Russian characters.
Image
If the game is on the C:\ drive, then there is no problem.

User avatar
rarkenin
Member
Posts: 668
Joined: Tue Nov 20, 2012 20:48

by rarkenin » Post

metalfanat wrote:The game closes with a critical error. Note that this problem occurs when the path to the folder goes through Russian characters.
Image
If the game is on the C:\ drive, then there is no problem.
There is a known issue dealing with non-latin characters. Perhaps LevelDB will fix this, just as a byproduct of its modified file access methods/
Admin pro tempore on 0gb.us:30000. Ask me if you have a problem, or just want help.
This is a signature virus. Add me to your signature so that I can multiply.
Now working on my own clone, Mosstest.
I guess I'm back for some time.

User avatar
warmaster4z2
New member
Posts: 3
Joined: Mon Mar 04, 2013 01:51

by warmaster4z2 » Post

kaeza's link solved my problem but now its lagging pretty bad, and on the top left corner it says something like:

Minetest 0.4.5
ERROR[main] generateTexture
ERROR[main] generateTexture
ERROR[main] generateTexture
ERROR[main] generateTexture
ERROR[main] generateTexture

User avatar
Topywo
Member
Posts: 1721
Joined: Fri May 18, 2012 20:27

by Topywo » Post

warmaster4z2 wrote:kaeza's link solved my problem but now its lagging pretty bad, and on the top left corner it says something like:

Minetest 0.4.5
ERROR[main] generateTexture
ERROR[main] generateTexture
ERROR[main] generateTexture
ERROR[main] generateTexture
ERROR[main] generateTexture
You can't do much against lagging. Sometimes it helps to not use certain heavier mods. Check also the viewing distance, toggle r on/off for maximum viewing distance or use + and - .

The ERROR[main] generate Texture might be a mod that misses some textures or can't find (wrong name) those in the textures folder or you deleted a mod with entities, for which it is looking for the textures. I don't know which one. At least it shouldn't be the texture atlas in 0.4.5.

If you can't figure out what is causing it, you can post the ERROR lines from the debug.txt in this topic. With 0.4.5 you'll need to delete your debug.txt first. Then put this line in the minetest.conf file: debug_log_level = 4 . Then restart your minetest game that caused the errors. Then post the ERROR-lines.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests